summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-10-21 12:24:19 +0000
committerJory Pratt <anarchy@gentoo.org>2010-10-21 12:24:19 +0000
commit102e7e9770c19af85fcc1476cace69a2ee8bf49c (patch)
treed3947ab3503922db2bebdf472a68c56e1b37caef /mail-client
parentAddress build failure with -alsa (diff)
downloadgentoo-2-102e7e9770c19af85fcc1476cace69a2ee8bf49c.tar.gz
gentoo-2-102e7e9770c19af85fcc1476cace69a2ee8bf49c.tar.bz2
gentoo-2-102e7e9770c19af85fcc1476cace69a2ee8bf49c.zip
Address build failure with -alsa
(Portage version: 2.1.9.20/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/ChangeLog6
-rw-r--r--mail-client/thunderbird/files/bug-606109.patch48
-rw-r--r--mail-client/thunderbird/thunderbird-3.1.5.ebuild4
3 files changed, 56 insertions, 2 deletions
diff --git a/mail-client/thunderbird/ChangeLog b/mail-client/thunderbird/ChangeLog
index 7fa2e891296c..19fc8de0abe1 100644
--- a/mail-client/thunderbird/ChangeLog
+++ b/mail-client/thunderbird/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/thunderbird
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.41 2010/10/21 07:47:05 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.42 2010/10/21 12:24:19 anarchy Exp $
+
+ 21 Oct 2010; Jory A. Pratt <anarchy@gentoo.org> thunderbird-3.1.5.ebuild,
+ +files/bug-606109.patch:
+ Address build failure with -alsa
21 Oct 2010; Lars Wendler <polynomial-c@gentoo.org>
thunderbird-3.1.5.ebuild:
diff --git a/mail-client/thunderbird/files/bug-606109.patch b/mail-client/thunderbird/files/bug-606109.patch
new file mode 100644
index 000000000000..57d9cd98cf61
--- /dev/null
+++ b/mail-client/thunderbird/files/bug-606109.patch
@@ -0,0 +1,48 @@
+# HG changeset patch
+# User Jory A. Pratt <anarchy@gentoo.org>
+# Parent 74e4421e0a30c6e21b594675e32a8d9d663c309c
+Add missing ifde MOZ_MEDIA
+
+diff --git a/content/base/src/nsContentSink.cpp b/content/base/src/nsContentSink.cpp
+--- a/mozilla/content/base/src/nsContentSink.cpp
++++ b/mozilla/content/base/src/nsContentSink.cpp
+@@ -1860,17 +1860,19 @@ nsIAtom** const kDefaultAllowedTags [] =
+ &nsGkAtoms::nobr,
+ &nsGkAtoms::noscript,
+ &nsGkAtoms::ol,
+ &nsGkAtoms::optgroup,
+ &nsGkAtoms::option,
+ &nsGkAtoms::output,
+ &nsGkAtoms::p,
+ &nsGkAtoms::pre,
++#ifdef MOZ_MEDIA
+ &nsGkAtoms::progress,
++#endif
+ &nsGkAtoms::q,
+ &nsGkAtoms::rp,
+ &nsGkAtoms::rt,
+ &nsGkAtoms::ruby,
+ &nsGkAtoms::s,
+ &nsGkAtoms::samp,
+ &nsGkAtoms::section,
+ &nsGkAtoms::select,
+@@ -1952,17 +1954,19 @@ nsIAtom** const kDefaultAllowedAttribute
+ &nsGkAtoms::itemref,
+ &nsGkAtoms::itemscope,
+ &nsGkAtoms::itemtype,
+ &nsGkAtoms::kind,
+ &nsGkAtoms::label,
+ &nsGkAtoms::lang,
+ &nsGkAtoms::list,
+ &nsGkAtoms::longdesc,
++#ifdef MOZ_MEDIA
+ &nsGkAtoms::loop,
++#endif
+ &nsGkAtoms::low,
+ &nsGkAtoms::max,
+ &nsGkAtoms::maxlength,
+ &nsGkAtoms::media,
+ &nsGkAtoms::min,
+ &nsGkAtoms::mozdonotsend,
+ &nsGkAtoms::method,
+ &nsGkAtoms::multiple,
diff --git a/mail-client/thunderbird/thunderbird-3.1.5.ebuild b/mail-client/thunderbird/thunderbird-3.1.5.ebuild
index 310eb84b6822..388aaea11f3a 100644
--- a/mail-client/thunderbird/thunderbird-3.1.5.ebuild
+++ b/mail-client/thunderbird/thunderbird-3.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-3.1.5.ebuild,v 1.2 2010/10/21 07:47:05 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-3.1.5.ebuild,v 1.3 2010/10/21 12:24:19 anarchy Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -114,6 +114,8 @@ src_prepare() {
EPATCH_FORCE="yes" \
epatch "${WORKDIR}"
+ epatch "${FILESDIR}/bug-606109.patch"
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user