summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-03-06 13:20:21 +0000
committerEray Aslan <eras@gentoo.org>2013-03-06 13:20:21 +0000
commit0b9a3cee71dab5b001fcc960233b0227161ffbd5 (patch)
treebe19fafe94040c9d5164e53e4a1dedcc7a8e9e0d /mail-client
parentMigrate to python-r1. (diff)
downloadgentoo-2-0b9a3cee71dab5b001fcc960233b0227161ffbd5.tar.gz
gentoo-2-0b9a3cee71dab5b001fcc960233b0227161ffbd5.tar.bz2
gentoo-2-0b9a3cee71dab5b001fcc960233b0227161ffbd5.zip
Fix building with ncurses[tinfo] - bug #460506
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/hap/ChangeLog8
-rw-r--r--mail-client/hap/files/hap-3.7-ncurses.patch14
-rw-r--r--mail-client/hap/hap-3.7-r1.ebuild8
3 files changed, 24 insertions, 6 deletions
diff --git a/mail-client/hap/ChangeLog b/mail-client/hap/ChangeLog
index 9520e5cd5733..2ca3690bfc89 100644
--- a/mail-client/hap/ChangeLog
+++ b/mail-client/hap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/hap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.14 2012/11/15 15:16:48 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.15 2013/03/06 13:20:21 eras Exp $
+
+ 06 Mar 2013; Eray Aslan <eras@gentoo.org> +files/hap-3.7-ncurses.patch,
+ hap-3.7-r1.ebuild:
+ Fix building with ncurses[tinfo] - bug #460506
15 Nov 2012; Agostino Sarubbo <ago@gentoo.org> hap-3.7-r1.ebuild:
Add ~amd64, wrt bug #443416
diff --git a/mail-client/hap/files/hap-3.7-ncurses.patch b/mail-client/hap/files/hap-3.7-ncurses.patch
new file mode 100644
index 000000000000..1ae79b9e9810
--- /dev/null
+++ b/mail-client/hap/files/hap-3.7-ncurses.patch
@@ -0,0 +1,14 @@
+--- configure.in 1996-07-17 00:50:03.000000000 +0300
++++ configure.in 2013-03-06 15:09:29.579148360 +0200
+@@ -6,8 +6,9 @@
+ AC_PROG_INSTALL
+
+ dnl Checks for libraries.
+-dnl Replace `main' with a function in -ltermcap:
+-AC_CHECK_LIB(termcap, tputs)
++dnl Replace `main' with a function in -lncurses or -ltinfo
++AC_CHECK_LIB(ncurses, tputs,,
++ [AC_CHECK_LIB(tinfo, tputs)])
+
+ dnl Checks for header files.
+ AC_CHECK_HEADERS(sgtty.h unistd.h libc.h termcap.h strings.h string.h dirent.h sys/ioctl.h)
diff --git a/mail-client/hap/hap-3.7-r1.ebuild b/mail-client/hap/hap-3.7-r1.ebuild
index ada6c1460e84..7138bcd50a80 100644
--- a/mail-client/hap/hap-3.7-r1.ebuild
+++ b/mail-client/hap/hap-3.7-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7-r1.ebuild,v 1.7 2012/11/15 15:16:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7-r1.ebuild,v 1.8 2013/03/06 13:20:21 eras Exp $
EAPI=4
-inherit autotools
+inherit autotools eutils
DESCRIPTION="A terminal mail notification program (replacement for biff)"
HOMEPAGE="http://www.transbay.net/~enf/sw.html"
@@ -22,7 +22,7 @@ S="${WORKDIR}/${PN}"
src_prepare() {
# Fix configure to use ncurses instead of termcap (bug #103105)
- sed -i -e '/AC_CHECK_LIB/s~termcap~ncurses~' configure.in || die
+ epatch "${FILESDIR}/${P}-ncurses.patch"
# Fix Makefile.in to use our CFLAGS and LDFLAGS
sed -i -e "s/^CFLAGS=-O/CFLAGS=${CFLAGS}/" \