summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-07-22 09:50:38 +0000
committerHans de Graaff <graaff@gentoo.org>2008-07-22 09:50:38 +0000
commit0a1242667d929c0ef6a32917366d99115be36c5e (patch)
tree4dde31d224e64450c9112d0f2f84459ede3a0bf9 /mail-client
parentVersion bump (diff)
downloadgentoo-2-0a1242667d929c0ef6a32917366d99115be36c5e.tar.gz
gentoo-2-0a1242667d929c0ef6a32917366d99115be36c5e.tar.bz2
gentoo-2-0a1242667d929c0ef6a32917366d99115be36c5e.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/ChangeLog10
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.4-dont-update-cache.patch25
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch33
-rw-r--r--mail-client/mail-notification/mail-notification-5.4.ebuild92
4 files changed, 159 insertions, 1 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index cfcd6f9ff33b..6078b2e3cd92 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.69 2008/05/03 06:19:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.70 2008/07/22 09:50:37 graaff Exp $
+
+*mail-notification-5.4 (22 Jul 2008)
+
+ 22 Jul 2008; Hans de Graaff <graaff@gentoo.org>
+ +files/mail-notification-5.4-dont-update-cache.patch,
+ +files/mail-notification-5.4-remove-ubuntu-special-case.patch,
+ +mail-notification-5.4.ebuild:
+ Version bump: fix regression for IMAP mailboxes. Also attempt to fix #215281.
03 May 2008; Hans de Graaff <graaff@gentoo.org>
mail-notification-5.0.ebuild, mail-notification-5.0-r1.ebuild:
diff --git a/mail-client/mail-notification/files/mail-notification-5.4-dont-update-cache.patch b/mail-client/mail-notification/files/mail-notification-5.4-dont-update-cache.patch
new file mode 100644
index 000000000000..6cdade158a71
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-5.4-dont-update-cache.patch
@@ -0,0 +1,25 @@
+Our gnome2 eclass takes care of proper rebuilding on the icon
+cache. We have to remove this also because it causes access
+violations.
+--- jbsrc/jb.c.~1~ 2008-03-20 16:53:02.000000000 +0100
++++ jbsrc/jb.c 2008-03-26 20:51:45.641363619 +0100
+@@ -327,7 +327,6 @@
+ jb_package_add_resources (void)
+ {
+ JBGroup *group;
+- JBRule *rule;
+ JBObject *object;
+
+ if (jb_variable_get_bool("compile-warnings"))
+@@ -362,11 +361,6 @@
+ if (jb_variable_get_bool("hotmail"))
+ jb_group_add_data_file(group, "hotmail.png", "$pkgdatadir");
+
+- rule = jb_rule_new();
+- jb_rule_set_install_message(rule, "updating the GTK+ icon cache");
+- jb_rule_add_install_command(rule, "-gtk-update-icon-cache -f -t $datadir/icons/hicolor");
+- jb_group_add_resource(group, JB_GROUP_RESOURCE(rule));
+-
+ jb_group_add(group);
+
+ /*** data ******************************************************************/
diff --git a/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch b/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch
new file mode 100644
index 000000000000..4516f32c6f52
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-5.4-remove-ubuntu-special-case.patch
@@ -0,0 +1,33 @@
+--- jbsrc/lib/src/core/jb-feature.c.~1~ 2008-04-27 16:47:27.000000000 +0200
++++ jbsrc/lib/src/core/jb-feature.c 2008-07-22 11:40:50.856886210 +0200
+@@ -164,8 +164,6 @@
+ static void
+ gconf_configure (void)
+ {
+- JBVariable *variable;
+-
+ jb_require_program("gconftool-2");
+
+ if (! strcmp(jb_variable_get_string("gconf-config-source"), "autodetect"))
+@@ -178,21 +176,6 @@
+ jb_variable_set_string("gconf-config-source", config_source);
+ g_free(config_source);
+ }
+-
+- /* fix the default schemas dir on Ubuntu */
+- variable = jb_variable_get_variable_or_error("gconf-schemas-dir");
+- if (! variable->user_set)
+- {
+- static const char *ubuntu_dir = "$datadir/gconf/schemas";
+- char *expanded;
+-
+- expanded = jb_variable_expand(ubuntu_dir, NULL);
+-
+- if (g_file_test(expanded, G_FILE_TEST_IS_DIR))
+- jb_variable_set_string("gconf-schemas-dir", ubuntu_dir);
+-
+- g_free(expanded);
+- }
+ }
+
+ static void
diff --git a/mail-client/mail-notification/mail-notification-5.4.ebuild b/mail-client/mail-notification/mail-notification-5.4.ebuild
new file mode 100644
index 000000000000..7933e1c860bf
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4.ebuild,v 1.1 2008/07/22 09:50:37 graaff Exp $
+
+inherit gnome2 multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="evo gmail imap ipv6 maildir mbox mh mozilla pop sasl ssl sylpheed yahoo"
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/glib-2.14
+ >=gnome-base/gconf-2.4.0
+ >=gnome-base/gnome-panel-2.6
+ >=gnome-base/eel-2.6
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2.0
+ dev-libs/dbus-glib
+ >=dev-libs/gmime-2.2.7
+ >=x11-libs/libnotify-0.4.1
+ pop? ( gnome-base/gnome-keyring )
+ imap? ( gnome-base/gnome-keyring )
+ gmail? ( gnome-base/gnome-keyring )
+ yahoo? ( gnome-base/gnome-keyring net-mail/fetchyahoo )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evo? ( >=mail-client/evolution-2.12 )
+ sylpheed? ( virtual/sylpheed )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
+# instead of autotools, this is a little helper function that basically does
+# the same thing as use_enable
+use_var() {
+ echo -n "${2:-$1}="
+ use "${1}" && echo "yes" || echo "no"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-dont-update-cache.patch"
+
+ # We are not Ubuntu, and I suspect that this is the cause of #215281
+ epatch "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
+}
+
+src_compile() {
+ ./jb configure destdir="${D}" prefix="/usr" libdir=/usr/$(get_libdir) \
+ sysconfdir="/etc" localstatedir="/var" cc="$(tc-getCC)" \
+ cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
+ scrollkeeper-dir="/var/lib/scrollkeeper" \
+ $(use_var evo evolution) \
+ $(use_var gmail) \
+ $(use_var imap) \
+ $(use_var ipv6) \
+ $(use_var maildir) \
+ $(use_var mbox) \
+ $(use_var mh) \
+ $(use_var mozilla) \
+ $(use_var pop pop3) \
+ $(use_var sasl) \
+ $(use_var ssl) \
+ $(use_var sylpheed) \
+ $(use_var yahoo)
+
+ ./jb build
+}
+
+src_install() {
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install
+
+ dodoc NEWS README AUTHORS TODO TRANSLATING
+
+ rm -rf "${D}/var/lib/scrollkeeper"
+}