summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-11-26 19:05:00 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-11-26 19:05:00 +0000
commit044786e128821c0e9452d02ca21975c8fcf9d23d (patch)
treeb6538c0a878388898c7c2431992247376e91413f /mail-client
parentVersion bump (bug #294497). (diff)
downloadgentoo-2-044786e128821c0e9452d02ca21975c8fcf9d23d.tar.gz
gentoo-2-044786e128821c0e9452d02ca21975c8fcf9d23d.tar.bz2
gentoo-2-044786e128821c0e9452d02ca21975c8fcf9d23d.zip
Fix crash when adding a new task or memo, per bug #294436
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/ChangeLog9
-rw-r--r--mail-client/evolution/evolution-2.28.1-r1.ebuild157
-rw-r--r--mail-client/evolution/files/evolution-2.28.1-new-task-sigsegv.patch30
3 files changed, 195 insertions, 1 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index ad5ee04f86da..3da5169926fc 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/evolution
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.280 2009/11/02 21:36:30 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.281 2009/11/26 19:05:00 mrpouet Exp $
+
+*evolution-2.28.1-r1 (26 Nov 2009)
+
+ 26 Nov 2009; Romain Perier <mrpouet@gentoo.org>
+ +evolution-2.28.1-r1.ebuild,
+ +files/evolution-2.28.1-new-task-sigsegv.patch:
+ Fix crash when adding a new task or memo, per bug #294436.
02 Nov 2009; Gilles Dartiguelongue <eva@gentoo.org>
evolution-2.28.1.ebuild:
diff --git a/mail-client/evolution/evolution-2.28.1-r1.ebuild b/mail-client/evolution/evolution-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..1c0e8bfe1942
--- /dev/null
+++ b/mail-client/evolution/evolution-2.28.1-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.28.1-r1.ebuild,v 1.1 2009/11/26 19:05:00 mrpouet Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools gnome2 flag-o-matic python
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt dbus hal kerberos krb4 ldap mono networkmanager nntp pda profile python ssl gstreamer exchange"
+# pst
+
+# Pango dependency required to avoid font rendering problems
+# We need a graphical pinentry frontend to be able to ask for the GPG
+# password from inside evolution, bug 160302
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.16
+ >=gnome-extra/evolution-data-server-${PV}
+ >=x11-themes/gnome-icon-theme-2.20
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libbonoboui-2.4.2
+ >=gnome-extra/gtkhtml-3.27.90
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomecanvas-2
+ >=gnome-base/libgnomeui-2
+ >=dev-libs/libxml2-2.7.3
+ >=dev-libs/libgweather-2.25.3
+ >=x11-misc/shared-mime-info-0.22
+ >=gnome-base/gnome-desktop-2.26.0
+ dbus? ( >=dev-libs/dbus-glib-0.74 )
+ hal? ( >=sys-apps/hal-0.5.4 )
+ x11-libs/libnotify
+ pda? (
+ >=app-pda/gnome-pilot-2.0.15
+ >=app-pda/gnome-pilot-conduits-2 )
+ dev-libs/atk
+ ssl? (
+ >=dev-libs/nspr-4.6.1
+ >=dev-libs/nss-3.11 )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ >=net-libs/libsoup-2.4
+ kerberos? ( virtual/krb5 )
+ krb4? ( app-crypt/mit-krb5[krb4] )
+ >=gnome-base/orbit-2.9.8
+ crypt? ( || (
+ ( >=app-crypt/gnupg-2.0.1-r2
+ || ( app-crypt/pinentry[gtk] app-crypt/pinentry[qt3] ) )
+ =app-crypt/gnupg-1.4* ) )
+ ldap? ( >=net-nds/openldap-2 )
+ mono? ( >=dev-lang/mono-1 )
+ python? ( >=dev-lang/python-2.4 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10 )"
+# Disabled until API stabilizes
+# pst? ( >=net-mail/libpst-0.6.41 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.16
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ sys-devel/bison
+ app-text/scrollkeeper
+ >=gnome-base/gnome-common-2.12.0
+ >=app-text/gnome-doc-utils-0.9.1"
+
+PDEPEND="exchange? ( >=gnome-extra/evolution-exchange-2.26.1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS* README"
+ELTCONF="--reverse-deps"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --without-kde-applnk-path
+ --enable-plugins=experimental
+ --with-weather
+ $(use_enable ssl nss)
+ $(use_enable ssl smime)
+ $(use_enable mono)
+ $(use_enable nntp)
+ $(use_enable networkmanager nm)
+ $(use_enable dbus)
+ $(use_enable gstreamer audio-inline)
+ $(use_enable exchange)
+ --disable-pst-import
+ $(use_enable pda pilot-conduits)
+ $(use_enable profile profiling)
+ $(use_enable python)
+ $(use_with ldap openldap)
+ $(use_with kerberos krb5 /usr)
+ $(use_with krb4 krb4 /usr)"
+
+ # dang - I've changed this to do --enable-plugins=experimental. This will
+ # autodetect new-mail-notify and exchange, but that cannot be helped for the
+ # moment. They should be changed to depend on a --enable-<foo> like mono
+ # is. This cleans up a ton of crap from this ebuild.
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix timezone offsets on fbsd. bug #183708
+ # FIXME: bsd needs to be more active at pushing stuff upstream
+ #epatch "${FILESDIR}/${PN}-2.21.3-fbsd.patch"
+
+ # Fix delete keyboard shortcut, bug #????
+ epatch "${FILESDIR}/${PN}-2.28.0-delete-key.patch"
+
+ # Fix multiple automagic plugins, bug #204300 & bug #271451
+ epatch "${FILESDIR}/${PN}-2.28.0-automagic-plugins.patch"
+
+ # Fix crash when adding a new task or memo, bug #294436,
+ # patch import from upstream bug #599627. WILL NOT needed for 2.28.2.
+ epatch "${FILESDIR}/${P}-new-task-sigsegv.patch"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ sed -i -e "s|mozilla-nss|nss|
+ s|mozilla-nspr|nspr|" "${S}"/configure || die "sed 1 failed"
+ G2CONF="${G2CONF} --enable-nss=yes"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # problems with -O3 on gcc-3.3.1
+ replace-flags -O3 -O2
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "To change the default browser if you are not using GNOME, do:"
+ elog "gconftool-2 --set /desktop/gnome/url-handlers/http/command -t string 'mozilla %s'"
+ elog "gconftool-2 --set /desktop/gnome/url-handlers/https/command -t string 'mozilla %s'"
+ elog ""
+ elog "Replace 'mozilla %s' with which ever browser you use."
+ elog ""
+ elog "Junk filters are now a run-time choice. You will get a choice of"
+ elog "bogofilter or spamassassin based on which you have installed"
+ elog ""
+ elog "You have to install one of these for the spam filtering to actually work"
+}
diff --git a/mail-client/evolution/files/evolution-2.28.1-new-task-sigsegv.patch b/mail-client/evolution/files/evolution-2.28.1-new-task-sigsegv.patch
new file mode 100644
index 000000000000..f7fb5c806577
--- /dev/null
+++ b/mail-client/evolution/files/evolution-2.28.1-new-task-sigsegv.patch
@@ -0,0 +1,30 @@
+From 571670cab5a6564ca560dbe0606b0b008906e992 Mon Sep 17 00:00:00 2001
+From: C de-Avillez <hggdh2@gmail.com>
+Date: Tue, 03 Nov 2009 14:05:11 +0000
+Subject: Bug #599627 - Crash when adding a new task in a table
+
+---
+diff --git a/calendar/gui/e-cal-model.c b/calendar/gui/e-cal-model.c
+index 490c48c..b212dcf 100644
+--- a/calendar/gui/e-cal-model.c
++++ b/calendar/gui/e-cal-model.c
+@@ -913,15 +913,11 @@ ecm_append_row (ETableModel *etm, ETableModel *source, gint row)
+ g_warning (G_STRLOC ": Could not create the object!");
+
+ /* FIXME: show error dialog */
+- icalcomponent_free (comp_data->icalcomp);
+- g_object_unref (comp_data);
+- return;
++ } else {
++ g_signal_emit (G_OBJECT (model), signals[ROW_APPENDED], 0);
+ }
+
+- icalcomponent_free (comp_data->icalcomp);
+ g_object_unref (comp_data);
+-
+- g_signal_emit (G_OBJECT (model), signals[ROW_APPENDED], 0);
+ }
+
+ static gpointer
+--
+cgit v0.8.2