summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-04-28 10:15:19 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-04-28 10:15:19 +0000
commit9e0d5a93cc0cea0d45d0a9e586ebf2b0c965427f (patch)
tree6a9d213b63de21e0cb32105af7c72c1f25e85720 /mail-client/sylpheed
parentRedigest for vmware-any-any109 and fix rc file for baselayout-2. (diff)
downloadgentoo-2-9e0d5a93cc0cea0d45d0a9e586ebf2b0c965427f.tar.gz
gentoo-2-9e0d5a93cc0cea0d45d0a9e586ebf2b0c965427f.tar.bz2
gentoo-2-9e0d5a93cc0cea0d45d0a9e586ebf2b0c965427f.zip
new upstream release.
(Portage version: 2.1.2.2)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.4.03
-rw-r--r--mail-client/sylpheed/sylpheed-2.4.0.ebuild70
3 files changed, 79 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 236747e69b43..3730275c3187 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.218 2007/04/01 12:59:06 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.219 2007/04/28 10:15:19 hattya Exp $
+
+*sylpheed-2.4.0 (28 Apr 2007)
+
+ 28 Apr 2007; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.4.0.ebuild:
+ new upstream release.
01 Apr 2007; Akinori Hattori <hattya@gentoo.org> sylpheed-2.2.7.ebuild,
sylpheed-2.3.0.ebuild, sylpheed-2.3.1.ebuild:
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.4.0 b/mail-client/sylpheed/files/digest-sylpheed-2.4.0
new file mode 100644
index 000000000000..c1bc0aca93d0
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.4.0
@@ -0,0 +1,3 @@
+MD5 217a13624e92b8a1b4ee3025b51d7c2b sylpheed-2.4.0.tar.bz2 2728460
+RMD160 c5dad0127c00fd1b8413f0fe7e3588c2aba3d608 sylpheed-2.4.0.tar.bz2 2728460
+SHA256 eaf52529ea6b92e4d5d6f6e397747cb67274aac1e8a5c96a6e3ba8fa12993020 sylpheed-2.4.0.tar.bz2 2728460
diff --git a/mail-client/sylpheed/sylpheed-2.4.0.ebuild b/mail-client/sylpheed/sylpheed-2.4.0.ebuild
new file mode 100644
index 000000000000..aca82c497f7c
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.4.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.4.0.ebuild,v 1.1 2007/04/28 10:15:19 hattya Exp $
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ eautomake
+ elibtoolize
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable crypt gpgme` \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable spell gtkspell` \
+ `use_enable ssl` \
+ `use_enable xface compface` \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+}