summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-12 17:41:57 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-12 17:41:57 +0000
commitf960b03f004e1b5debe52934977e8c903e6c63b7 (patch)
treea464d7ca5d80f31c4be0d5652dfdc09ca7e2e45f /mail-client/roundcube
parentVersion bump, bug 405153. Thanks to Michael (kensington) for the patch and th... (diff)
downloadgentoo-2-f960b03f004e1b5debe52934977e8c903e6c63b7.tar.gz
gentoo-2-f960b03f004e1b5debe52934977e8c903e6c63b7.tar.bz2
gentoo-2-f960b03f004e1b5debe52934977e8c903e6c63b7.zip
Version bump.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog7
-rw-r--r--mail-client/roundcube/roundcube-0.7.2.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 15e2e9446711..7d826a04e0a4 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.73 2012/03/09 11:55:24 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.74 2012/03/12 17:41:57 radhermit Exp $
+
+*roundcube-0.7.2 (12 Mar 2012)
+
+ 12 Mar 2012; Tim Harder <radhermit@gentoo.org> +roundcube-0.7.2.ebuild:
+ Version bump.
*roundcube-0.8_beta (09 Mar 2012)
diff --git a/mail-client/roundcube/roundcube-0.7.2.ebuild b/mail-client/roundcube/roundcube-0.7.2.ebuild
new file mode 100644
index 000000000000..5333b1e1dc9c
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.7.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.7.2.ebuild,v 1.1 2012/03/12 17:41:57 radhermit Exp $
+
+EAPI="4"
+
+inherit webapp
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres ssl spell +sqlite"
+
+RDEPEND="virtual/httpd-php
+ >=dev-lang/php-5.3[crypt,gd,iconv,json,ldap?,postgres?,session,sqlite?,sockets,ssl?,xml,unicode]
+ mysql? (
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )
+ || ( dev-php/PEAR-MDB2_Driver_mysql dev-php/PEAR-MDB2_Driver_mysqli )
+ )
+ postgres? ( dev-php/PEAR-MDB2_Driver_pgsql )
+ spell? ( dev-lang/php[curl,spell] )
+ sqlite? ( dev-php/PEAR-MDB2_Driver_sqlite )
+ >=dev-php/PEAR-MDB2-2.5.0_beta3
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Auth_SASL-1.0.3"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cp config/db.inc.php{.dist,} || die
+ cp config/main.inc.php{.dist,} || die
+
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Mail,MDB2*,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.6.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en-0.6.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}