summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-18 04:27:51 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-18 04:27:51 +0000
commitb07da5f231cd15a991d599e4bce4f862b696bc3a (patch)
tree9c9c19d8f42daafa301d1ab85028099a4dc4fb1d /mail-client/roundcube
parentRemove libz/libminizip static files by name to avoid deleting files for targe... (diff)
downloadgentoo-2-b07da5f231cd15a991d599e4bce4f862b696bc3a.tar.gz
gentoo-2-b07da5f231cd15a991d599e4bce4f862b696bc3a.tar.bz2
gentoo-2-b07da5f231cd15a991d599e4bce4f862b696bc3a.zip
Version bumps.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog9
-rw-r--r--mail-client/roundcube/roundcube-0.7.3.ebuild63
-rw-r--r--mail-client/roundcube/roundcube-0.8.1.ebuild63
3 files changed, 134 insertions, 1 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index 65a9ffc12c5c..97203e527b60 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.84 2012/08/10 17:50:10 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.85 2012/08/18 04:27:51 radhermit Exp $
+
+*roundcube-0.8.1 (18 Aug 2012)
+*roundcube-0.7.3 (18 Aug 2012)
+
+ 18 Aug 2012; Tim Harder <radhermit@gentoo.org> +roundcube-0.7.3.ebuild,
+ +roundcube-0.8.1.ebuild:
+ Version bumps.
10 Aug 2012; Tim Harder <radhermit@gentoo.org> -roundcube-0.7.1.ebuild,
-roundcube-0.8_rc.ebuild:
diff --git a/mail-client/roundcube/roundcube-0.7.3.ebuild b/mail-client/roundcube/roundcube-0.7.3.ebuild
new file mode 100644
index 000000000000..fc24a0e6a0a9
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.7.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.7.3.ebuild,v 1.1 2012/08/18 04:27:51 radhermit Exp $
+
+EAPI="4"
+
+inherit webapp
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap +mysql postgres ssl spell"
+
+RDEPEND="virtual/httpd-php
+ >=dev-lang/php-5.3[crypt,gd,iconv,json,ldap?,postgres?,session,sockets,ssl?,xml,unicode]
+ mysql? (
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )
+ || ( dev-php/PEAR-MDB2_Driver_mysql dev-php/PEAR-MDB2_Driver_mysqli )
+ )
+ postgres? ( dev-php/PEAR-MDB2_Driver_pgsql )
+ spell? ( dev-lang/php[curl,spell] )
+ >=dev-php/PEAR-MDB2-2.5.0_beta3
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Auth_SASL-1.0.3"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,} || die
+ cp config/main.inc.php{.dist,} || die
+
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Mail,MDB2*,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.6.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en-0.6.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}
diff --git a/mail-client/roundcube/roundcube-0.8.1.ebuild b/mail-client/roundcube/roundcube-0.8.1.ebuild
new file mode 100644
index 000000000000..dcb681278b21
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.8.1.ebuild,v 1.1 2012/08/18 04:27:51 radhermit Exp $
+
+EAPI="4"
+
+inherit webapp
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV/_/-}"
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap +mysql postgres ssl spell"
+
+RDEPEND="virtual/httpd-php
+ >=dev-lang/php-5.3[crypt,gd,iconv,json,ldap?,postgres?,session,sockets,ssl?,xml,unicode]
+ mysql? (
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )
+ || ( dev-php/PEAR-MDB2_Driver_mysql dev-php/PEAR-MDB2_Driver_mysqli )
+ )
+ postgres? ( dev-php/PEAR-MDB2_Driver_pgsql )
+ spell? ( dev-lang/php[curl,spell] )
+ >=dev-php/PEAR-MDB2-2.5.0_beta3
+ >=dev-php/PEAR-Mail_Mime-1.8.1
+ >=dev-php/PEAR-Net_SMTP-1.4.2
+ >=dev-php/PEAR-Net_IDNA2-0.1.1
+ >=dev-php/PEAR-Auth_SASL-1.0.3"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp config/db.inc.php{.dist,} || die
+ cp config/main.inc.php{.dist,} || die
+
+ # Remove bundled PEAR packages
+ rm -r program/lib/{Auth,Mail,MDB2*,Net,PEAR*} || die
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.6.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en-0.6.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}