summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-09-07 19:12:25 +0000
committerFabian Groffen <grobian@gentoo.org>2009-09-07 19:12:25 +0000
commitf3fc40ea299e9c120878c2ca7c0a14cb881da1da (patch)
tree10e8ebb9ec6075416c5fe14a238517b8e961a3ff /mail-client/mutt
parentChange license from as-is to icaclient, bug 283944 (diff)
downloadgentoo-2-f3fc40ea299e9c120878c2ca7c0a14cb881da1da.tar.gz
gentoo-2-f3fc40ea299e9c120878c2ca7c0a14cb881da1da.tar.bz2
gentoo-2-f3fc40ea299e9c120878c2ca7c0a14cb881da1da.zip
Bump, three more regression patches fixing a block when opening an MH folder, a segfault on certain search patterns and a segfault after 'next' when the previous search pattern was invalid
(Portage version: 2.2.00.14200-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'mail-client/mutt')
-rw-r--r--mail-client/mutt/ChangeLog12
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch16
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch23
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch22
-rw-r--r--mail-client/mutt/mutt-1.5.20-r5.ebuild262
5 files changed, 334 insertions, 1 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index c670f5523e39..dbab86789188 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mail-client/mutt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.152 2009/09/07 18:36:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.153 2009/09/07 19:12:25 grobian Exp $
+
+*mutt-1.5.20-r5 (07 Sep 2009)
+
+ 07 Sep 2009; Fabian Groffen <grobian@gentoo.org> +mutt-1.5.20-r5.ebuild,
+ +files/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch,
+ +files/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch,
+ +files/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch:
+ Bump, three more regression patches fixing a block when opening an MH
+ folder, a segfault on certain search patterns and a segfault after 'next'
+ when the previous search pattern was invalid
07 Sep 2009; Fabian Groffen <grobian@gentoo.org> -mutt-1.5.15-r2.ebuild,
-files/mutt-1.5.15-parallel-make.patch, -mutt-1.5.20-r1.ebuild,
diff --git a/mail-client/mutt/files/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch b/mail-client/mutt/files/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch
new file mode 100644
index 000000000000..b0a390f2f262
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch
@@ -0,0 +1,16 @@
+http://dev.mutt.org/trac/ticket/3312
+http://dev.mutt.org/trac/changeset/14bb498c6a1c
+
+Fix MH parsing, fixes [0698e8195545]. Closes #3312
+
+Index: mh.c
+===================================================================
+--- mh.c (revision 5999:2fc9348684fe)
++++ mh.c (revision 6005:14bb498c6a1c)
+@@ -147,5 +147,5 @@
+ {
+ *p++ = '\0';
+- if (mutt_atoi (t, first) < 0 || mutt_atoi (t, last) < 0)
++ if (mutt_atoi (t, first) < 0 || mutt_atoi (p, last) < 0)
+ return -1;
+ }
diff --git a/mail-client/mutt/files/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch b/mail-client/mutt/files/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch
new file mode 100644
index 000000000000..18b84a59b535
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch
@@ -0,0 +1,23 @@
+http://dev.mutt.org/trac/ticket/3315
+http://dev.mutt.org/trac/changeset/6a08a5244d60
+
+Clear last search pattern if it's invalid. Closes #3315.
+
+We keep both, the string version and compiled version around
+for search-next; however, in case of parsing errors we dropped
+only the compiled version and not the string one making the
+code attempting to perform a search using a NULL pattern.
+
+Index: pattern.c
+===================================================================
+--- pattern.c (revision 6018:053ef7bbaa72)
++++ pattern.c (revision 6019:6a08a5244d60)
+@@ -1437,6 +1437,7 @@
+ err.dsize = sizeof (error);
+ if ((SearchPattern = mutt_pattern_comp (temp, M_FULL_MSG, &err)) == NULL)
+- {
++ {
+ mutt_error ("%s", error);
++ LastSearch[0] = '\0';
+ return (-1);
+ }
diff --git a/mail-client/mutt/files/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch b/mail-client/mutt/files/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch
new file mode 100644
index 000000000000..df8d99e8fb6a
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch
@@ -0,0 +1,22 @@
+http://dev.mutt.org/trac/ticket/3314
+http://dev.mutt.org/trac/changeset/053ef7bbaa72
+
+Bail on missing pattern modifiers at end of pattern. Closes #3314.
+
+Index: pattern.c
+===================================================================
+--- pattern.c (revision 5989:77ac8b5c2be6)
++++ pattern.c (revision 6018:053ef7bbaa72)
+@@ -824,5 +824,11 @@
+ case '=':
+ case '~':
+- if (*(ps.dptr + 1) == '(')
++ if (!*(ps.dptr + 1))
++ {
++ snprintf (err->data, err->dsize, _("missing pattern: %s"), ps.dptr);
++ mutt_pattern_free (&curlist);
++ return NULL;
++ }
++ if (*(ps.dptr + 1) == '(')
+ {
+ ps.dptr ++; /* skip ~ */
diff --git a/mail-client/mutt/mutt-1.5.20-r5.ebuild b/mail-client/mutt/mutt-1.5.20-r5.ebuild
new file mode 100644
index 000000000000..7e252baeb265
--- /dev/null
+++ b/mail-client/mutt/mutt-1.5.20-r5.ebuild
@@ -0,0 +1,262 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r5.ebuild,v 1.1 2009/09/07 19:12:25 grobian Exp $
+
+inherit eutils flag-o-matic autotools
+
+PATCHSET_REV="-r3"
+
+# note: latest sidebar patches can be found here:
+# http://www.lunar-linux.org/index.php?option=com_content&task=view&id=44
+SIDEBAR_PATCH_N="patch-1.5.20.sidebar.20090619.txt"
+
+DESCRIPTION="a small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org"
+SRC_URI="ftp://ftp.mutt.org/mutt/devel/${P}.tar.gz
+ !vanilla? (
+ !sidebar? (
+ mirror://gentoo/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ http://dev.gentoo.org/~grobian/distfiles/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ )
+ )
+ sidebar? (
+ http://www.lunar-linux.org/~tchan/mutt/${SIDEBAR_PATCH_N}
+ )"
+IUSE="berkdb crypt debug doc gdbm gnutls gpg idn imap mbox nls nntp pop qdbm sasl sidebar smime smtp ssl vanilla"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+RDEPEND=">=sys-libs/ncurses-5.2
+ qdbm? ( dev-db/qdbm )
+ !qdbm? (
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ smtp? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpg? ( >=app-crypt/gpgme-0.9.0 )
+ smime? ( >=dev-libs/openssl-0.9.6 )
+ app-misc/mime-types"
+DEPEND="${RDEPEND}
+ net-mail/mailbase
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || ( www-client/lynx www-client/w3m www-client/elinks )
+ )"
+
+PATCHDIR="${WORKDIR}"/${P}-gentoo-patches${PATCHSET_REV}
+
+src_unpack() {
+ unpack ${A//${SIDEBAR_PATCH_N}}
+ cd "${S}"
+
+ # this patch is non-generic and only works because we use a sysconfdir
+ # different from the one used by the mailbase ebuild
+ use prefix && epatch "${FILESDIR}"/mutt-1.5.13-prefix-mailcap.patch
+
+ epatch "${FILESDIR}"/mutt-1.5.18-bdb-prefix.patch # fix bdb detection
+ epatch "${FILESDIR}"/mutt-1.5.18-interix.patch
+ built_with_use sys-libs/ncurses unicode && \
+ epatch "${FILESDIR}"/mutt-1.5.18-solaris-ncurses-chars.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-gpgme-1.2.0.patch
+ # post-release hot-fixes
+ epatch "${FILESDIR}"/mutt-1.5.20-imap-port-invalid-d6f88fbf8387.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-header-weeding-f40de578e8ed.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-display-unsigned-pgp-7f37d0a57d83.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-unmailbox-segfault-25e46aad362b.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-mbox-new-mail-bd59be56c6b0.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-mbox-unchanged-new-mail-9ae13dedb5ed.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-imap-start-fatal-fe30f394cbe6.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-smtp-batch-mode-0a3de4d9a009-f6c6066a5925.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-gpgme-keys-d41e043fa775.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-mhs-flags-leak-9f3053f75f27.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-hcache-restore-address-848f08512bf3.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-ungroup-command-77ac8b5c2be6.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-propagate-mh_read_sequences-2fc9348684fe.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-hcache-uidvalidity-size-fix-a2a4286491b4.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-fix-mh-parsing-14bb498c6a1c.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-search-pattern-crash-053ef7bbaa72.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-next-invalid-pattern-crash-6a08a5244d60.patch
+
+ # patch version string for bug reports
+ sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}"')"/' \
+ muttlib.c || die "failed patching in Gentoo version"
+
+ if use !vanilla && use !sidebar ; then
+ use nntp || rm "${PATCHDIR}"/06-nntp.patch
+ for p in "${PATCHDIR}"/*.patch ; do
+ epatch "${p}"
+ done
+ fi
+
+ if use sidebar ; then
+ use vanilla || \
+ ewarn "The sidebar patch is only applied to a vanilla mutt tree."
+ epatch "${DISTDIR}"/${SIDEBAR_PATCH_N}
+ fi
+
+ AT_M4DIR="m4" eautoreconf
+
+ # the configure script contains some "cleverness" whether or not to setgid
+ # the dotlock program, resulting in bugs like #278332
+ sed -i -e 's/@DOTLOCK_GROUP@//' \
+ Makefile.in || die "sed failed"
+
+ # don't just build documentation (lengthy process, with big dependencies)
+ if use !doc ; then
+ sed -i -e '/SUBDIRS =/s/doc//' Makefile.in || die
+ fi
+}
+
+src_compile() {
+ declare myconf="
+ $(use_enable nls) \
+ $(use_enable gpg gpgme) \
+ $(use_enable imap) \
+ $(use_enable pop) \
+ $(use_enable smtp) \
+ $(use_enable crypt pgp) \
+ $(use_enable smime) \
+ $(use_enable debug) \
+ $(use_with idn) \
+ --with-curses \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --enable-nfs-fix --enable-external-dotlock \
+ $(use_with !nntp mixmaster) \
+ --with-exec-shell=${EPREFIX}/bin/sh"
+
+ case $CHOST in
+ *-darwin7)
+ # locales are broken on Panther
+ myconf="${myconf} --enable-locales-fix --without-wc-funcs"
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ *-solaris*)
+ # Solaris has no flock in the standard headers
+ myconf="${myconf} --enable-fcntl --disable-flock"
+ ;;
+ *)
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ esac
+
+ # See Bug #22787
+ unset WANT_AUTOCONF_2_5 WANT_AUTOCONF
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use qdbm; then
+ myconf="${myconf} --enable-hcache \
+ --with-qdbm --without-gdbm --without-bdb"
+ elif use gdbm ; then
+ myconf="${myconf} --enable-hcache \
+ --without-qdbm --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache \
+ --without-gdbm --without-qdbm --with-bdb"
+ else
+ myconf="${myconf} --disable-hcache \
+ --without-qdbm --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without socket support
+ if use pop || use imap || use smtp ; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=${EPREFIX}/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ if use !vanilla && use !sidebar ; then
+ # rr.compressed patch
+ myconf="${myconf} --enable-compressed"
+
+ # nntp patch applied conditionally, so avoid QA warning when doing
+ # --disable-nntp while patch not being applied, bug #262069
+ use nntp && myconf="${myconf} --enable-nntp"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ local ED=${ED-${D}}
+ make DESTDIR="${D}" install || die "install failed"
+ find "${ED}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if use mbox; then
+ insinto /etc/mutt
+ newins "${FILESDIR}"/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins "${FILESDIR}"/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm "${ED}"/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ # A man-page is always handy
+ if use !doc; then
+ cp doc/mutt.man mutt.1
+ cp doc/muttbug.man flea.1
+ doman mutt.1 flea.1
+ fi
+
+ if use !prefix ; then
+ fowners root:mail /usr/bin/mutt_dotlock
+ fperms g+s /usr/bin/mutt_dotlock
+ fi
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_setup() {
+ if ! use gpg &&
+ has_version "<${CATEGORY}/${PN}-1.5.20-r2" &&
+ built_with_use ${CATEGORY}/${PN} gpgme ;
+ then
+ ewarn 'The "gpgme" USE-flag has been changed into "gpg". You'
+ ewarn 'previously had "gpgme" set, and you most likely want to'
+ ewarn 'enable "gpg" instead, right now, to obtain equivalent behaviour.'
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "If you are new to mutt you may want to take a look at"
+ elog "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ elog " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}