summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-06-12 09:15:16 +0000
committerFabian Groffen <grobian@gentoo.org>2010-06-12 09:15:16 +0000
commit34879ca12c1005e6c51acc4a885c5de9c2bdb885 (patch)
treee4f4ce8416c37358f7145d343b9ad4357bbc6734 /mail-client/mutt
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-34879ca12c1005e6c51acc4a885c5de9c2bdb885.tar.gz
gentoo-2-34879ca12c1005e6c51acc4a885c5de9c2bdb885.tar.bz2
gentoo-2-34879ca12c1005e6c51acc4a885c5de9c2bdb885.zip
Add patch for bug #323613, needs to be taken upstream, works for me to resolve the crash.
(Portage version: 2.2.00.15842-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'mail-client/mutt')
-rw-r--r--mail-client/mutt/ChangeLog8
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-crash-on-invalid-limit-pattern.patch12
-rw-r--r--mail-client/mutt/mutt-1.5.20-r15.ebuild42
3 files changed, 44 insertions, 18 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 5560574a23df..3fea2f4748c1 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/mutt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.185 2010/06/06 10:39:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.186 2010/06/12 09:15:16 grobian Exp $
+
+ 12 Jun 2010; Fabian Groffen <grobian@gentoo.org> mutt-1.5.20-r15.ebuild,
+ +files/mutt-1.5.20-crash-on-invalid-limit-pattern.patch:
+ Add patch for bug #323613, needs to be taken upstream, works for me to
+ resolve the crash. Reorganise src_prepare such that we don't patch
+ anything other than what is strictly necessary with USE=vanilla.
*mutt-1.5.20-r15 (06 Jun 2010)
diff --git a/mail-client/mutt/files/mutt-1.5.20-crash-on-invalid-limit-pattern.patch b/mail-client/mutt/files/mutt-1.5.20-crash-on-invalid-limit-pattern.patch
new file mode 100644
index 000000000000..ec37824344a3
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-crash-on-invalid-limit-pattern.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/show_bug.cgi?id=323613
+
+--- pattern.c
++++ pattern.c
+@@ -1310,6 +1310,7 @@
+ simple = safe_strdup (buf);
+ mutt_check_simple (buf, sizeof (buf), NONULL (SimpleSearch));
+
++ memset(&err, 0, sizeof(err));
+ err.data = error;
+ err.dsize = sizeof (error);
+ if ((pat = mutt_pattern_comp (buf, M_FULL_MSG, &err)) == NULL)
diff --git a/mail-client/mutt/mutt-1.5.20-r15.ebuild b/mail-client/mutt/mutt-1.5.20-r15.ebuild
index 26a3fe3cd3a0..49766cc6b92a 100644
--- a/mail-client/mutt/mutt-1.5.20-r15.ebuild
+++ b/mail-client/mutt/mutt-1.5.20-r15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r15.ebuild,v 1.1 2010/06/06 10:39:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r15.ebuild,v 1.2 2010/06/12 09:15:16 grobian Exp $
EAPI="3"
@@ -76,30 +76,38 @@ src_prepare() {
# different from the one used by the mailbase ebuild
use prefix && epatch "${FILESDIR}"/mutt-1.5.13-prefix-mailcap.patch
+ # must haves to compile or behave correctly
epatch "${FILESDIR}"/mutt-1.5.18-bdb-prefix.patch # fix bdb detection
epatch "${FILESDIR}"/mutt-1.5.18-interix.patch
built_with_use sys-libs/ncurses unicode && \
epatch "${FILESDIR}"/mutt-1.5.18-solaris-ncurses-chars.patch
epatch "${FILESDIR}"/mutt-1.5.20-gpgme-1.2.0.patch
- epatch "${FILESDIR}"/mutt-1.5.20-dont-reveal-bbc.patch
- epatch "${FILESDIR}"/mutt-1.5.20-realpath-slowness.patch
- # post-release hot-fixes
- for rev in $(eval echo {0..${PR#r}}) ; do
- local revpatch="${PATCHDIR}"/mutt-gentoo-${PV}-r${rev}.patch
- [[ -e ${revpatch} ]] && \
- epatch "${revpatch}"
- done
+ if use !vanilla ; then
+ # fixes that are not yet upstream, or that upstream doesn't like
+ epatch "${FILESDIR}"/mutt-1.5.20-dont-reveal-bbc.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-realpath-slowness.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-crash-on-invalid-limit-pattern.patch
- # patch version string for bug reports
- sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}"')"/' \
- muttlib.c || die "failed patching in Gentoo version"
-
- if use !vanilla && use !sidebar ; then
- use nntp || rm "${PATCHDIR}"/06-nntp.patch
- for p in "${PATCHDIR}"/[0-9][0-9]-*.patch ; do
- epatch "${p}"
+ # post-release hot-fixes grabbed from HG
+ for rev in $(eval echo {0..${PR#r}}) ; do
+ local revpatch="${PATCHDIR}"/mutt-gentoo-${PV}-r${rev}.patch
+ [[ -e ${revpatch} ]] && \
+ epatch "${revpatch}"
done
+
+ # patch version string for bug reports
+ sed -i -e 's/"Mutt %s (%s)"/"Mutt %s (%s, Gentoo '"${PVR}"')"/' \
+ muttlib.c || die "failed patching in Gentoo version"
+
+ # the big feature patches that upstream doesn't want to include, but
+ # nearly every distro has due to their usefulness
+ if use !sidebar ; then
+ use nntp || rm "${PATCHDIR}"/06-nntp.patch
+ for p in "${PATCHDIR}"/[0-9][0-9]-*.patch ; do
+ epatch "${p}"
+ done
+ fi
fi
if use sidebar ; then