summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-18 14:52:08 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-18 14:52:08 +0000
commitb83b1b6a238a87cf3b070e28cb744ec3e1d92922 (patch)
tree4656fa7c72d6a68b62cc7e338f309f231918f623 /mail-client/mozilla-thunderbird
parent- Fix bug 54179: Install mozillafirefox.desktop to (diff)
downloadgentoo-2-b83b1b6a238a87cf3b070e28cb744ec3e1d92922.tar.gz
gentoo-2-b83b1b6a238a87cf3b070e28cb744ec3e1d92922.tar.bz2
gentoo-2-b83b1b6a238a87cf3b070e28cb744ec3e1d92922.zip
- Fix bug 54179: Install mozillathunderbird.desktop to
/usr/share/applications instead of /usr/share/gnome/apps/Internet. This also necessitated some changes to the .desktop file which I based on balsa.desktop - Fix bug 54295: Move init file unpacking from pkg_postinst to src_install - Get rid of the stupid perl dependency; it was only being used to edit the .desktop file, and sed would have sufficed in any case
Diffstat (limited to 'mail-client/mozilla-thunderbird')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog13
-rw-r--r--mail-client/mozilla-thunderbird/files/icon/mozillathunderbird.desktop3
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild22
3 files changed, 26 insertions, 12 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 19fc20f9d700..400f6c833048 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-mail/mozilla-thunderbird
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.9 2004/06/17 23:25:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.10 2004/06/18 14:52:08 agriffis Exp $
+
+ 18 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ files/icon/mozillathunderbird.desktop, mozilla-thunderbird-0.7.ebuild:
+ - Fix bug 54179: Install mozillathunderbird.desktop to
+ /usr/share/applications instead of /usr/share/gnome/apps/Internet.
+ This also necessitated some changes to the .desktop file which I
+ based on balsa.desktop
+ - Fix bug 54295: Move init file unpacking from pkg_postinst to
+ src_install
+ - Get rid of the stupid perl dependency; it was only being used to
+ edit the .desktop file, and sed would have sufficed in any case
*mozilla-thunderbird-0.6-r2 (17 Jun 2004)
diff --git a/mail-client/mozilla-thunderbird/files/icon/mozillathunderbird.desktop b/mail-client/mozilla-thunderbird/files/icon/mozillathunderbird.desktop
index f9cc517d96dd..8e91b69de6f2 100644
--- a/mail-client/mozilla-thunderbird/files/icon/mozillathunderbird.desktop
+++ b/mail-client/mozilla-thunderbird/files/icon/mozillathunderbird.desktop
@@ -3,5 +3,6 @@ Name=Mozilla Thunderbird
Comment=Mail & News Reader
Exec=/usr/bin/thunderbird
Icon=thunderbird-icon.png
-Terminal=0
+Terminal=false
Type=Application
+Categories=Application;Network;
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild
index bc1e03615dbc..a2a1c8df1c74 100644
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild,v 1.2 2004/06/17 23:25:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-0.7.ebuild,v 1.3 2004/06/18 14:52:08 agriffis Exp $
IUSE="gnome gtk2 ipv6 ldap crypt xinerama"
@@ -44,8 +44,7 @@ RDEPEND="virtual/x11
>=net-www/mozilla-launcher-1.7-r1"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-lang/perl"
+ dev-util/pkgconfig"
S=${WORKDIR}/mozilla
@@ -279,9 +278,18 @@ src_install() {
if use gnome; then
insinto /usr/share/pixmaps
doins ${FILESDIR}/icon/thunderbird-icon.png
- insinto /usr/share/gnome/apps/Internet
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
doins ${FILESDIR}/icon/mozillathunderbird.desktop
fi
+
+ # Normally thunderbird-0.7 must be run as root once before it can
+ # be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting thunderbird-${PV} initialization files"
+ tar xjpf ${FILESDIR}/thunderbird-${PV}-init.tar.bz2 \
+ -C ${D}/usr/lib/MozillaThunderbird
}
pkg_preinst() {
@@ -293,12 +301,6 @@ pkg_preinst() {
pkg_postinst() {
export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaThunderbird"
- # Normally thunderbird-0.7 must be run as root once before it can
- # be run as a normal user. Drop in some initialized files to
- # avoid this.
- einfo "Extracting thunderbird-${PV} initialization files"
- cd ${MOZILLA_FIVE_HOME} && tar xjpf ${FILESDIR}/thunderbird-${PV}-init.tar.bz2
-
# Fix permissions on misc files
find ${MOZILLA_FIVE_HOME}/ -perm 0700 -exec chmod 0755 {} \; || :