summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-07-04 06:05:18 +0000
committerBrad Laue <brad@gentoo.org>2004-07-04 06:05:18 +0000
commit2aec9e74544b8d436fbc2b281ce7c2dfbbae3e99 (patch)
treebaededf487603feb19e455b9e4e079a9ad47dc28 /mail-client/mozilla-thunderbird-bin
parentCentralize icon placement in 0.7.ebuild (diff)
downloadgentoo-2-2aec9e74544b8d436fbc2b281ce7c2dfbbae3e99.tar.gz
gentoo-2-2aec9e74544b8d436fbc2b281ce7c2dfbbae3e99.tar.bz2
gentoo-2-2aec9e74544b8d436fbc2b281ce7c2dfbbae3e99.zip
Update to 0.7.1
Diffstat (limited to 'mail-client/mozilla-thunderbird-bin')
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog9
-rw-r--r--mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-0.7.11
-rw-r--r--mail-client/mozilla-thunderbird-bin/files/icon/mozillathunderbird-bin.desktop2
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-0.7.1.ebuild91
4 files changed, 101 insertions, 2 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index d687ae64d866..2fd195a73d9e 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/mozilla-thunderbird-bin
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.8 2004/07/04 05:51:46 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.9 2004/07/04 06:05:18 brad Exp $
+
+*mozilla-thunderbird-bin-0.7.1 (04 Jul 2004)
+
+ 04 Jul 2004; Brad Laue <brad@gentoo.org>
+ files/icon/mozillathunderbird-bin.desktop,
+ +mozilla-thunderbird-bin-0.7.1.ebuild:
+ Update to 0.7.1, fix menu icon.
04 Jul 2004; Brad Laue <brad@gentoo.org>
+files/icon/mozillathunderbird-bin-icon.png,
diff --git a/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-0.7.1 b/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-0.7.1
new file mode 100644
index 000000000000..ee41d3841fdc
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/files/digest-mozilla-thunderbird-bin-0.7.1
@@ -0,0 +1 @@
+MD5 a2c3f019e912e455652ea0f173df6b39 thunderbird-0.7.1-i686-linux-gtk2+xft.tar.gz 9957844
diff --git a/mail-client/mozilla-thunderbird-bin/files/icon/mozillathunderbird-bin.desktop b/mail-client/mozilla-thunderbird-bin/files/icon/mozillathunderbird-bin.desktop
index 7fdb61334656..b0f03a52bc89 100644
--- a/mail-client/mozilla-thunderbird-bin/files/icon/mozillathunderbird-bin.desktop
+++ b/mail-client/mozilla-thunderbird-bin/files/icon/mozillathunderbird-bin.desktop
@@ -2,7 +2,7 @@
Name=Mozilla Thunderbird (bin)
Comment=Mail & News Reader
Exec=/usr/bin/thunderbird-bin
-Icon=thunderbird-bin-icon.png
+Icon=mozillathunderbird-bin-icon.png
Terminal=false
Type=Application
Categories=Application;Network;
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-0.7.1.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-0.7.1.ebuild
new file mode 100644
index 000000000000..9f8053e3e682
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-0.7.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-0.7.1.ebuild,v 1.1 2004/07/04 06:05:18 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/thunderbird
+
+DESCRIPTION="The Mozilla Thunderbird Mail & News Reader"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/thunderbird-${PV}-i686-linux-gtk2+xft.tar.gz"
+
+HOMEPAGE="http://www.mozilla.org/projects/thunderbird"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="gnome gtk2 crypt"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=x11-libs/gtk+-2.1.1
+ virtual/xft
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install thunderbird in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/thunderbird
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/thunderbird
+
+ # mozilla-launcher-1.13 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/thunderbird-bin
+
+ # Install icon and .desktop for menu entry
+ if use gnome; then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillathunderbird-bin-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillathunderbird-bin.desktop
+ fi
+
+ # Normally thunderbird-bin-0.7 must be run as root once before it
+ # can be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting firefox-bin-${PV} initialization files"
+ tar xjpf ${FILESDIR}/thunderbird-bin-0.7-init.tar.bz2 \
+ -C ${D}/opt/thunderbird
+}
+
+pkg_preinst() {
+ # Remove entire installed instance to solve various
+ # problems, for example see bug 27719
+ rm -rf ${ROOT}/opt/MozillaThunderbird
+ rm -rf ${ROOT}/opt/thunderbird
+}
+
+pkg_postinst() {
+ einfo "To enable Enigmail, you must install the Enigmail and Enigmime"
+ einfo "extensions as root. Go to Tools / Options / Extensions and click"
+ einfo "on Install Extension to install Enigmail in your Thunderbird build."
+ einfo "Restart Thunderbird after having installed both extensions."
+ einfo ""
+ einfo "The extensions are located at http://enigmail.mozdev.org/"
+ einfo ""
+ einfo "Please note that the binary name has changed from MozillaThunderbird"
+ einfo "to simply thunderbird-bin"
+ einfo ""
+
+ # This should be called in the postinst and postrm of all the
+ # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
+ # thunderbird-bin ebuilds.
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}