summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-08-26 13:43:04 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-08-26 13:43:04 +0000
commit1800b5b0a541b61d5416495e4b3a4341dac6dfd2 (patch)
treecd4da65ba6acdc22abb8fd29bd5d639071acea7e /mail-client/mozilla-thunderbird-bin
parentStable for HPPA (bug #282642). (diff)
downloadgentoo-2-1800b5b0a541b61d5416495e4b3a4341dac6dfd2.tar.gz
gentoo-2-1800b5b0a541b61d5416495e4b3a4341dac6dfd2.tar.bz2
gentoo-2-1800b5b0a541b61d5416495e4b3a4341dac6dfd2.zip
Version bump
(Portage version: 2.1.6.13/cvs/Linux ia64)
Diffstat (limited to 'mail-client/mozilla-thunderbird-bin')
-rw-r--r--mail-client/mozilla-thunderbird-bin/ChangeLog10
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.23.ebuild140
-rw-r--r--mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta3.ebuild165
3 files changed, 314 insertions, 1 deletions
diff --git a/mail-client/mozilla-thunderbird-bin/ChangeLog b/mail-client/mozilla-thunderbird-bin/ChangeLog
index 0e860059e65a..c9e44b3b1ef4 100644
--- a/mail-client/mozilla-thunderbird-bin/ChangeLog
+++ b/mail-client/mozilla-thunderbird-bin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-client/mozilla-thunderbird-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.131 2009/06/28 11:53:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/ChangeLog,v 1.132 2009/08/26 13:43:04 armin76 Exp $
+
+*mozilla-thunderbird-bin-3.0_beta3 (26 Aug 2009)
+*mozilla-thunderbird-bin-2.0.0.23 (26 Aug 2009)
+
+ 26 Aug 2009; Raúl Porcel <armin76@gentoo.org>
+ +mozilla-thunderbird-bin-2.0.0.23.ebuild,
+ +mozilla-thunderbird-bin-3.0_beta3.ebuild:
+ Version bump
28 Jun 2009; Markus Meier <maekke@gentoo.org>
mozilla-thunderbird-bin-2.0.0.22.ebuild:
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.23.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.23.ebuild
new file mode 100644
index 000000000000..414c78a03419
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.23.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-2.0.0.23.ebuild,v 1.1 2009/08/26 13:43:04 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib mozextension
+
+LANGS="af be bg ca cs da de el en-GB en-US es-AR es-ES eu fi fr ga-IE he hu it ja ko lt mk nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ru sk sl sv-SE tr uk zh-CN zh-TW"
+NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
+
+DESCRIPTION="Thunderbird Mail Client"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${PV}/linux-i686/en-US/thunderbird-${PV}.tar.gz"
+HOMEPAGE="http://www.mozilla.com/thunderbird"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentooexperimental.org/~armin76/dist/${P/-bin}-xpi/${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${P/-bin}-xpi/${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.41"
+
+S="${WORKDIR}/thunderbird"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack thunderbird-${PV}.tar.gz
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_unpack ${P/-bin}-${X}.xpi
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/opt/thunderbird"
+
+ # Install thunderbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_install ${WORKDIR}/${P/-bin}-${X}
+ done
+
+ local LANG=${linguas%% *}
+ if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
+ ebegin "Setting default locale to ${LANG}"
+ sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-thunderbird.js \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-l10n.js
+ eend $? || die "sed failed to change locale"
+ fi
+
+ # Install /usr/bin/thunderbird-bin
+ install_mozilla_launcher_stub thunderbird-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}"/icon/${PN}-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10thunderbird-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71thunderbird-bin
+}
+
+pkg_postinst() {
+ elog "For enigmail, please see instructions at"
+ elog " http://enigmail.mozdev.org/"
+
+ use amd64 && einfo "NB: You just installed a 32-bit thunderbird"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}
diff --git a/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta3.ebuild b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta3.ebuild
new file mode 100644
index 000000000000..974ae6a330c2
--- /dev/null
+++ b/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta3.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird-bin/mozilla-thunderbird-bin-3.0_beta3.ebuild,v 1.1 2009/08/26 13:43:04 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib mozextension
+
+LANGS="af ar be ca cs de el en-US es-AR es-ES et eu fi fr fy-NL ga-IE gl hu id is it ja ko lt nb-NO nl nn-NO pa-IN pl pt-BR ro ru si sk sv-SE uk vi zh-CN"
+NOSHORTLANGS="es-AR"
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Thunderbird Mail Client"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/${MY_PV}/linux-i686/en-US/thunderbird-${MY_PV}.tar.bz2"
+HOMEPAGE="http://www.mozilla.com/thunderbird"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( http://dev.gentooexperimental.org/~armin76/dist/${MY_P/-bin}-xpi/${MY_P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )"
+
+S="${WORKDIR}/thunderbird"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_unpack ${MY_P/-bin}-${X}.xpi
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/opt/thunderbird"
+
+ # Install thunderbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_install ${WORKDIR}/${MY_P/-bin}-${X}
+ done
+
+ local LANG=${linguas%% *}
+ if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
+ ebegin "Setting default locale to ${LANG}"
+ sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-thunderbird.js \
+ "${D}"${MOZILLA_FIVE_HOME}/defaults/pref/all-l10n.js
+ eend $? || die "sed failed to change locale"
+ fi
+
+ # Install /usr/bin/thunderbird-bin
+ make_wrapper thunderbird-bin "${MOZILLA_FIVE_HOME}/thunderbird"
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}"/icon/${PN}-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10thunderbird-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71thunderbird-bin
+}
+
+pkg_postinst() {
+ #elog "For enigmail, please see instructions at"
+ #elog " http://enigmail.mozdev.org/"
+
+ ewarn "Enigmail or probably any other extension won't work"
+ ewarn "with Thunderbird 3.0."
+
+ if use x86; then
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl' && built_with_use --missing \
+ true 'net-misc/curl' nss; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+ else
+ einfo
+ einfo "NB: You just installed a 32-bit thunderbird"
+ einfo
+ einfo "Crashreporter won't work on amd64"
+ einfo
+ fi
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}