summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-21 23:35:20 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-21 23:35:20 +0000
commit039b87dc8413065b2eeea7200f0d65b9be8ea9ee (patch)
tree7c74ccf4d83d560b849ae3f2473bc600d48df351 /mail-client/mail-notification/mail-notification-5.4-r4.ebuild
parentversion bump, remove old, Scalar-List-Utils no longer needed (diff)
downloadgentoo-2-039b87dc8413065b2eeea7200f0d65b9be8ea9ee.tar.gz
gentoo-2-039b87dc8413065b2eeea7200f0d65b9be8ea9ee.tar.bz2
gentoo-2-039b87dc8413065b2eeea7200f0d65b9be8ea9ee.zip
Inherit eutils for epatch, use $(usex), and display configure commands.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/mail-notification/mail-notification-5.4-r4.ebuild')
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail-client/mail-notification/mail-notification-5.4-r4.ebuild b/mail-client/mail-notification/mail-notification-5.4-r4.ebuild
index a9fa7b9a6558..fda1c16714aa 100644
--- a/mail-client/mail-notification/mail-notification-5.4-r4.ebuild
+++ b/mail-client/mail-notification/mail-notification-5.4-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r4.ebuild,v 1.9 2012/05/04 08:42:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r4.ebuild,v 1.10 2012/05/21 23:35:20 vapier Exp $
EAPI=2
-inherit gnome2 multilib flag-o-matic toolchain-funcs
+inherit gnome2 multilib flag-o-matic toolchain-funcs eutils
DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
HOMEPAGE="http://www.nongnu.org/mailnotify/"
@@ -13,7 +13,6 @@ SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
KEYWORDS="amd64 ppc sparc x86"
SLOT="0"
LICENSE="GPL-3"
-
IUSE="evo gmail imap ipv6 maildir mbox mh mozilla pop sasl ssl sylpheed"
# gmime is actually optional, but it's used by so much of the package
@@ -46,8 +45,7 @@ DEPEND="${RDEPEND}
# instead of autotools, this is a little helper function that basically does
# the same thing as use_enable
use_var() {
- echo -n "${2:-$1}="
- use "${1}" && echo "yes" || echo "no"
+ echo "${2:-$1}=$(usex $1)"
}
src_prepare() {
@@ -77,6 +75,7 @@ src_prepare() {
}
src_configure() {
+ set -- \
./jb configure destdir="${D}" prefix="/usr" libdir=/usr/$(get_libdir) \
sysconfdir="/etc" localstatedir="/var" cc="$(tc-getCC)" \
cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
@@ -92,7 +91,9 @@ src_configure() {
$(use_var pop pop3) \
$(use_var sasl) \
$(use_var ssl) \
- $(use_var sylpheed) || die
+ $(use_var sylpheed)
+ echo "$@"
+ "$@" || die
}
src_compile() {