summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-12-17 11:58:57 +0000
committerTom Martin <slarti@gentoo.org>2005-12-17 11:58:57 +0000
commit3b3e114b870796d1b53059d8993bad9ba9d47477 (patch)
treef7bb1563f82e1f52380eaa28e2b82a587a6e8478 /mail-client/mail-notification/mail-notification-2.0.ebuild
parentUse mirror://gentoo/ instead of not giving any url for the files. Close bug #... (diff)
downloadgentoo-2-3b3e114b870796d1b53059d8993bad9ba9d47477.tar.gz
gentoo-2-3b3e114b870796d1b53059d8993bad9ba9d47477.tar.bz2
gentoo-2-3b3e114b870796d1b53059d8993bad9ba9d47477.zip
Append some LDFLAGS to resolve a bug experienced by some, and fix the evolution plugin install destination. #115302, #115499
(Portage version: 2.0.53)
Diffstat (limited to 'mail-client/mail-notification/mail-notification-2.0.ebuild')
-rw-r--r--mail-client/mail-notification/mail-notification-2.0.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/mail-client/mail-notification/mail-notification-2.0.ebuild b/mail-client/mail-notification/mail-notification-2.0.ebuild
index e2ef8db36ea7..f576a8f8fe67 100644
--- a/mail-client/mail-notification/mail-notification-2.0.ebuild
+++ b/mail-client/mail-notification/mail-notification-2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.2 2005/12/09 14:46:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-2.0.ebuild,v 1.3 2005/12/17 11:58:57 slarti Exp $
-inherit eutils gnome2 multilib
+inherit eutils gnome2 multilib flag-o-matic
DESCRIPTION="A GNOME trayicon which checks for mail. Supports mbox, MH,
Maildir, IMAP, Sylpheed, POP3, Gmail and Evolution. Authenticates via
@@ -53,15 +53,20 @@ src_unpack() {
epatch ${FILESDIR}/${P}-gmail-properties-fix.diff
}
+src_compile() {
+ append-ldflags -Wl,-export-dynamic
+ gnome2_src_compile
+}
+
src_install() {
- gnome2_src_install evolution_plugindir="${D}/usr/$(get_libdir)/evolution/2.2/plugins"
+ gnome2_src_install evolution_plugindir="${D}/usr/$(get_libdir)/evolution/2.4/plugins"
}
pkg_postinst() {
- echo
+ ewarn ""
ewarn "Due to a bug in bonobo-activation, your GNOME/X11 session must"
ewarn "be restarted for mail-notification to work. If you don't do"
ewarn "this, this program will crash during the setup phase."
ewarn "See http://bugzilla.gnome.org/show_bug.cgi?id=151082"
- echo
+ ewarn ""
}