summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-01 19:04:59 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-01 19:04:59 +0000
commit0ae9d01459c921cfc8914bf5455296400d7bc6ff (patch)
tree99595f71005383641fc8e00ad40e0423e57c6bd5 /mail-client/claws-mail
parentVersion bump (diff)
downloadgentoo-2-0ae9d01459c921cfc8914bf5455296400d7bc6ff.tar.gz
gentoo-2-0ae9d01459c921cfc8914bf5455296400d7bc6ff.tar.bz2
gentoo-2-0ae9d01459c921cfc8914bf5455296400d7bc6ff.zip
Backport a RSS parsing fix, https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/47 by cerebrum.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'mail-client/claws-mail')
-rw-r--r--mail-client/claws-mail/ChangeLog11
-rw-r--r--mail-client/claws-mail/claws-mail-3.11.1-r1.ebuild (renamed from mail-client/claws-mail/claws-mail-3.11.1.ebuild)6
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch23
3 files changed, 36 insertions, 4 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index 62b696c8dfc4..34f972b18842 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/claws-mail
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.246 2014/11/23 07:27:21 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.247 2015/03/01 19:04:59 mgorny Exp $
+
+*claws-mail-3.11.1-r1 (01 Mar 2015)
+
+ 01 Mar 2015; Michał Górny <mgorny@gentoo.org> +claws-mail-3.11.1-r1.ebuild,
+ +files/claws-mail-3.11.1_RSSyl-encodings-fix.patch, -claws-mail-3.11.1.ebuild:
+ Backport a RSS parsing fix, https://github.com/gentoo/gentoo-portage-rsync-
+ mirror/pull/47 by cerebrum.
*claws-mail-3.11.1 (23 Nov 2014)
diff --git a/mail-client/claws-mail/claws-mail-3.11.1.ebuild b/mail-client/claws-mail/claws-mail-3.11.1-r1.ebuild
index 89300af3fd5c..307e661bbd67 100644
--- a/mail-client/claws-mail/claws-mail-3.11.1.ebuild
+++ b/mail-client/claws-mail/claws-mail-3.11.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.11.1.ebuild,v 1.1 2014/11/23 07:27:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.11.1-r1.ebuild,v 1.1 2015/03/01 19:04:59 mgorny Exp $
EAPI="5"
@@ -99,6 +99,8 @@ RDEPEND="${COMMONDEPEND}
app-misc/mime-types
x11-misc/shared-mime-info"
+PATCHES=( "${FILESDIR}/${P}_RSSyl-encodings-fix.patch" )
+
src_configure() {
local myeconfargs=(
$(use_enable debug crash-dialog)
diff --git a/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch b/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch
new file mode 100644
index 000000000000..82e13b25390f
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-3.11.1_RSSyl-encodings-fix.patch
@@ -0,0 +1,23 @@
+From: Andrej Kacian <ticho@claws-mail.org>
+Date: Thu, 1 Jan 2015 22:36:36 +0000 (+0100)
+Subject: RSSyl: Fix handling of feeds with encodings unknown to expat. Turns out the only...
+X-Git-Url: http://git.claws-mail.org/?p=claws.git;a=commitdiff_plain;h=d05156031070efe6104695acad93aa879bc0f084
+
+RSSyl: Fix handling of feeds with encodings unknown to expat. Turns out the only thing missing was that HAVE_ICONV macro (from config.h) was not defined in parser.c, so our "unknown encoding" expat handler function did nothing. Fixes bug #3339.
+---
+
+diff --git a/src/plugins/rssyl/libfeed/parser.c b/src/plugins/rssyl/libfeed/parser.c
+index bb0bb0d..14f4a36 100644
+--- a/src/plugins/rssyl/libfeed/parser.c
++++ b/src/plugins/rssyl/libfeed/parser.c
+@@ -17,6 +17,10 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #include <glib.h>
+ #include <curl/curl.h>
+ #include <expat.h>