summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-04-14 21:45:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-04-14 21:45:24 +0000
commitc4b6bb23fc25305d17426274e016b026c6f46894 (patch)
tree5c54a2c1b902c5b231684a81ac8bb4d19da08706 /mail-client/balsa
parentremoving myself from metadata -- i'm loaded enough with php work (diff)
downloadgentoo-2-c4b6bb23fc25305d17426274e016b026c6f46894.tar.gz
gentoo-2-c4b6bb23fc25305d17426274e016b026c6f46894.tar.bz2
gentoo-2-c4b6bb23fc25305d17426274e016b026c6f46894.zip
Fix build failure with USE=-libnotify, bug #314123.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/balsa')
-rw-r--r--mail-client/balsa/ChangeLog6
-rw-r--r--mail-client/balsa/balsa-2.4.7.ebuild9
-rw-r--r--mail-client/balsa/files/balsa-2.4.7-build-failure-notify.patch29
3 files changed, 42 insertions, 2 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index 3c91d311a64a..55ebd422b108 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/balsa
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.95 2010/03/26 16:42:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.96 2010/04/14 21:45:24 eva Exp $
+
+ 14 Apr 2010; Gilles Dartiguelongue <eva@gentoo.org> balsa-2.4.7.ebuild,
+ +files/balsa-2.4.7-build-failure-notify.patch:
+ Fix build failure with USE=-libnotify, bug #314123.
26 Mar 2010; Pacho Ramos <pacho@gentoo.org> -balsa-2.3.28.ebuild,
-balsa-2.4.1.ebuild:
diff --git a/mail-client/balsa/balsa-2.4.7.ebuild b/mail-client/balsa/balsa-2.4.7.ebuild
index dec717970ee3..4369e9c2954d 100644
--- a/mail-client/balsa/balsa-2.4.7.ebuild
+++ b/mail-client/balsa/balsa-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.4.7.ebuild,v 1.1 2010/03/10 23:46:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.4.7.ebuild,v 1.2 2010/04/14 21:45:24 eva Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -98,3 +98,10 @@ pkg_setup() {
$(use_with ssl)
$(use_with xface compface)"
}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix build failure with USE="-libnotify", bug #314123
+ epatch "${FILESDIR}/${P}-build-failure-notify.patch"
+}
diff --git a/mail-client/balsa/files/balsa-2.4.7-build-failure-notify.patch b/mail-client/balsa/files/balsa-2.4.7-build-failure-notify.patch
new file mode 100644
index 000000000000..b4bd7d2c8808
--- /dev/null
+++ b/mail-client/balsa/files/balsa-2.4.7-build-failure-notify.patch
@@ -0,0 +1,29 @@
+From 45e0d4d656079f572a9fc39688705ede2eba15c8 Mon Sep 17 00:00:00 2001
+From: Peter Bloomfield <PeterBloomfield@bellsouth.net>
+Date: Tue, 16 Feb 2010 18:59:21 -0500
+Subject: [PATCH] Build when libnotify is not available
+
+ * libbalsa/information.c: build when libnotify is not available.
+---
+ libbalsa/information.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/libbalsa/information.c b/libbalsa/information.c
+index e752200..7f3c8fe 100644
+--- a/libbalsa/information.c
++++ b/libbalsa/information.c
+@@ -41,10 +41,10 @@ static gboolean libbalsa_information_idle_handler(struct information_data*);
+
+ LibBalsaInformationFunc libbalsa_real_information_func;
+
++#ifdef HAVE_NOTIFY
+ static void lbi_notification_closed_cb(NotifyNotification * note,
+ gpointer data);
+
+-#ifdef HAVE_NOTIFY
+ static void
+ lbi_notification_parent_weak_notify(gpointer data, GObject * parent)
+ {
+--
+1.7.0.4
+