summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 10:07:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 10:07:20 +0000
commitbe12fc045d9b519860b063cd9945ee25a2762758 (patch)
tree151270c0de7b114287366e3544854b0299ee9425 /mail-client/balsa
parentVersion bump (diff)
downloadgentoo-2-be12fc045d9b519860b063cd9945ee25a2762758.tar.gz
gentoo-2-be12fc045d9b519860b063cd9945ee25a2762758.tar.bz2
gentoo-2-be12fc045d9b519860b063cd9945ee25a2762758.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/balsa')
-rw-r--r--mail-client/balsa/ChangeLog6
-rw-r--r--mail-client/balsa/balsa-2.4.8.ebuild9
-rw-r--r--mail-client/balsa/files/balsa-2.4.8-libnotify-0.7.patch51
3 files changed, 63 insertions, 3 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index 099082cd1ffe..60eef1ec9439 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/balsa
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.104 2011/01/24 16:33:42 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.105 2011/02/05 10:07:19 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> balsa-2.4.8.ebuild,
+ +files/balsa-2.4.8-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
24 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org> balsa-2.4.8.ebuild:
Pin dependencies to appropriate slots.
diff --git a/mail-client/balsa/balsa-2.4.8.ebuild b/mail-client/balsa/balsa-2.4.8.ebuild
index 2390f8374334..25407a51c86c 100644
--- a/mail-client/balsa/balsa-2.4.8.ebuild
+++ b/mail-client/balsa/balsa-2.4.8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.4.8.ebuild,v 1.2 2011/01/24 16:33:42 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.4.8.ebuild,v 1.3 2011/02/05 10:07:19 ssuominen Exp $
EAPI="2"
GCONF_DEBUG="no"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Email client for GNOME"
HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
@@ -100,3 +100,8 @@ pkg_setup() {
$(use_with ssl)
$(use_with xface compface)"
}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
diff --git a/mail-client/balsa/files/balsa-2.4.8-libnotify-0.7.patch b/mail-client/balsa/files/balsa-2.4.8-libnotify-0.7.patch
new file mode 100644
index 000000000000..0cef7f54ac8f
--- /dev/null
+++ b/mail-client/balsa/files/balsa-2.4.8-libnotify-0.7.patch
@@ -0,0 +1,51 @@
+--- libbalsa/information.c
++++ libbalsa/information.c
+@@ -27,6 +27,9 @@
+
+ #ifdef HAVE_NOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #include <gtk/gtk.h>
+ #endif
+ #include <string.h>
+@@ -122,7 +125,11 @@
+ g_free(msg);
+
+ note =
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notify_notification_new("Balsa", escaped->str, icon_str);
++#else
+ notify_notification_new("Balsa", escaped->str, icon_str, NULL);
++#endif
+ g_string_free(escaped, TRUE);
+
+ notify_notification_set_timeout(note, 7000); /* 7 seconds */
+--- src/main-window.c
++++ src/main-window.c
+@@ -85,6 +85,12 @@
+
+ #define MAILBOX_DATA "mailbox_data"
+
++#ifdef HAVE_NOTIFY
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++#endif
++
+ enum {
+ OPEN_MAILBOX_NODE,
+ CLOSE_MAILBOX_NODE,
+@@ -3406,7 +3412,11 @@
+ } else {
+ num_total = num_new;
+ balsa_app.main_window->new_mail_note =
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notify_notification_new("Balsa", NULL, NULL);
++#else
+ notify_notification_new("Balsa", NULL, NULL, NULL);
++#endif
+ g_object_add_weak_pointer(G_OBJECT(balsa_app.main_window->
+ new_mail_note),
+ (gpointer) & balsa_app.main_window->