summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-05 05:24:19 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-05 05:24:19 +0000
commitef5531bcae03b5d86ef7f4883493c4b5de1d7996 (patch)
treedb9d695b5143718060888ac0032059d58a9d228a /lxde-base
parentFixing infinite loop, bug #280399 , Patch thanks to Yuan Ye <yuanyelele@gmail... (diff)
downloadgentoo-2-ef5531bcae03b5d86ef7f4883493c4b5de1d7996.tar.gz
gentoo-2-ef5531bcae03b5d86ef7f4883493c4b5de1d7996.tar.bz2
gentoo-2-ef5531bcae03b5d86ef7f4883493c4b5de1d7996.zip
Fixing infinite loop, bug #280399 , Patch thanks to Yuan Ye <yuanyelele@gmail.com>
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxshortcut/ChangeLog7
-rw-r--r--lxde-base/lxshortcut/files/lxshortcut-0.1.1-intltool.patch15
-rw-r--r--lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild15
3 files changed, 35 insertions, 2 deletions
diff --git a/lxde-base/lxshortcut/ChangeLog b/lxde-base/lxshortcut/ChangeLog
index 20d1012c8f99..6841dc53d0f7 100644
--- a/lxde-base/lxshortcut/ChangeLog
+++ b/lxde-base/lxshortcut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxshortcut
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxshortcut/ChangeLog,v 1.1 2009/08/04 19:16:27 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxshortcut/ChangeLog,v 1.2 2009/08/05 05:24:18 vostorga Exp $
+
+ 05 Aug 2009; <vostorga@gentoo.org> lxshortcut-0.1.1.ebuild,
+ +files/lxshortcut-0.1.1-intltool.patch:
+ Fixing infinite loop, bug #280399
+ Patch thanks to Yuan Ye <yuanyelele@gmail.com>
*lxshortcut-0.1.1 (04 Aug 2009)
diff --git a/lxde-base/lxshortcut/files/lxshortcut-0.1.1-intltool.patch b/lxde-base/lxshortcut/files/lxshortcut-0.1.1-intltool.patch
new file mode 100644
index 000000000000..50e3bc689197
--- /dev/null
+++ b/lxde-base/lxshortcut/files/lxshortcut-0.1.1-intltool.patch
@@ -0,0 +1,15 @@
+diff -NrU5 lxshortcut-0.1.1.original/configure.in lxshortcut-0.1.1/configure.in
+--- lxshortcut-0.1.1.original/configure.in 2009-08-04 23:06:40.000000000 -0600
++++ lxshortcut-0.1.1/configure.in 2009-08-04 23:07:11.000000000 -0600
+@@ -2,10 +2,11 @@
+
+ AC_INIT(configure.in)
+ AM_INIT_AUTOMAKE(lxshortcut, 0.1.1)
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
++IT_PROG_INTLTOOL
+
+ AC_ISC_POSIX
+ AC_PROG_CC
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
diff --git a/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild b/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild
index 30bcc8066e8a..6b5890b955d5 100644
--- a/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild
+++ b/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild,v 1.1 2009/08/04 19:16:27 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxshortcut/lxshortcut-0.1.1.ebuild,v 1.2 2009/08/05 05:24:18 vostorga Exp $
EAPI="1"
+inherit autotools eutils
+
DESCRIPTION="LXDE tool to edit desktop entry files"
HOMEPAGE="http://lxde.sourceforge.net/"
SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
@@ -19,6 +21,17 @@ DEPEND="${RDEPEND}
sys-devel/gettext
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-intltool.patch
+
+ # Rerun autotools
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog README || die "dodoc failed"