summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-18 10:11:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-18 10:11:51 +0000
commit9190af77f773e05d2e56e2610e02c667af84fc9e (patch)
tree8ee80e5507a50af92a0c4234bc5c1337e1ef02ff /lxde-base
parentAdd version 0.8.4 (diff)
downloadgentoo-2-9190af77f773e05d2e56e2610e02c667af84fc9e.tar.gz
gentoo-2-9190af77f773e05d2e56e2610e02c667af84fc9e.tar.bz2
gentoo-2-9190af77f773e05d2e56e2610e02c667af84fc9e.zip
Do not start pcmanfm with -d option. Bug #367639
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxde-common/ChangeLog8
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch2
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.0-r2.ebuild41
3 files changed, 49 insertions, 2 deletions
diff --git a/lxde-base/lxde-common/ChangeLog b/lxde-base/lxde-common/ChangeLog
index d5a3a26c6c50..aef58829861a 100644
--- a/lxde-base/lxde-common/ChangeLog
+++ b/lxde-base/lxde-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxde-base/lxde-common
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.20 2011/03/07 20:33:35 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.21 2011/05/18 10:11:51 hwoarang Exp $
+
+*lxde-common-0.5.0-r2 (18 May 2011)
+
+ 18 May 2011; Markos Chandras <hwoarang@gentoo.org>
+ +lxde-common-0.5.0-r2.ebuild, files/lxde-common-0.5.0-desktop-icons.patch:
+ Do not start pcmanfm with -d option. Bug #367639
07 Mar 2011; Tobias Klausmann <klausman@gentoo.org>
lxde-common-0.5.0-r1.ebuild:
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
index b96a06ef3671..c751ae64dba3 100644
--- a/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
@@ -5,4 +5,4 @@ diff -NrU5 lxde-common-0.5.0.original/autostart lxde-common-0.5.0/autostart
@xscreensaver -no-splash
@lxpanel --profile LXDE
-@pcmanfm -d
-+@pcmanfm -d --desktop
++@pcmanfm --desktop
diff --git a/lxde-base/lxde-common/lxde-common-0.5.0-r2.ebuild b/lxde-base/lxde-common/lxde-common-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..9cd379b45783
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/lxde-common-0.5.0-r2.ebuild,v 1.1 2011/05/18 10:11:51 hwoarang Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-session-fix.patch
+ epatch "${FILESDIR}"/${P}-desktop-icons.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}