summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-14 18:16:24 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-14 18:16:24 +0000
commit2d722184fa7fe8665fb8e330e50243f040e56dc8 (patch)
treead994b581208fa66828cbc66ace62e99df4c3ecc /lxde-base
parentamd64/arm/x86 stable wrt #510316 (diff)
downloadgentoo-2-2d722184fa7fe8665fb8e330e50243f040e56dc8.tar.gz
gentoo-2-2d722184fa7fe8665fb8e330e50243f040e56dc8.tar.bz2
gentoo-2-2d722184fa7fe8665fb8e330e50243f040e56dc8.zip
[QA] EAPI 1 -> 5. Added missing dependencies using ELF's NEEDED entries. Support as-needed.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxlauncher/ChangeLog9
-rw-r--r--lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild24
2 files changed, 18 insertions, 15 deletions
diff --git a/lxde-base/lxlauncher/ChangeLog b/lxde-base/lxlauncher/ChangeLog
index fd5516d3a32f..5731e3f85518 100644
--- a/lxde-base/lxlauncher/ChangeLog
+++ b/lxde-base/lxlauncher/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for lxde-base/lxlauncher
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/ChangeLog,v 1.16 2012/06/05 01:02:28 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/ChangeLog,v 1.17 2014/05/14 18:16:24 tomwij Exp $
+
+ 14 May 2014; Tom Wijsman <TomWij@gentoo.org> lxlauncher-0.2.1-r1.ebuild:
+ [QA] EAPI 1 -> 5. Added missing dependencies using ELF's NEEDED entries.
+ Support as-needed.
05 Jun 2012; Michael Weber <xmw@gentoo.org> lxlauncher-0.2.2.ebuild:
ppc stable (bug 385189)
@@ -64,4 +68,3 @@
07 Nov 2008; Ben de Groot <yngwin@gentoo.org> +metadata.xml,
+lxlauncher-0.2.ebuild:
Initial import of ebuild from lxde overlay
-
diff --git a/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild b/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild
index 22e6cd77e0ce..53b30c7d65cb 100644
--- a/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild
+++ b/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild,v 1.3 2012/05/04 05:50:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild,v 1.4 2014/05/14 18:16:24 tomwij Exp $
-EAPI="1"
+EAPI="5"
inherit autotools eutils
@@ -16,8 +16,11 @@ KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="dev-libs/glib:2
- x11-libs/gtk+:2
gnome-base/gnome-menus
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
x11-libs/startup-notification"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -26,19 +29,16 @@ DEPEND="${RDEPEND}
lxde-base/menu-cache
!lxde-base/lxlauncher-gmenu"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-intltool.patch
epatch "${FILESDIR}"/${P}-fix-segfault.patch
# Rerun autotools
einfo "Regenerating autotools files..."
eautoreconf
-}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README
+ # Support as-needed and add missing libraries.
+ sed -e 's/^\(LINK = .*\) -o $@$/\1/' \
+ -e 's/$(lxlauncher_OBJECTS) $(lxlauncher_LDADD) $(LIBS)/\0 -lX11 -o $@/' \
+ -i src/Makefile.in || die
}