summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Kazakov <nullishzero@gentoo.org>2014-09-10 01:54:45 +0000
committerPavel Kazakov <nullishzero@gentoo.org>2014-09-10 01:54:45 +0000
commit290492fd1131fedf42b66139f9ff0c099bfe2a9a (patch)
tree27690dc7f83268d775a5c065676b0b13981017fa /lxde-base
parentVersion bump, resolves bug 522466. (diff)
downloadgentoo-2-290492fd1131fedf42b66139f9ff0c099bfe2a9a.tar.gz
gentoo-2-290492fd1131fedf42b66139f9ff0c099bfe2a9a.tar.bz2
gentoo-2-290492fd1131fedf42b66139f9ff0c099bfe2a9a.zip
Patch for fixing left-click issue, thanks to Jonathan Thibault for bug report (Bug #522404). Also looks as if >=x11-libs/libfm-1.2.0 is a hard dependency now.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x39E7AB2E)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog10
-rw-r--r--lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch25
-rw-r--r--lxde-base/lxpanel/lxpanel-0.7.0-r1.ebuild74
3 files changed, 108 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index f62437329fda..e4590d1af8ff 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.61 2014/09/06 09:03:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.62 2014/09/10 01:54:45 nullishzero Exp $
+
+*lxpanel-0.7.0-r1 (10 Sep 2014)
+
+ 10 Sep 2014; Pavel Kazakov <nullishzero@gentoo.org>
+ +files/lxpanel-0.7.0-right-click-fix.patch, +lxpanel-0.7.0-r1.ebuild:
+ Patch for fixing left-click issue, thanks to Jonathan Thibault for bug report
+ (Bug #522404). Also looks as if >=x11-libs/libfm-1.2.0 is a hard dependency
+ now.
*lxpanel-0.7.0 (06 Sep 2014)
diff --git a/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch b/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch
new file mode 100644
index 000000000000..f6325b6f8c3f
--- /dev/null
+++ b/lxde-base/lxpanel/files/lxpanel-0.7.0-right-click-fix.patch
@@ -0,0 +1,25 @@
+From d4943c80cded6325284be8b58003fe63dd6e8255 Mon Sep 17 00:00:00 2001
+From: Raimar <no@email.de>
+Date: Thu, 21 Aug 2014 23:21:28 +0200
+Subject: [PATCH 1/1] fix crash after click on empty part of panel
+
+---
+ src/panel.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/panel.c b/src/panel.c
+index 6b2ede6..87903d8 100644
+--- a/src/panel.c
++++ b/src/panel.c
+@@ -233,7 +233,7 @@ static gboolean lxpanel_button_press(GtkWidget *widget, GdkEventButton *event)
+ gtk_menu_popup(popup, NULL, NULL, NULL, NULL, event->button, event->time);
+ return TRUE;
+ }
+- return GTK_WIDGET_CLASS(lxpanel_parent_class)->button_press_event(widget, event);
++ return FALSE;
+ }
+
+ static void lxpanel_class_init(PanelToplevelClass *klass)
+--
+1.7.10.4
+
diff --git a/lxde-base/lxpanel/lxpanel-0.7.0-r1.ebuild b/lxde-base/lxpanel/lxpanel-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..4d157f3d935c
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.7.0-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.7.0-r1.ebuild,v 1.1 2014/09/10 01:54:45 nullishzero Exp $
+
+EAPI="4"
+
+inherit autotools eutils readme.gentoo versionator
+
+MAJOR_VER="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${MAJOR_VER}.x/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa wifi"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ >=x11-libs/libfm-1.2.0
+ x11-libs/libwnck:1
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOC_CONTENTS="If you have problems with broken icons shown in the main panel,
+you will have to configure panel settings via its menu.
+This will not be an issue with first time installations."
+
+src_prepare() {
+ #bug #522404
+ epatch "${FILESDIR}"/${PN}-0.7.0-right-click-fix.patch
+ epatch "${FILESDIR}"/${PN}-0.5.9-sandbox.patch
+ #bug #415595
+ sed -i "s:-Werror::" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local plugins="netstatus,volume,cpu,deskno,batt, \
+ kbled,xkb,thermal,cpufreq,monitors"
+
+ use wifi && plugins+=",netstat"
+ use alsa && plugins+=",volumealsa"
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins="${plugins}"
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+
+ # Get rid of the .la files.
+ find "${D}" -name '*.la' -delete
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}