summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-07-29 13:59:53 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-07-29 13:59:53 +0000
commit5cdf15435a3b46c4d52842170e61894f32c3ead9 (patch)
treeca9aff7070dcb9f8c1949cb27ef312738a86ff9c /lxde-base/lxde-common
parentStable on amd64 wrt bug #329627 (diff)
downloadgentoo-2-5cdf15435a3b46c4d52842170e61894f32c3ead9.tar.gz
gentoo-2-5cdf15435a3b46c4d52842170e61894f32c3ead9.tar.bz2
gentoo-2-5cdf15435a3b46c4d52842170e61894f32c3ead9.zip
Showing desktop icons as expected, patch thanks to Lucas Paul <reilithion@gmail.com> , bug #327545
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'lxde-base/lxde-common')
-rw-r--r--lxde-base/lxde-common/ChangeLog10
-rw-r--r--lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch8
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.0-r1.ebuild41
3 files changed, 58 insertions, 1 deletions
diff --git a/lxde-base/lxde-common/ChangeLog b/lxde-base/lxde-common/ChangeLog
index 5e22e10134d2..b4b933376ac2 100644
--- a/lxde-base/lxde-common/ChangeLog
+++ b/lxde-base/lxde-common/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for lxde-base/lxde-common
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.14 2010/02/28 18:34:40 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.15 2010/07/29 13:59:53 vostorga Exp $
+
+*lxde-common-0.5.0-r1 (29 Jul 2010)
+
+ 29 Jul 2010; Víctor Ostorga <vostorga@gentoo.org>
+ +lxde-common-0.5.0-r1.ebuild,
+ +files/lxde-common-0.5.0-desktop-icons.patch:
+ Showing desktop icons as expected, patch thanks to Lucas Paul
+ <reilithion@gmail.com> , bug #327545
28 Feb 2010; nixnut <nixnut@gentoo.org> lxde-common-0.5.0.ebuild:
ppc stable #306433
diff --git a/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
new file mode 100644
index 000000000000..b96a06ef3671
--- /dev/null
+++ b/lxde-base/lxde-common/files/lxde-common-0.5.0-desktop-icons.patch
@@ -0,0 +1,8 @@
+diff -NrU5 lxde-common-0.5.0.original/autostart lxde-common-0.5.0/autostart
+--- lxde-common-0.5.0.original/autostart 2009-07-14 13:39:53.000000000 +0200
++++ lxde-common-0.5.0/autostart 2010-07-29 15:42:14.585488801 +0200
+@@ -1,3 +1,3 @@
+ @xscreensaver -no-splash
+ @lxpanel --profile LXDE
+-@pcmanfm -d
++@pcmanfm -d --desktop
diff --git a/lxde-base/lxde-common/lxde-common-0.5.0-r1.ebuild b/lxde-base/lxde-common/lxde-common-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..036e2102ac7c
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/lxde-common-0.5.0-r1.ebuild,v 1.1 2010/07/29 13:59:53 vostorga Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-session-fix.patch
+ epatch "${FILESDIR}"/${P}-desktop-icons.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}