summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 15:15:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-21 15:15:38 +0000
commite09e3143c6b230c5da0a206750dd8afdab546795 (patch)
tree12c753ec7f08b80232838db6556c6cc3645f5184 /kde-misc
parentAdd patch by Philipp to build with GCC 4.3 (bug #212833). (diff)
downloadgentoo-2-e09e3143c6b230c5da0a206750dd8afdab546795.tar.gz
gentoo-2-e09e3143c6b230c5da0a206750dd8afdab546795.tar.bz2
gentoo-2-e09e3143c6b230c5da0a206750dd8afdab546795.zip
Add patch to build with GCC 4.3.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tork/ChangeLog6
-rw-r--r--kde-misc/tork/files/tork-0.27+gcc-4.3.patch64
-rw-r--r--kde-misc/tork/tork-0.27.ebuild5
3 files changed, 72 insertions, 3 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index e6b407ee0ea7..bb58e67906f4 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.28 2008/03/29 01:18:20 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.29 2008/04/21 15:15:37 flameeyes Exp $
+
+ 21 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tork-0.27+gcc-4.3.patch, tork-0.27.ebuild:
+ Add patch to build with GCC 4.3.
*tork-0.27 (29 Mar 2008)
diff --git a/kde-misc/tork/files/tork-0.27+gcc-4.3.patch b/kde-misc/tork/files/tork-0.27+gcc-4.3.patch
new file mode 100644
index 000000000000..e0d0b3443caf
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.27+gcc-4.3.patch
@@ -0,0 +1,64 @@
+Index: tork-0.27/src/functions.cpp
+===================================================================
+--- tork-0.27.orig/src/functions.cpp
++++ tork-0.27/src/functions.cpp
+@@ -29,6 +29,7 @@
+
+ #include "functions.h"
+
++#include <cstdlib>
+
+ namespace tk
+ {
+Index: tork-0.27/src/hiddensrvs.ui.h
+===================================================================
+--- tork-0.27.orig/src/hiddensrvs.ui.h
++++ tork-0.27/src/hiddensrvs.ui.h
+@@ -29,6 +29,8 @@
+ #include <kprocio.h>
+ #include <kmessagebox.h>
+
++#include <cstdlib>
++
+ void MyHidden::init()
+ {
+
+Index: tork-0.27/src/hidsrvwizard.ui.h
+===================================================================
+--- tork-0.27.orig/src/hidsrvwizard.ui.h
++++ tork-0.27/src/hidsrvwizard.ui.h
+@@ -23,6 +23,8 @@
+ #include <qtimer.h>
+ #include <kmessagebox.h>
+
++#include <cstdlib>
++
+ bool local;
+ QString thttpd;
+
+Index: tork-0.27/src/mixminion.ui.h
+===================================================================
+--- tork-0.27.orig/src/mixminion.ui.h
++++ tork-0.27/src/mixminion.ui.h
+@@ -26,6 +26,8 @@
+ #include <qtimer.h>
+ #include "torkconfig.h"
+
++#include <cstdlib>
++
+ KProgressDialog* progressDialog;
+ QString output;
+
+Index: tork-0.27/src/newfirstrunwizard.ui.h
+===================================================================
+--- tork-0.27.orig/src/newfirstrunwizard.ui.h
++++ tork-0.27/src/newfirstrunwizard.ui.h
+@@ -40,6 +40,8 @@
+ #include <krun.h>
+ #include <qvaluevector.h>
+
++#include <cstdlib>
++
+ #include "functions.h"
+
+ TorClient* client;
diff --git a/kde-misc/tork/tork-0.27.ebuild b/kde-misc/tork/tork-0.27.ebuild
index a20bfdbbaa24..a7f133c5b94f 100644
--- a/kde-misc/tork/tork-0.27.ebuild
+++ b/kde-misc/tork/tork-0.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.27.ebuild,v 1.1 2008/03/29 01:18:20 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.27.ebuild,v 1.2 2008/04/21 15:15:37 flameeyes Exp $
inherit kde multilib
@@ -26,7 +26,8 @@ RDEPEND="${DEPEND}
need-kde 3.5
-PATCHES="${FILESDIR}/${P}-ext_tsocks.patch"
+PATCHES=( "${FILESDIR}/${P}-ext_tsocks.patch"
+ "${FILESDIR}/${P}+gcc-4.3.patch" )
src_compile() {
# Fix desktop file