summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-07-06 20:11:01 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-07-06 20:11:01 +0000
commitc06d8db4d1cd8e7829af1f783a2f91ee5c233783 (patch)
tree66f3b64b700e56507b0d9e0b185590edb824fcec /kde-misc
parentRemove obsolete dev-libs/tdb (xdb) backend and include stdio.h for GCC 4.4 wr... (diff)
downloadgentoo-2-c06d8db4d1cd8e7829af1f783a2f91ee5c233783.tar.gz
gentoo-2-c06d8db4d1cd8e7829af1f783a2f91ee5c233783.tar.bz2
gentoo-2-c06d8db4d1cd8e7829af1f783a2f91ee5c233783.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/ChangeLog8
-rw-r--r--kde-misc/kanyremote/files/disable_bluetooth.patch17
-rw-r--r--kde-misc/kanyremote/kanyremote-5.10.ebuild32
3 files changed, 56 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 115792460736..42c59a6ece14 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.2 2009/04/26 11:43:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.3 2009/07/06 20:11:01 hwoarang Exp $
+
+*kanyremote-5.10 (06 Jul 2009)
+
+ 06 Jul 2009; Markos Chandras <hwoarang@gentoo.org>
+ +kanyremote-5.10.ebuild, +files/disable_bluetooth.patch:
+ Version bump. First PyQt4 release
26 Apr 2009; Markos Chandras <hwoarang@gentoo.org> kanyremote-5.8.2:
Add dev-python/pybluez dependency. Fixes bug #267499
diff --git a/kde-misc/kanyremote/files/disable_bluetooth.patch b/kde-misc/kanyremote/files/disable_bluetooth.patch
new file mode 100644
index 000000000000..214e9f257a32
--- /dev/null
+++ b/kde-misc/kanyremote/files/disable_bluetooth.patch
@@ -0,0 +1,17 @@
+Index: kanyremote-5.10/kanyremote
+===================================================================
+--- kanyremote-5.10.orig/kanyremote
++++ kanyremote-5.10/kanyremote
+@@ -3777,8 +3777,10 @@ def main():
+ usepybluez = False
+
+ if pybluez == False and usepybluez == True:
+- print _tr('Install PyBluez first !\nOr run with --npybluez option')
+- return
++# print _tr('Install PyBluez first !\nOr run with --npybluez option')
++ print _tr('Bluetooth support is disabled')
++ usepybluez = False
++# return
+
+ if debug: print 'Use port ' + port
+
diff --git a/kde-misc/kanyremote/kanyremote-5.10.ebuild b/kde-misc/kanyremote/kanyremote-5.10.ebuild
new file mode 100644
index 000000000000..8518b8e78f16
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.10.ebuild,v 1.1 2009/07/06 20:11:01 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=">=net-misc/anyremote-4.4[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}