summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-01-30 16:47:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-01-30 16:47:39 +0000
commit90aa6bdbc0bdb7c6f2f1291d05e39f9fe8bdb1a6 (patch)
treea16bae0b1783531baae45576ca2e00b165452d2d /kde-misc
parentStable for amd64, wrt bug #401229 (diff)
downloadgentoo-2-90aa6bdbc0bdb7c6f2f1291d05e39f9fe8bdb1a6.tar.gz
gentoo-2-90aa6bdbc0bdb7c6f2f1291d05e39f9fe8bdb1a6.tar.bz2
gentoo-2-90aa6bdbc0bdb7c6f2f1291d05e39f9fe8bdb1a6.zip
Add new snapshot from a more active fork. Snapshot is patched to build with kde 4.8. Remove old snapshot violates naming scheme. Fixes bug #400863.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/smooth-tasks/ChangeLog12
-rw-r--r--kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch176
-rw-r--r--kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild (renamed from kde-misc/smooth-tasks/smooth-tasks-20101106.ebuild)17
3 files changed, 195 insertions, 10 deletions
diff --git a/kde-misc/smooth-tasks/ChangeLog b/kde-misc/smooth-tasks/ChangeLog
index 3ad0ee19a2bf..7880377c9188 100644
--- a/kde-misc/smooth-tasks/ChangeLog
+++ b/kde-misc/smooth-tasks/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-misc/smooth-tasks
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/smooth-tasks/ChangeLog,v 1.4 2011/10/29 00:07:54 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/smooth-tasks/ChangeLog,v 1.5 2012/01/30 16:47:39 johu Exp $
+
+*smooth-tasks-0_p20120130 (30 Jan 2012)
+
+ 30 Jan 2012; Johannes Huber <johu@gentoo.org>
+ +files/smooth-tasks-0_p20120130-kde48.patch, +smooth-tasks-0_p20120130.ebuild,
+ -smooth-tasks-20101106.ebuild:
+ Add new snapshot from a more active fork. Snapshot is patched to build with
+ kde 4.8. Remove old snapshot violates naming scheme. Fixes bug #400863.
29 Oct 2011; Jonathan Callen <abcd@gentoo.org> smooth-tasks-20101106.ebuild:
Bump to EAPI=4
diff --git a/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch b/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch
new file mode 100644
index 000000000000..c754ba1c2fe5
--- /dev/null
+++ b/kde-misc/smooth-tasks/files/smooth-tasks-0_p20120130-kde48.patch
@@ -0,0 +1,176 @@
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/PlasmaToolTip.cpp src/smooth-tasks-fork/applet/SmoothTasksX/PlasmaToolTip.cpp
+--- src/smooth-tasks-fork/applet/SmoothTasks/PlasmaToolTip.cpp 2011-12-24 03:13:55.604361299 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/PlasmaToolTip.cpp 2011-12-24 03:11:00.000000000 +0100
+@@ -91,7 +91,7 @@
+ }
+
+ Plasma::ToolTipContent data;
+- TaskManager::TaskPtr taskPtr(task->task());
++ TaskManager::Task* taskPtr(task->task());
+ QList<WId> windows;
+ int desktop = -1;
+
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/SmoothToolTip.cpp src/smooth-tasks-fork/applet/SmoothTasksX/SmoothToolTip.cpp
+--- src/smooth-tasks-fork/applet/SmoothTasks/SmoothToolTip.cpp 2011-12-24 03:13:55.605361287 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/SmoothToolTip.cpp 2011-12-24 03:10:24.000000000 +0100
+@@ -474,7 +474,7 @@
+ foreach (WindowPreview *preview, m_previews) {
+ preview->show();
+
+- TaskManager::TaskPtr task = preview->task()->task();
++ TaskManager::Task* task = preview->task()->task();
+
+ if (task && preview->task()->type() != Task::StartupItem && preview->task()->type() != Task::LauncherItem) {
+ winIds.append(task->window());
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/Task.cpp src/smooth-tasks-fork/applet/SmoothTasksX/Task.cpp
+--- src/smooth-tasks-fork/applet/SmoothTasks/Task.cpp 2011-12-24 03:13:55.606361275 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/Task.cpp 2011-12-24 03:07:21.000000000 +0100
+@@ -118,8 +118,8 @@
+ }
+
+ QString Task::text() const {
+- TaskManager::TaskPtr task;
+- TaskManager::StartupPtr startup;
++ TaskManager::Task *task;
++ TaskManager::Startup *startup;
+
+ switch (type()) {
+ case StartupItem:
+@@ -186,12 +186,23 @@
+ return m_task ? m_task->task()->desktop() : -1;
+ }
+
+-TaskManager::TaskPtr Task::task() const {
+- return m_task ? m_task->task() : TaskManager::TaskPtr();
+-}
+-
+-TaskManager::StartupPtr Task::startup() const {
+- return m_task ? m_task->startup() : TaskManager::StartupPtr();
++TaskManager::Task* Task::task() const {
++ if (m_task) {
++ return m_task->task();
++ } else {
++ TaskManager::Task *task;
++ return task;
++ }
++ //return m_task ? m_task->task() : ::TaskManager::Task task;
++}
++
++TaskManager::Startup* Task::startup() const {
++ if (m_task) {
++ return m_task->startup();
++ } else {
++ TaskManager::Startup* startup;
++ return startup;
++ }
+ }
+
+ int Task::taskCount() const {
+@@ -309,7 +320,7 @@
+ void Task::setWindowTask(TaskManager::TaskItem* taskItem) {
+ m_type = TaskItem;
+ if (m_task && m_task->task()) {
+- disconnect(m_task->task().constData(), 0, this, 0);
++ disconnect(m_task->task(), 0, this, 0);
+ }
+
+ m_task = taskItem;
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/Task.h src/smooth-tasks-fork/applet/SmoothTasksX/Task.h
+--- src/smooth-tasks-fork/applet/SmoothTasks/Task.h 2011-12-24 03:13:55.607361262 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/Task.h 2011-12-24 02:34:23.000000000 +0100
+@@ -78,12 +78,12 @@
+ QString text() const;
+ QString description() const;
+ int desktop() const;
+- TaskManager::TaskPtr task() const;
++ TaskManager::Task *task() const;
+ TaskManager::AbstractGroupableItem *abstractItem() { return m_abstractItem; }
+ TaskManager::GroupPtr group() const { return m_group; }
+- TaskManager::TaskItem *taskItem() const { return m_task; }
++ TaskManager::TaskItem *taskItem() const { return m_task; }
+ TaskManager::LauncherItem *launcherItem() const { return m_launcher; }
+- TaskManager::StartupPtr startup() const;
++ TaskManager::Startup *startup() const;
+ TaskFlags flags() const { return m_flags; }
+ ItemType type() const { return m_type; }
+ void addMimeData(QMimeData* mimeData);
+Only in src/smooth-tasks-fork/applet/SmoothTasksX: .Task.h.kate-swp
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/TaskItem.cpp src/smooth-tasks-fork/applet/SmoothTasksX/TaskItem.cpp
+--- src/smooth-tasks-fork/applet/SmoothTasks/TaskItem.cpp 2011-12-24 03:13:55.610361223 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/TaskItem.cpp 2011-12-24 03:09:11.000000000 +0100
+@@ -375,7 +375,7 @@
+
+ void TaskItem::publishIconGeometry() {
+ QRect iconRect(iconGeometry());
+- TaskManager::TaskPtr task;
++ TaskManager::Task *task;
+ TaskManager::GroupPtr group;
+
+ switch (m_task->type()) {
+@@ -465,7 +465,7 @@
+ }
+
+ void TaskItem::mouseReleaseEvent(QGraphicsSceneMouseEvent *event) {
+- TaskManager::TaskPtr task;
++ TaskManager::Task* task;
+
+ switch (event->button()) {
+ case Qt::LeftButton:
+@@ -626,7 +626,7 @@
+ }
+
+ void TaskItem::activate() {
+- TaskManager::TaskPtr task;
++ TaskManager::Task* task;
+
+ switch (m_task->type()) {
+ case Task::TaskItem:
+Common subdirectories: src/smooth-tasks-fork/applet/SmoothTasks/Ui and src/smooth-tasks-fork/applet/SmoothTasksX/Ui
+diff -u src/smooth-tasks-fork/applet/SmoothTasks/WindowPreview.cpp src/smooth-tasks-fork/applet/SmoothTasksX/WindowPreview.cpp
+--- src/smooth-tasks-fork/applet/SmoothTasks/WindowPreview.cpp 2011-12-24 03:13:55.619361111 +0100
++++ src/smooth-tasks-fork/applet/SmoothTasksX/WindowPreview.cpp 2011-12-24 03:12:49.000000000 +0100
+@@ -117,7 +117,7 @@
+ if (m_toolTip->previewsAvailable()) {
+ // determine preview size:
+ WId wid = 0;
+- TaskManager::TaskPtr task = m_task->task();
++ TaskManager::Task* task = m_task->task();
+
+ if (task) {
+ wid = task->window();
+@@ -297,7 +297,7 @@
+ }
+
+ void WindowPreview::highlightTask() {
+- TaskManager::TaskPtr task = m_task->task();
++ TaskManager::Task* task = m_task->task();
+
+ if (task) {
+ m_toolTip->highlightTask(task->window());
+@@ -325,7 +325,7 @@
+ m_toolTip->hide();
+
+ if(m_task->type() != Task::LauncherItem) {
+- TaskManager::TaskPtr task = m_task->task();
++ TaskManager::Task* task = m_task->task();
+ if (task) {
+ task->activate();
+ }
+@@ -336,7 +336,7 @@
+ }
+
+ void WindowPreview::activateForDrop() {
+- TaskManager::TaskPtr task = m_task->task();
++ TaskManager::Task* task = m_task->task();
+ if (task) {
+ if (task->isMinimized()) {
+ task->restore();
+@@ -347,7 +347,7 @@
+ }
+
+ void WindowPreview::closeTask() {
+- TaskManager::TaskPtr task = m_task->task();
++ TaskManager::Task* task = m_task->task();
+ if (task) {
+ task->close();
+ }
diff --git a/kde-misc/smooth-tasks/smooth-tasks-20101106.ebuild b/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild
index 758f42d46b53..77f37436364b 100644
--- a/kde-misc/smooth-tasks/smooth-tasks-20101106.ebuild
+++ b/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild
@@ -1,18 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/smooth-tasks/smooth-tasks-20101106.ebuild,v 1.4 2011/10/29 00:07:54 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/smooth-tasks/smooth-tasks-0_p20120130.ebuild,v 1.1 2012/01/30 16:47:39 johu Exp $
EAPI=4
KDE_LINGUAS="cs de fr hu pl ru zh_CN"
-KDE_MINIMAL="4.5"
inherit kde4-base
-MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-
DESCRIPTION="Alternate taskbar KDE plasmoid, similar to Windows 7"
-HOMEPAGE="http://www.kde-look.org/content/show.php/Smooth+Tasks?content=101586"
-SRC_URI="http://kde-look.org/CONTENT/content-files/101586-${PN}-src-wip-${MY_PV}.tar.bz2"
+HOMEPAGE="https://bitbucket.org/flupp/smooth-tasks-fork"
+SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="4"
@@ -26,4 +23,8 @@ RDEPEND="${DEPEND}
$(add_kdebase_dep plasma-workspace)
"
-S="${WORKDIR}/${PN}-src-wip-${MY_PV}"
+PATCHES=(
+ "${FILESDIR}/${P}-kde48.patch"
+)
+
+S="${WORKDIR}/${PN}"