summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-03-04 10:25:51 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-03-04 10:25:51 +0000
commit8e48674640bd2af369c7593c87ceb4b6ac0e6567 (patch)
tree31bccc7e04223c626ae6a01307652e9b96880d07 /kde-misc
parentAdd upstream metadata. (diff)
downloadgentoo-2-8e48674640bd2af369c7593c87ceb4b6ac0e6567.tar.gz
gentoo-2-8e48674640bd2af369c7593c87ceb4b6ac0e6567.tar.bz2
gentoo-2-8e48674640bd2af369c7593c87ceb4b6ac0e6567.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/ChangeLog8
-rw-r--r--kde-misc/kanyremote/kanyremote-6.3.5.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 8975a56f0259..be8b3b6d0e8e 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.49 2015/03/04 10:23:15 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.50 2015/03/04 10:25:51 kensington Exp $
+
+*kanyremote-6.3.5 (04 Mar 2015)
+
+ 04 Mar 2015; Michael Palimaka <kensington@gentoo.org>
+ +kanyremote-6.3.5.ebuild:
+ Version bump.
04 Mar 2015; Michael Palimaka <kensington@gentoo.org> metadata.xml:
Add upstream metadata.
diff --git a/kde-misc/kanyremote/kanyremote-6.3.5.ebuild b/kde-misc/kanyremote/kanyremote-6.3.5.ebuild
new file mode 100644
index 000000000000..b1dc06fa10f2
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.3.5.ebuild,v 1.1 2015/03/04 10:25:51 kensington Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth?]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}