summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:15:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 01:15:51 +0000
commit6abcc429d745de84baacca56c4e9fb867cd79433 (patch)
tree61e55fc501cc52774eba485352944a32442d574d /kde-misc
parentNew beta version (diff)
downloadgentoo-2-6abcc429d745de84baacca56c4e9fb867cd79433.tar.gz
gentoo-2-6abcc429d745de84baacca56c4e9fb867cd79433.tar.bz2
gentoo-2-6abcc429d745de84baacca56c4e9fb867cd79433.zip
Version bump, use external GeoIP version now without patch; add instead a patch for GCC 4.1 compatibility.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tork/ChangeLog9
-rw-r--r--kde-misc/tork/files/digest-tork-0.093
-rw-r--r--kde-misc/tork/files/tork-0.09-gcc41.patch13
-rw-r--r--kde-misc/tork/tork-0.09.ebuild35
4 files changed, 59 insertions, 1 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index d519528c62b9..3c99814ce538 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/tork
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.7 2006/09/30 12:04:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.8 2006/10/19 01:15:51 flameeyes Exp $
+
+*tork-0.09 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/tork-0.09-gcc41.patch, +tork-0.09.ebuild:
+ Version bump, use external GeoIP version now without patch; add instead a
+ patch for GCC 4.1 compatibility.
30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
-files/tork-0.07-geoip.patch, -files/tork-0.07-qt335.patch,
diff --git a/kde-misc/tork/files/digest-tork-0.09 b/kde-misc/tork/files/digest-tork-0.09
new file mode 100644
index 000000000000..aaf2990f1a4b
--- /dev/null
+++ b/kde-misc/tork/files/digest-tork-0.09
@@ -0,0 +1,3 @@
+MD5 81f948988302538c15f1978d12c72378 tork-0.09.tar.bz2 1900253
+RMD160 42cc5bc8dc13b5afe9d29c3b405e388b6aa7c0f5 tork-0.09.tar.bz2 1900253
+SHA256 1b572e429db34421f94916830ca7347df228235b6e31d22913f67fb12d9b33fb tork-0.09.tar.bz2 1900253
diff --git a/kde-misc/tork/files/tork-0.09-gcc41.patch b/kde-misc/tork/files/tork-0.09-gcc41.patch
new file mode 100644
index 000000000000..a28b6fbc47ff
--- /dev/null
+++ b/kde-misc/tork/files/tork-0.09-gcc41.patch
@@ -0,0 +1,13 @@
+Index: tork-0.09/src/tork.h
+===================================================================
+--- tork-0.09.orig/src/tork.h
++++ tork-0.09/src/tork.h
+@@ -88,7 +88,7 @@ public:
+ KSystemTray *_tray;
+ torkView *m_view;
+ QDict<QListViewItem> inodes;
+- bool tork::connectedToTor(){return (client!=0) ? true : false;};
++ bool connectedToTor(){return (client!=0) ? true : false;};
+
+ private slots:
+ void fileNew();
diff --git a/kde-misc/tork/tork-0.09.ebuild b/kde-misc/tork/tork-0.09.ebuild
new file mode 100644
index 000000000000..1d98fd8be9f8
--- /dev/null
+++ b/kde-misc/tork/tork-0.09.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.09.ebuild,v 1.1 2006/10/19 01:15:51 flameeyes Exp $
+
+inherit kde
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/geoip-1.4.0"
+
+RDEPEND="net-misc/tor
+ >=net-proxy/privoxy-3.0.3-r5
+ ${DEPEND}"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${P}-gcc41.patch"
+
+src_compile() {
+ local myconf="--with-external-geoip"
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ rm -rf "${D}/usr/share/applnk"
+}