summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-13 21:53:49 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-13 21:53:49 +0000
commit6a2135261da378579e31a73d8a3c706fdda95182 (patch)
tree57aad2a04beb48d39a195c421cc7f3cf9490aa3a /kde-misc
parentAlso use same USE-defaults for live ebuild, spotted by mgorny (diff)
downloadgentoo-2-6a2135261da378579e31a73d8a3c706fdda95182.tar.gz
gentoo-2-6a2135261da378579e31a73d8a3c706fdda95182.tar.bz2
gentoo-2-6a2135261da378579e31a73d8a3c706fdda95182.zip
New package, bug 185523. Thanks to Harry.TX, Julien Cynober, and all the other people who contributed.
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/semantik/ChangeLog12
-rw-r--r--kde-misc/semantik/files/semantik-0.7.3_p20091013-wscript_ldconfig.patch13
-rw-r--r--kde-misc/semantik/metadata.xml5
-rw-r--r--kde-misc/semantik/semantik-0.7.3_p20091013.ebuild38
4 files changed, 68 insertions, 0 deletions
diff --git a/kde-misc/semantik/ChangeLog b/kde-misc/semantik/ChangeLog
new file mode 100644
index 000000000000..3c1f004e3dca
--- /dev/null
+++ b/kde-misc/semantik/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for kde-misc/semantik
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/semantik/ChangeLog,v 1.1 2011/06/13 21:53:49 dilfridge Exp $
+
+*semantik-0.7.3_p20091013 (13 Jun 2011)
+
+ 13 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +semantik-0.7.3_p20091013.ebuild,
+ +files/semantik-0.7.3_p20091013-wscript_ldconfig.patch, +metadata.xml:
+ New package, bug 185523. Thanks to Harry.TX, Julien Cynober, and all the
+ other people who contributed.
+
diff --git a/kde-misc/semantik/files/semantik-0.7.3_p20091013-wscript_ldconfig.patch b/kde-misc/semantik/files/semantik-0.7.3_p20091013-wscript_ldconfig.patch
new file mode 100644
index 000000000000..0229f341660e
--- /dev/null
+++ b/kde-misc/semantik/files/semantik-0.7.3_p20091013-wscript_ldconfig.patch
@@ -0,0 +1,13 @@
+diff -ruN semantik-0.7.4.orig/wscript semantik-0.7.4/wscript
+--- semantik-0.7.4.orig/wscript 2009-10-12 18:26:26.000000000 +0200
++++ semantik-0.7.4/wscript 2011-06-13 15:05:53.246840006 +0200
+@@ -260,9 +260,6 @@
+ opt.add_option('--use64', action='store_true', default=False, help='set the installation into lib+64 (configuration)')
+
+ def post_build(bld):
+- if Options.commands['install']:
+- try: os.popen('/sbin/ldconfig 2> /dev/null')
+- except: pass
+ if Options.options.exe:
+ #os.popen('export LD_LIBRARY_PATH=out/default/:$LD_LIBRARY_PATH; PATH=plugins:$PATH out/default/src/semantik')
+ Utils.pproc.Popen('LD_LIBRARY_PATH=out/default/:$LD_LIBRARY_PATH out/default/src/semantik --style plastique', shell=True).wait()
diff --git a/kde-misc/semantik/metadata.xml b/kde-misc/semantik/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-misc/semantik/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-misc/semantik/semantik-0.7.3_p20091013.ebuild b/kde-misc/semantik/semantik-0.7.3_p20091013.ebuild
new file mode 100644
index 000000000000..efa8bc998714
--- /dev/null
+++ b/kde-misc/semantik/semantik-0.7.3_p20091013.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/semantik/semantik-0.7.3_p20091013.ebuild,v 1.1 2011/06/13 21:53:49 dilfridge Exp $
+
+EAPI=4
+
+inherit kde4-base waf-utils
+
+DESCRIPTION="Mindmapping-like tool for document generation."
+HOMEPAGE="http://freehackers.org/~tnagy/semantik.html"
+SRC_URI="http://semantik.googlecode.com/files/semantik-snapshot.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml
+ dev-lang/python
+"
+RDEPEND="
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-xmlpatterns
+ dev-lang/python[xml]
+"
+
+S="${WORKDIR}/semantik-0.7.4"
+WAF_BINARY="${S}/waf"
+
+PATCHES=( "${FILESDIR}/${P}"-wscript_ldconfig.patch )
+
+src_configure() {
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ "--prefix=${EPREFIX}/usr" --want-rpath=0 \
+ configure || die "configure failed"
+}