summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-08-21 15:12:38 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-08-21 15:12:38 +0000
commit6026c5fa3e778b37f6cb281a4966b8a5989e49c2 (patch)
tree41a72a031a674c457934f7e7251d8538ab08e161 /kde-misc
parentVersion bump. (diff)
downloadgentoo-2-6026c5fa3e778b37f6cb281a4966b8a5989e49c2.tar.gz
gentoo-2-6026c5fa3e778b37f6cb281a4966b8a5989e49c2.tar.bz2
gentoo-2-6026c5fa3e778b37f6cb281a4966b8a5989e49c2.zip
Improved python-related code, thanks to Locke Shinseiko
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/ksplasher/ChangeLog10
-rw-r--r--kde-misc/ksplasher/ksplasher-2.0_beta2-r1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/kde-misc/ksplasher/ChangeLog b/kde-misc/ksplasher/ChangeLog
index 070189c6231d..2dc6267a7345 100644
--- a/kde-misc/ksplasher/ChangeLog
+++ b/kde-misc/ksplasher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/ksplasher
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ChangeLog,v 1.1 2009/11/11 01:05:42 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ChangeLog,v 1.2 2010/08/21 15:12:38 tampakrap Exp $
+
+*ksplasher-2.0_beta2-r1 (21 Aug 2010)
+
+ 21 Aug 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +ksplasher-2.0_beta2-r1.ebuild:
+ Improved python-related code, thanks to Locke Shinseiko
*ksplasher-2.0_beta2 (11 Nov 2009)
diff --git a/kde-misc/ksplasher/ksplasher-2.0_beta2-r1.ebuild b/kde-misc/ksplasher/ksplasher-2.0_beta2-r1.ebuild
new file mode 100644
index 000000000000..ce703da7ddde
--- /dev/null
+++ b/kde-misc/ksplasher/ksplasher-2.0_beta2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/ksplasher/ksplasher-2.0_beta2-r1.ebuild,v 1.1 2010/08/21 15:12:38 tampakrap Exp $
+
+EAPI=2
+PYTHON_DEPEND="2"
+inherit python eutils
+
+DESCRIPTION="a KSplashX engine (KDE4) Splash Screen Creator"
+HOMEPAGE="http://ksplasher.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}x${PV/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/imaging
+ dev-python/PyQt4"
+
+S=${WORKDIR}/${PN}x
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ # ksplasherx is a bash script which calls 'python foo'. We fix it here.
+ sed -i -e 's:python:/usr/bin/env python2:g' ksplasherx || die
+}
+
+src_install() {
+ dobin ksplasherx || die
+ insinto /usr/share/ksplasherx
+ doins -r src || die
+ doicon ksicon.png
+ make_desktop_entry ${PN}x KSplasherX ksicon "Qt;KDE;Graphics"
+ dodoc README
+}