summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-09-08 13:45:42 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-09-08 13:45:42 +0000
commit325fd3baac1060b02427a4aa0245696af4a26bb5 (patch)
treecaa4ffdeab88ade0a2fde008fa80b0a4d71dc839 /kde-misc
parentrevbump -> EAPI 5 (diff)
downloadgentoo-2-325fd3baac1060b02427a4aa0245696af4a26bb5.tar.gz
gentoo-2-325fd3baac1060b02427a4aa0245696af4a26bb5.tar.bz2
gentoo-2-325fd3baac1060b02427a4aa0245696af4a26bb5.zip
Add patch to fix build with KDE 4.10, wrt bug #484102.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/nightmode/ChangeLog9
-rw-r--r--kde-misc/nightmode/files/nightmode-0.3-kde-4.10.patch13
-rw-r--r--kde-misc/nightmode/nightmode-0.3.ebuild6
3 files changed, 23 insertions, 5 deletions
diff --git a/kde-misc/nightmode/ChangeLog b/kde-misc/nightmode/ChangeLog
index 277c15f668bc..bb65dc019435 100644
--- a/kde-misc/nightmode/ChangeLog
+++ b/kde-misc/nightmode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-misc/nightmode
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/nightmode/ChangeLog,v 1.6 2012/04/19 05:45:04 johu Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/nightmode/ChangeLog,v 1.7 2013/09/08 13:45:42 kensington Exp $
+
+ 08 Sep 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/nightmode-0.3-kde-4.10.patch, nightmode-0.3.ebuild:
+ Add patch to fix build with KDE 4.10, wrt bug #484102.
19 Apr 2012; Johannes Huber <johu@gentoo.org> -nightmode-0.2.ebuild:
Remove old.
@@ -25,4 +29,3 @@
+nightmode-0.2.ebuild, +metadata.xml:
New plugin, fixes bug 317291. Thanks to Ciprian Ciubotariu for the initial
ebuild.
-
diff --git a/kde-misc/nightmode/files/nightmode-0.3-kde-4.10.patch b/kde-misc/nightmode/files/nightmode-0.3-kde-4.10.patch
new file mode 100644
index 000000000000..f1f0da20749b
--- /dev/null
+++ b/kde-misc/nightmode/files/nightmode-0.3-kde-4.10.patch
@@ -0,0 +1,13 @@
+Fixes build error caused by API changes in KDE 4.10
+
+--- nightmode.cpp
++++ nightmode.cpp
+@@ -74,7 +74,7 @@
+ void NightmodeEffect::paintWindow(EffectWindow *w, int mask, QRegion region, WindowPaintData &data )
+ {
+ if (m_active) {
+- data.brightness *= (m_brightness / 100.0);
++ data.setBrightness(data.brightness() * (m_brightness / 100.0));
+ // data.saturation *= (m_brightness / 100.0);
+ }
+ effects->paintWindow( w, mask, region, data );
diff --git a/kde-misc/nightmode/nightmode-0.3.ebuild b/kde-misc/nightmode/nightmode-0.3.ebuild
index fa8d340b4edc..b0e01c6ba644 100644
--- a/kde-misc/nightmode/nightmode-0.3.ebuild
+++ b/kde-misc/nightmode/nightmode-0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/nightmode/nightmode-0.3.ebuild,v 1.3 2012/04/19 04:46:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/nightmode/nightmode-0.3.ebuild,v 1.4 2013/09/08 13:45:42 kensington Exp $
EAPI=4
@@ -20,3 +20,5 @@ DEPEND="$(add_kdebase_dep kwin)"
RDEPEND="${DEPEND}"
S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}/${P}-kde-4.10.patch" )