summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-20 23:43:45 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-20 23:43:45 +0000
commit1ca068082e1be631069d80c812f5202ad7241951 (patch)
tree8665b67241d36e93e98649eb3e93e15e11e50533 /kde-misc/tork
parentFix Makefiles, bug #206546 (diff)
downloadgentoo-2-1ca068082e1be631069d80c812f5202ad7241951.tar.gz
gentoo-2-1ca068082e1be631069d80c812f5202ad7241951.tar.bz2
gentoo-2-1ca068082e1be631069d80c812f5202ad7241951.zip
Version bump as per bug 205770.
(Portage version: 2.1.4)
Diffstat (limited to 'kde-misc/tork')
-rw-r--r--kde-misc/tork/ChangeLog9
-rw-r--r--kde-misc/tork/files/digest-tork-0.263
-rw-r--r--kde-misc/tork/tork-0.26.ebuild44
3 files changed, 54 insertions, 2 deletions
diff --git a/kde-misc/tork/ChangeLog b/kde-misc/tork/ChangeLog
index 768be809b2a2..197853c0307a 100644
--- a/kde-misc/tork/ChangeLog
+++ b/kde-misc/tork/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tork
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.24 2007/12/16 23:20:38 philantrop Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/ChangeLog,v 1.25 2008/01/20 23:43:44 philantrop Exp $
+
+*tork-0.26 (20 Jan 2008)
+
+ 20 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org> +tork-0.26.ebuild:
+ Version bump as per bug 205770.
16 Dec 2007; Wulf C. Krueger <philantrop@gentoo.org> -tork-0.17.ebuild,
-tork-0.20.ebuild, -tork-0.21.ebuild:
diff --git a/kde-misc/tork/files/digest-tork-0.26 b/kde-misc/tork/files/digest-tork-0.26
new file mode 100644
index 000000000000..48839d9c1ab8
--- /dev/null
+++ b/kde-misc/tork/files/digest-tork-0.26
@@ -0,0 +1,3 @@
+MD5 d5feaf9b2743e6a8c18c2378b47ce085 tork-0.26.tar.bz2 2663154
+RMD160 b90e6b71ff7f6a5bc43498848ea8153ef415641f tork-0.26.tar.bz2 2663154
+SHA256 1e348e105c03badd009bdd003d057805c9a88246a830240d7c2058fe962da4d5 tork-0.26.tar.bz2 2663154
diff --git a/kde-misc/tork/tork-0.26.ebuild b/kde-misc/tork/tork-0.26.ebuild
new file mode 100644
index 000000000000..8b25859eff2a
--- /dev/null
+++ b/kde-misc/tork/tork-0.26.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tork/tork-0.26.ebuild,v 1.1 2008/01/20 23:43:44 philantrop Exp $
+
+inherit kde multilib
+
+DESCRIPTION="A Tor controller for the KDE desktop"
+HOMEPAGE="http://tork.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/geoip-1.4.0
+ || ( kde-base/kdebase kde-base/libkonq )"
+
+RDEPEND="${DEPEND}
+ >=net-misc/tor-0.1.2.14
+ >=net-proxy/privoxy-3.0.3-r5
+ >=net-proxy/tsocks-1.8_beta5-r2"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${PN}-0.24-ext_tsocks.patch"
+
+src_compile() {
+ # Fix desktop file
+ sed -i -e "s:^\(Categories=.*\):\1;:" "${S}/src/tork.desktop"
+
+ local myconf="--with-external-geoip --with-conf=/etc/socks/tsocks.conf"
+ kde_src_compile
+}
+
+pkg_postinst() {
+ if ! built_with_use --missing false net-proxy/tsocks tordns; then
+ ewarn "WARNING: you have net-proxy/tsocks installed without"
+ ewarn "the patch to avoid DNS leaking while using Tor."
+ ewarn "For better privacy, please emerge again net-proxy/tsocks"
+ ewarn "with the USE flag 'tordns' enabled."
+ fi
+}