summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-08-25 19:39:20 +0000
committerChris Reffett <creffett@gentoo.org>2012-08-25 19:39:20 +0000
commit4e1396bb24c1f4a720fde8cdbf5fb6f4e2402391 (patch)
tree06101911b025c642a9491d09bfec15d7e7972a5d /kde-misc/openofficeorg-thumbnail
parent[bump] dev-perl/DBIx-Class-0.82.0 (diff)
downloadgentoo-2-4e1396bb24c1f4a720fde8cdbf5fb6f4e2402391.tar.gz
gentoo-2-4e1396bb24c1f4a720fde8cdbf5fb6f4e2402391.tar.bz2
gentoo-2-4e1396bb24c1f4a720fde8cdbf5fb6f4e2402391.zip
Revision bump, moved to EAPI 4 and fixed .desktop validation warnings.
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/openofficeorg-thumbnail')
-rw-r--r--kde-misc/openofficeorg-thumbnail/ChangeLog11
-rw-r--r--kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r1.ebuild26
2 files changed, 34 insertions, 3 deletions
diff --git a/kde-misc/openofficeorg-thumbnail/ChangeLog b/kde-misc/openofficeorg-thumbnail/ChangeLog
index 9cc6ffcc3e5b..f8403d920c56 100644
--- a/kde-misc/openofficeorg-thumbnail/ChangeLog
+++ b/kde-misc/openofficeorg-thumbnail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/openofficeorg-thumbnail
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/openofficeorg-thumbnail/ChangeLog,v 1.4 2011/01/31 06:13:48 tampakrap Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/openofficeorg-thumbnail/ChangeLog,v 1.5 2012/08/25 19:39:20 creffett Exp $
+
+*openofficeorg-thumbnail-1.0.0-r1 (25 Aug 2012)
+
+ 25 Aug 2012; Chris Reffett <creffett@gentoo.org>
+ +openofficeorg-thumbnail-1.0.0-r1.ebuild:
+ Revision bump, moved to EAPI 4 and fixed .desktop validation warnings.
31 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
openofficeorg-thumbnail-1.0.0.ebuild:
@@ -19,4 +25,3 @@
15 Nov 2009; Alex Alexander <wired@gentoo.org>
+openofficeorg-thumbnail-1.0.0.ebuild, +metadata.xml:
new ebuild, bug #293022
-
diff --git a/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r1.ebuild b/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..6a5166b7769b
--- /dev/null
+++ b/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/openofficeorg-thumbnail/openofficeorg-thumbnail-1.0.0-r1.ebuild,v 1.1 2012/08/25 19:39:20 creffett Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+MY_PN="OpenOfficeorgThumbnail"
+MY_P="${MY_PN}"-"${PV}"
+DESCRIPTION="KDE thumbnail-plugin that generates thumbnails for ODF files"
+HOMEPAGE="http://www.kde-apps.org/content/show.php?content=110864"
+SRC_URI="http://arielch.fedorapeople.org/devel/src/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ sed -e "s:CacheThumbnail:X-CacheThumbnail:" \
+ -e "s:IgnoreMaximumSize:X-IgnoreMaximumSize:" \
+ -i src/openofficeorgthumbnail.desktop || die "fixing .desktop file failed"
+}