summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-17 17:58:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-17 17:58:48 +0000
commit2f57fca54111e2431cc21266503b9f6cc843b99a (patch)
tree51a01ec4e4de46f9707da4148f0e20f1ddccb2b4 /kde-misc/kanyremote
parentVersion bump (diff)
downloadgentoo-2-2f57fca54111e2431cc21266503b9f6cc843b99a.tar.gz
gentoo-2-2f57fca54111e2431cc21266503b9f6cc843b99a.tar.bz2
gentoo-2-2f57fca54111e2431cc21266503b9f6cc843b99a.zip
Version bump
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kanyremote')
-rw-r--r--kde-misc/kanyremote/ChangeLog7
-rw-r--r--kde-misc/kanyremote/kanyremote-6.0.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 978f74aca993..73742cbdebbe 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.25 2012/07/21 11:06:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.26 2012/08/17 17:58:48 hwoarang Exp $
+
+*kanyremote-6.0.1 (17 Aug 2012)
+
+ 17 Aug 2012; Markos Chandras <hwoarang@gentoo.org> +kanyremote-6.0.1.ebuild:
+ Version bump
21 Jul 2012; Johannes Huber <johu@gentoo.org> kanyremote-5.13.ebuild,
kanyremote-6.0.ebuild:
diff --git a/kde-misc/kanyremote/kanyremote-6.0.1.ebuild b/kde-misc/kanyremote/kanyremote-6.0.1.ebuild
new file mode 100644
index 000000000000..6ea8db5681ad
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.0.1.ebuild,v 1.1 2012/08/17 17:58:48 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit autotools python base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=app-mobilephone/anyremote-6.0[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup () {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+ "${T}"/gettextize -f --no-changelog > /dev/null
+ #fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
+ eautoreconf
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}