summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-04 09:44:47 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-04 09:44:47 +0000
commitfbe5814a4996332fc309a1d2c99ec17b3d02445b (patch)
treef66c832a76b3ffa82e3f624936b4492382c76a49 /kde-base
parentAdd patch for hal-0.5 compatibility (#105553). Add patch to fix opengl relate... (diff)
downloadgentoo-2-fbe5814a4996332fc309a1d2c99ec17b3d02445b.tar.gz
gentoo-2-fbe5814a4996332fc309a1d2c99ec17b3d02445b.tar.bz2
gentoo-2-fbe5814a4996332fc309a1d2c99ec17b3d02445b.zip
Add patch to fix opengl related crash (#103937).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kcontrol/ChangeLog9
-rw-r--r--kde-base/kcontrol/files/digest-kcontrol-3.4.2-r14
-rw-r--r--kde-base/kcontrol/files/kdebase-3.4.2-kinfocenter-opengl-fix.patch12
-rw-r--r--kde-base/kcontrol/kcontrol-3.4.2-r1.ebuild54
4 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index 941913e9f275..f18dd234c8cd 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.27 2005/09/24 13:26:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.28 2005/10/04 09:44:47 greg_g Exp $
+
+*kcontrol-3.4.2-r1 (04 Oct 2005)
+
+ 04 Oct 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdebase-3.4.2-kinfocenter-opengl-fix.patch,
+ +kcontrol-3.4.2-r1.ebuild:
+ Add patch to fix opengl related crash (#103937).
24 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
-kcontrol-3.5_alpha1.ebuild:
diff --git a/kde-base/kcontrol/files/digest-kcontrol-3.4.2-r1 b/kde-base/kcontrol/files/digest-kcontrol-3.4.2-r1
new file mode 100644
index 000000000000..a5f92d1d76f9
--- /dev/null
+++ b/kde-base/kcontrol/files/digest-kcontrol-3.4.2-r1
@@ -0,0 +1,4 @@
+MD5 c88659e558ca98dc45377bf8ddfc26c9 kdebase-3.4.0.tar.bz2 22670772
+MD5 3b99262a66edd3c9ad86220ad6cf6579 kdebase-3.4.0-3.4.1.tar.xdelta 1089415
+MD5 7fc67dd6be199ef3208bfc0200a900aa kdebase-3.4.1-3.4.2.tar.xdelta 928157
+MD5 0ea16eb7185ef014d8bd4da4f4530272 kdebase-3.4.2.tar.bz2 22466433
diff --git a/kde-base/kcontrol/files/kdebase-3.4.2-kinfocenter-opengl-fix.patch b/kde-base/kcontrol/files/kdebase-3.4.2-kinfocenter-opengl-fix.patch
new file mode 100644
index 000000000000..f18c216257ff
--- /dev/null
+++ b/kde-base/kcontrol/files/kdebase-3.4.2-kinfocenter-opengl-fix.patch
@@ -0,0 +1,12 @@
+--- kcontrol/info/opengl.cpp.bak 2005-05-23 07:13:35.000000000 -0500
++++ kcontrol/info/opengl.cpp 2005-08-27 10:45:08.000000000 -0500
+@@ -235,6 +235,9 @@
+ GL_COMPRESSED_TEXTURE_FORMATS
+ */
+
++ if (!glExtensions)
++ return;
++
+ struct token_name {
+ GLuint type; // count and flags, !!! count must be <=2 for now
+ GLenum token;
diff --git a/kde-base/kcontrol/kcontrol-3.4.2-r1.ebuild b/kde-base/kcontrol/kcontrol-3.4.2-r1.ebuild
new file mode 100644
index 000000000000..f441d73e7b27
--- /dev/null
+++ b/kde-base/kcontrol/kcontrol-3.4.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.4.2-r1.ebuild,v 1.1 2005/10/04 09:44:47 greg_g Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl arts ieee1394 logitech-mouse opengl"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ ssl? ( dev-libs/openssl )
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ opengl? ( virtual/opengl )
+ ieee1394? ( sys-libs/libraw1394 )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )"
+
+RDEPEND="${DEPEND}
+$(deprange 3.4.1 $MAXKDEVER kde-base/kcminit)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+$(deprange 3.4.1 $MAXKDEVER kde-base/kdesu)
+$(deprange $PV $MAXKDEVER kde-base/khelpcenter)
+$(deprange $PV $MAXKDEVER kde-base/khotkeys)"
+
+KMEXTRACTONLY="kicker/core/kicker.h
+ kwin/kwinbindings.cpp
+ kicker/core/kickerbindings.cpp
+ kicker/taskbar/taskbarbindings.cpp
+ kdesktop/kdesktopbindings.cpp
+ klipper/klipperbindings.cpp
+ kxkb/kxkbbindings.cpp
+ libkonq/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+
+KMCOMPILEONLY="kicker/share" # for kickerSettings.h
+KMEXTRA="doc/kinfocenter"
+
+# configure.in.in-kdm-settings.diff: add configure tests from kdm necessary to configure kcontrol
+# kdebase-3.4.1-configure.patch: add --with-libusb configure switch
+PATCHES="$FILESDIR/configure.in.in-kdm-settings.diff
+ $FILESDIR/kdebase-3.4.1-configure.patch"
+
+# Fix crash related to opengl (kde bug 101154). Applied for 3.4.3.
+PATCHES1="${FILESDIR}/kdebase-3.4.2-kinfocenter-opengl-fix.patch"
+
+src_compile() {
+ myconf="$myconf `use_with ssl` `use_with arts` `use_with opengl gl`
+ `use_with ieee1394 libraw1394` `use_with logitech-mouse libusb`"
+ kde-meta_src_compile
+}