summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-12 17:19:56 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-12 17:19:56 +0000
commite68cb168affdc663b28fb5e816490e69806f98c9 (patch)
tree185fa646dee11a21cd9d4f36a6d74e95fcb99ed6 /kde-base
parentold (diff)
downloadgentoo-2-e68cb168affdc663b28fb5e816490e69806f98c9.tar.gz
gentoo-2-e68cb168affdc663b28fb5e816490e69806f98c9.tar.bz2
gentoo-2-e68cb168affdc663b28fb5e816490e69806f98c9.zip
Backport fix for weather widget related crashes, bug 372397
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/plasma-workspace/ChangeLog9
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.7.3-weathercrash.patch31
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.7.3-r1.ebuild (renamed from kde-base/plasma-workspace/plasma-workspace-4.7.3.ebuild)3
3 files changed, 41 insertions, 2 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index e8707e1ac08a..b0a31bd1bcf1 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.130 2011/11/02 20:48:10 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.131 2011/11/12 17:19:56 dilfridge Exp $
+
+*plasma-workspace-4.7.3-r1 (12 Nov 2011)
+
+ 12 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ -plasma-workspace-4.7.3.ebuild, +plasma-workspace-4.7.3-r1.ebuild,
+ +files/plasma-workspace-4.7.3-weathercrash.patch:
+ Backport fix for weather widget related crashes, bug 372397
*plasma-workspace-4.7.3 (02 Nov 2011)
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-weathercrash.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-weathercrash.patch
new file mode 100644
index 000000000000..a9daa5004ea7
--- /dev/null
+++ b/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-weathercrash.patch
@@ -0,0 +1,31 @@
+commit 92b1e7cc6766023050aaaae41390bb5cfcc07ec5
+Author: Max Lin <max7442@gmail.com>
+Date: Thu Nov 3 11:48:32 2011 +0800
+
+ Used the gps_open() return value as condition instead of checking m_gpsdata
+
+ Checking the return value of gps_open() as condition instead of checking
+ m_gpsdata for GPSD_API_MAJOR_VERSION >=5, there should be prevent crash
+ occurred when no gpsd running.
+
+ BUG: 277036
+ REVIEW: 103035
+
+diff --git a/plasma/generic/dataengines/geolocation/location_gps.cpp b/plasma/generic/dataengines/geolocation/location_gps.cpp
+index 709321b..551aec2 100644
+--- a/plasma/generic/dataengines/geolocation/location_gps.cpp
++++ b/plasma/generic/dataengines/geolocation/location_gps.cpp
+@@ -83,11 +83,11 @@ Gps::Gps(QObject* parent, const QVariantList& args)
+ {
+ #if GPSD_API_MAJOR_VERSION >= 5
+ m_gpsdata = new gps_data_t;
+- gps_open("localhost", DEFAULT_GPSD_PORT, m_gpsdata);
++ if (gps_open("localhost", DEFAULT_GPSD_PORT, m_gpsdata) != -1) {
+ #else
+ gps_data_t* m_gpsdata = gps_open("localhost", DEFAULT_GPSD_PORT);
+-#endif
+ if (m_gpsdata) {
++#endif
+ kDebug() << "gpsd found.";
+ m_gpsd = new Gpsd(m_gpsdata);
+ connect(m_gpsd, SIGNAL(dataReady(Plasma::DataEngine::Data)),
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.7.3.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.7.3-r1.ebuild
index 05c00ebe47af..648c7a619703 100644
--- a/kde-base/plasma-workspace/plasma-workspace-4.7.3.ebuild
+++ b/kde-base/plasma-workspace/plasma-workspace-4.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.7.3.ebuild,v 1.1 2011/11/02 20:48:10 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.7.3-r1.ebuild,v 1.1 2011/11/12 17:19:56 dilfridge Exp $
EAPI=4
@@ -74,6 +74,7 @@ KMLOADLIBS="libkworkspace libplasmaclock libplasmagenericshell libtaskmanager"
PATCHES=(
"${FILESDIR}/${PN}-4.4.2-xinerama_cmake_automagic.patch"
+ "${FILESDIR}/${PN}-4.7.3-weathercrash.patch"
)
pkg_setup() {