summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-26 15:40:20 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-26 15:40:20 +0000
commitc9bf5f630c6097bee716f80ae959fe91a1d3be0d (patch)
tree90b150faa3a6018fe1341e74025a666fe1e3ca27 /kde-base
parentfix #3594: remove -fomit-frame-opinter flag from subdir kdm/kfrontend's makefile (diff)
downloadgentoo-2-c9bf5f630c6097bee716f80ae959fe91a1d3be0d.tar.gz
gentoo-2-c9bf5f630c6097bee716f80ae959fe91a1d3be0d.tar.bz2
gentoo-2-c9bf5f630c6097bee716f80ae959fe91a1d3be0d.zip
ditto for 3.1_alpha1: remove -fomit-frame-pointer flag from subdir kdm/kfrontend's makefile
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/kdebase-3.1_alpha1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/kde-base/kdebase/kdebase-3.1_alpha1.ebuild b/kde-base/kdebase/kdebase-3.1_alpha1.ebuild
index 9968ab910676..e4657eb369e6 100644
--- a/kde-base/kdebase/kdebase-3.1_alpha1.ebuild
+++ b/kde-base/kdebase/kdebase-3.1_alpha1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1_alpha1.ebuild,v 1.3 2002/07/25 17:53:21 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1_alpha1.ebuild,v 1.4 2002/07/26 15:40:20 danarmak Exp $
inherit kde-dist
DESCRIPTION="KDE $PV - base packages: the desktop, panel, window manager, konqueror..."
@@ -33,6 +33,15 @@ use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+
+}
+
src_install() {
kde_src_install