summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-01 02:32:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-01 02:32:32 +0000
commitb6afe3049b4e2464a1c5d260abda3da6118ff8c5 (patch)
treeb7b8707960f2102f7bf97f1e43d0014d38bfb9c5 /kde-base
parentadded french keyboard (diff)
downloadgentoo-2-b6afe3049b4e2464a1c5d260abda3da6118ff8c5.tar.gz
gentoo-2-b6afe3049b4e2464a1c5d260abda3da6118ff8c5.tar.bz2
gentoo-2-b6afe3049b4e2464a1c5d260abda3da6118ff8c5.zip
*** empty log message ***
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdesupport/files/digest-kdesupport-2.11
-rw-r--r--kde-base/kdesupport/kdesupport-2.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdesupport/files/digest-kdesupport-2.1 b/kde-base/kdesupport/files/digest-kdesupport-2.1
new file mode 100644
index 000000000000..42cbbe3ab991
--- /dev/null
+++ b/kde-base/kdesupport/files/digest-kdesupport-2.1
@@ -0,0 +1 @@
+MD5 7654d34591e6d460e1fa2a1aeda8c22f kdesupport-2.1.tar.bz2
diff --git a/kde-base/kdesupport/kdesupport-2.1.ebuild b/kde-base/kdesupport/kdesupport-2.1.ebuild
new file mode 100644
index 000000000000..0432c0141c3f
--- /dev/null
+++ b/kde-base/kdesupport/kdesupport-2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesupport/kdesupport-2.1.ebuild,v 1.1 2001/03/01 02:32:32 achim Exp $
+
+V=2.1
+A=${PN}-${V}.tar.bz2
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE 2.1 - support"
+SRC_PATH="kde/stable/2.1/distribution/tar/generic/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.twoguys.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=sys-devel/gcc-2.95.2
+ >=media-libs/audiofile-0.1.9
+ >=net-print/cups-1.1.4
+ >=x11-libs/qt-x11-2.2.3"
+
+RDEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-devel/gcc-2.95.2"
+
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=/opt/kde${V} --host=${CHOST} --enable-threads \
+ --without-audiofile --with-qt-dir=$QTBASE
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS ChangeLog COPYING README
+}
+
+