summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 13:32:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 13:32:27 +0000
commitaede38ff6f8f0cb2475869585f17d9f905b453e7 (patch)
treed25d6de1674f7c8aea51f9da24086ee675a2f2a5 /kde-base
parentFix typo in strict aliasing patch, thanks to Honza Macháček in bug #137573. (diff)
downloadgentoo-2-aede38ff6f8f0cb2475869585f17d9f905b453e7.tar.gz
gentoo-2-aede38ff6f8f0cb2475869585f17d9f905b453e7.tar.bz2
gentoo-2-aede38ff6f8f0cb2475869585f17d9f905b453e7.zip
Move myconf population in src_compile rather than global scope.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/ksayit/ChangeLog6
-rw-r--r--kde-base/ksayit/ksayit-3.4.3-r1.ebuild8
-rw-r--r--kde-base/ksayit/ksayit-3.5.2.ebuild8
-rw-r--r--kde-base/ksayit/ksayit-3.5.3.ebuild8
4 files changed, 23 insertions, 7 deletions
diff --git a/kde-base/ksayit/ChangeLog b/kde-base/ksayit/ChangeLog
index 1fdcfe1318e1..87cecfaf4542 100644
--- a/kde-base/ksayit/ChangeLog
+++ b/kde-base/ksayit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksayit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ChangeLog,v 1.52 2006/06/01 19:47:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ChangeLog,v 1.53 2006/06/22 13:32:27 flameeyes Exp $
+
+ 22 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> ksayit-3.4.3-r1.ebuild,
+ ksayit-3.5.2.ebuild, ksayit-3.5.3.ebuild:
+ Move myconf population in src_compile rather than global scope.
*ksayit-3.5.3 (01 Jun 2006)
diff --git a/kde-base/ksayit/ksayit-3.4.3-r1.ebuild b/kde-base/ksayit/ksayit-3.4.3-r1.ebuild
index 9ef289899731..a773af662a3f 100644
--- a/kde-base/ksayit/ksayit-3.4.3-r1.ebuild
+++ b/kde-base/ksayit/ksayit-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.4.3-r1.ebuild,v 1.8 2006/03/27 20:18:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.4.3-r1.ebuild,v 1.9 2006/06/22 13:32:27 flameeyes Exp $
KMNAME=kdeaccessibility
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -12,6 +12,10 @@ IUSE=""
DEPEND="$(deprange $PV $MAXKDEVER kde-base/kttsd)
$(deprange $PV $MAXKDEVER kde-base/arts)
$(deprange-dual 3.4.1 $MAXKDEVER kde-base/kdemultimedia-arts)"
-myconf="--enable-ksayit-audio-plugins"
PATCHES="${FILESDIR}/${P}-pointer.patch"
+
+src_compile() {
+ myconf="--enable-ksayit-audio-plugins"
+ kde-meta_src_compile
+}
diff --git a/kde-base/ksayit/ksayit-3.5.2.ebuild b/kde-base/ksayit/ksayit-3.5.2.ebuild
index a2e8d6d9f7f3..695612bf09d1 100644
--- a/kde-base/ksayit/ksayit-3.5.2.ebuild
+++ b/kde-base/ksayit/ksayit-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.2.ebuild,v 1.8 2006/06/01 07:26:06 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.2.ebuild,v 1.9 2006/06/22 13:32:27 flameeyes Exp $
KMNAME=kdeaccessibility
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -12,4 +12,8 @@ IUSE=""
DEPEND="$(deprange $PV $MAXKDEVER kde-base/kttsd)
$(deprange $PV $MAXKDEVER kde-base/arts)
$(deprange-dual $PV $MAXKDEVER kde-base/kdemultimedia-arts)"
-myconf="--enable-ksayit-audio-plugins"
+
+src_compile() {
+ myconf="--enable-ksayit-audio-plugins"
+ kde-meta_src_compile
+}
diff --git a/kde-base/ksayit/ksayit-3.5.3.ebuild b/kde-base/ksayit/ksayit-3.5.3.ebuild
index c3b0d4deedd3..64f8e5bf1496 100644
--- a/kde-base/ksayit/ksayit-3.5.3.ebuild
+++ b/kde-base/ksayit/ksayit-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.3.ebuild,v 1.1 2006/06/01 19:47:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.3.ebuild,v 1.2 2006/06/22 13:32:27 flameeyes Exp $
KMNAME=kdeaccessibility
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -12,4 +12,8 @@ IUSE=""
DEPEND="$(deprange $PV $MAXKDEVER kde-base/kttsd)
$(deprange $PV $MAXKDEVER kde-base/arts)
$(deprange-dual $PV $MAXKDEVER kde-base/kdemultimedia-arts)"
-myconf="--enable-ksayit-audio-plugins"
+
+src_compile() {
+ myconf="--enable-ksayit-audio-plugins"
+ kde-meta_src_compile
+}