summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 11:41:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 11:41:57 +0000
commita43851c14bead749aa2062ff29cbd1acbbb82fb0 (patch)
tree66eccf9760269fa4d6c7a4812665a35fb939d009 /kde-base
parent Version bump (#256552). (diff)
downloadgentoo-2-a43851c14bead749aa2062ff29cbd1acbbb82fb0.tar.gz
gentoo-2-a43851c14bead749aa2062ff29cbd1acbbb82fb0.tar.bz2
gentoo-2-a43851c14bead749aa2062ff29cbd1acbbb82fb0.zip
Fixing CFLAGS for uclibc to fix #260418
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/automoc/ChangeLog6
-rw-r--r--kde-base/automoc/automoc-0.9.84.ebuild14
-rw-r--r--kde-base/automoc/automoc-0.9.88.ebuild11
3 files changed, 25 insertions, 6 deletions
diff --git a/kde-base/automoc/ChangeLog b/kde-base/automoc/ChangeLog
index 88f5d6781690..5aa43b80c3ca 100644
--- a/kde-base/automoc/ChangeLog
+++ b/kde-base/automoc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/automoc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/ChangeLog,v 1.5 2009/02/01 22:40:07 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/ChangeLog,v 1.6 2009/03/01 11:41:57 patrick Exp $
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> automoc-0.9.84.ebuild,
+ automoc-0.9.88.ebuild:
+ Fixing CFLAGS for uclibc to fix #260418
01 Feb 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
automoc-0.9.88.ebuild:
diff --git a/kde-base/automoc/automoc-0.9.84.ebuild b/kde-base/automoc/automoc-0.9.84.ebuild
index bed28da1d537..6e1a3fdac917 100644
--- a/kde-base/automoc/automoc-0.9.84.ebuild
+++ b/kde-base/automoc/automoc-0.9.84.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/automoc-0.9.84.ebuild,v 1.3 2008/11/02 07:47:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/automoc-0.9.84.ebuild,v 1.4 2009/03/01 11:41:57 patrick Exp $
EAPI="2"
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="KDE Meta Object Compiler"
HOMEPAGE="http://www.kde.org/"
@@ -19,3 +19,11 @@ DEPEND="x11-libs/qt-core:4"
RDEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}4-${PV}"
+
+
+src_prepare() {
+ if [[ ${ELIBC} == "uclibc" ]]; then
+ append-flags -pthread
+ fi
+}
+
diff --git a/kde-base/automoc/automoc-0.9.88.ebuild b/kde-base/automoc/automoc-0.9.88.ebuild
index 1c97f2318bc0..d6604f9f3b1b 100644
--- a/kde-base/automoc/automoc-0.9.88.ebuild
+++ b/kde-base/automoc/automoc-0.9.88.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/automoc-0.9.88.ebuild,v 1.2 2009/02/01 22:40:07 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/automoc/automoc-0.9.88.ebuild,v 1.3 2009/03/01 11:41:57 patrick Exp $
EAPI="2"
MY_PN="automoc4"
MY_P="$MY_PN-${PV}"
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="KDE Meta Object Compiler"
HOMEPAGE="http://www.kde.org"
@@ -22,3 +22,10 @@ DEPEND="x11-libs/qt-core:4"
RDEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ if [[ ${ELIBC} == "uclibc" ]]; then
+ append-flags -pthread
+ fi
+}
+