summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-02-28 01:45:35 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-02-28 01:45:35 +0000
commit8cfce5ba611424079c5916a03e53f91745482b61 (patch)
treeb20de879c9d54104c76975655077211d816ac359 /kde-base
parentbam! (diff)
downloadgentoo-2-8cfce5ba611424079c5916a03e53f91745482b61.tar.gz
gentoo-2-8cfce5ba611424079c5916a03e53f91745482b61.tar.bz2
gentoo-2-8cfce5ba611424079c5916a03e53f91745482b61.zip
2.1 on the way
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/kdebase-2.1.ebuild35
-rw-r--r--kde-base/kdelibs/kdelibs-2.1.ebuild79
2 files changed, 114 insertions, 0 deletions
diff --git a/kde-base/kdebase/kdebase-2.1.ebuild b/kde-base/kdebase/kdebase-2.1.ebuild
new file mode 100644
index 000000000000..26be677e9c92
--- /dev/null
+++ b/kde-base/kdebase/kdebase-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-2.1.ebuild,v 1.1 2001/02/28 01:45:35 drobbins Exp $
+
+V="2.1"
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE 2.1 - Base"
+SRC_PATH="kde/stable/distribution/${V}/tar/generic/src/${PN}-${V}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp://ftp.twoguys.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-2.1
+ >=x11-libs/openmotif-2.1.30"
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ export CFLAGS="${CFLAGS} -I/usr/X11R6/include"
+ export CXXFLAGS="${CXXFLAGS} -I/usr/X11R6/include"
+ export CPPFLAGS="${CXXFLAGS} -I/usr/X11R6/include"
+ try ./configure --prefix=/opt/kde${V} --host=${CHOST} --with-shadow --with-x \
+ --with-pam=yes --with-ldap \
+ --with-qt-dir=$QTBASE
+ try make
+}
+
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS ChangeLog README*
+}
+
+
diff --git a/kde-base/kdelibs/kdelibs-2.1.ebuild b/kde-base/kdelibs/kdelibs-2.1.ebuild
new file mode 100644
index 000000000000..82e35b0f53d5
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-2.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-2.1.ebuild,v 1.1 2001/02/28 01:45:35 drobbins Exp $
+
+V=2.1
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE 2.1 - libs"
+SRC_PATH="kde/stable/distribution/${V}/tar/generic/src/${PN}-${V}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.twoguys.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=sys-devel/gcc-2.95.2
+ >=media-libs/audiofile-0.1.9
+ >=media-libs/tiff-3.5.5
+ >=x11-libs/qt-x11-2.2.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ mysql? ( >=dev-db/mysql-3.23.30 )
+ postgres? ( >=dev-db/postgresql-7.0.3 )"
+
+RDEPEND=">=sys-devel/gcc-2.95.2
+ >=media-libs/audiofile-0.1.9
+ >=x11-libs/qt-x11-2.2.3"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+
+ local myopts
+ if [ "`use ssl`" ]
+ then
+ myopts="--with-ssl-dir=/usr"
+ else
+ myopts="--without-ssl"
+ fi
+ if [ "`use mysql`" ]
+ then
+ myopts="$myopts --enable-mysql "
+ else
+ myopts="$myopts --disable-mysql"
+ fi
+ if [ "`use postgres`" ]
+ then
+ myopts="$myopts --enable-pgsql"
+ else
+ myopts="$myopts --disable-pgsql"
+ fi
+ export myopts
+ cp configure configure.orig
+ sed -e "s:^DO_NOT_COMPILE=\"\$DO_NOT_COMPILE kdedb\"::" \
+ configure.orig > configure
+ try ./configure --prefix=/opt/kde${V} --host=${CHOST} \
+ --with-qt-dir=$QTBASE --with-alsa $myopts
+ for i in kdb kdbcore kdbui plugins plugins/mysql plugins/postgres
+ do
+ cd ${S}/kdedb/$i
+ cp Makefile Makefile.orig
+ sed -e "s:^all_includes = :all_includes = -I\$\(top_srcdir\)/kio :" \
+ -e "s:^MYSQL_LIBDIR.*$:MYSQL_LIBDIR = /usr/lib:" \
+ Makefile.orig > Makefile
+ done
+ cd ${S}
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS ChangeLog COMPILING COPYING* NAMING NEWS README
+ docinto html
+ dodoc *.html
+}
+
+