summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 20:26:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 20:26:52 +0000
commit89c3509e9dec20d06544cfab37085b9ba379260a (patch)
treed1388b81faefa00d9dc44f631ad464f14284b76c /kde-base
parentAdd patch to disable xcomposite support and xcomposite useflag to enable/disa... (diff)
downloadgentoo-2-89c3509e9dec20d06544cfab37085b9ba379260a.tar.gz
gentoo-2-89c3509e9dec20d06544cfab37085b9ba379260a.tar.bz2
gentoo-2-89c3509e9dec20d06544cfab37085b9ba379260a.zip
Add extra patch to disable composite support from kicker, too.
(Portage version: 2529-svn)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/ChangeLog6
-rw-r--r--kde-base/kdebase/files/kicker-3.5.0-composite.patch54
-rw-r--r--kde-base/kdebase/kdebase-3.5.0-r1.ebuild7
3 files changed, 65 insertions, 2 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 2ee590d4299d..439e35ec3223 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.250 2006/01/11 19:58:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.251 2006/01/11 20:26:52 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kicker-3.5.0-composite.patch, kdebase-3.5.0-r1.ebuild:
+ Add extra patch to disable composite support from kicker, too.
11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/kdesktop-3.5.0-xscreensaver.patch, kdebase-3.5.0-r1.ebuild:
diff --git a/kde-base/kdebase/files/kicker-3.5.0-composite.patch b/kde-base/kdebase/files/kicker-3.5.0-composite.patch
new file mode 100644
index 000000000000..e04bd84a6c7d
--- /dev/null
+++ b/kde-base/kdebase/files/kicker-3.5.0-composite.patch
@@ -0,0 +1,54 @@
+Index: kicker/taskmanager/configure.in.in
+===================================================================
+--- kicker/taskmanager/configure.in.in (revision 492938)
++++ kicker/taskmanager/configure.in.in (working copy)
+@@ -1,14 +1,16 @@
+-dnl XComposite check
+-KDE_CHECK_HEADER(X11/extensions/Xcomposite.h, [xcomposite_h=yes], [xcomposite_h=no], [#include <X11/Xlib.h>])
+-if test "$xcomposite_h" = yes; then
+- KDE_CHECK_LIB(Xcomposite, XCompositeQueryExtension, [
+- LIB_XCOMPOSITE=-lXcomposite
+- AC_DEFINE_UNQUOTED(HAVE_XCOMPOSITE, 1, [Define if you have the XComposite extension])
+- ], [], -lXext -X11 $X_EXTRA_LIBS)
+-else
+- LIB_XCOMPOSITE=
++if test "x$with_composite" != "xno"; then
++ dnl XComposite check
++ KDE_CHECK_HEADER(X11/extensions/Xcomposite.h, [xcomposite_h=yes], [xcomposite_h=no], [#include <X11/Xlib.h>])
++ if test "$xcomposite_h" = yes; then
++ KDE_CHECK_LIB(Xcomposite, XCompositeQueryExtension, [
++ LIB_XCOMPOSITE=-lXcomposite
++ AC_DEFINE_UNQUOTED(HAVE_XCOMPOSITE, 1, [Define if you have the XComposite extension])
++ ], [], -lXext -X11 $X_EXTRA_LIBS)
++ else
++ LIB_XCOMPOSITE=
++ fi
++ AC_SUBST(LIB_XCOMPOSITE)
+ fi
+-AC_SUBST(LIB_XCOMPOSITE)
+
+ dnl XFixes check
+ KDE_CHECK_HEADER(X11/extensions/Xfixes.h, [xfixes_h=yes], [xfixes_h=no], [#include <X11/Xlib.h>])
+Index: kwin/kompmgr/configure.in.in
+===================================================================
+--- kwin/kompmgr/configure.in.in (revision 497009)
++++ kwin/kompmgr/configure.in.in (working copy)
+@@ -1,6 +1,3 @@
+-AC_ARG_WITH([composite],
+- AS_HELP_STRING([--without-composite], [Disable Xcomposite support (default: check)]) )
+-
+ if test "x$with_composite" != "xno"; then
+ KDE_CHECK_HEADERS(X11/extensions/Xdamage.h,,compile_kompmgr=no,[#include <X11/Xlib.h>])
+ KDE_CHECK_HEADERS(X11/extensions/Xcomposite.h,,compile_kompmgr=no,[#include <X11/Xlib.h>])
+Index: configure.in.in
+===================================================================
+--- configure.in.in (revision 492938)
++++ configure.in.in (working copy)
+@@ -275,3 +275,7 @@
+ AC_SUBST(LIBART_LIBS)
+ AC_SUBST(LIBART_CFLAGS)
+ AC_SUBST(LIBART_RPATH)
++
++AC_ARG_WITH([composite],
++ AS_HELP_STRING([--without-composite], [Disable Xcomposite support (default: check)]) )
++
diff --git a/kde-base/kdebase/kdebase-3.5.0-r1.ebuild b/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
index 0b0b6db33a9d..ea779e9f7c26 100644
--- a/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
+++ b/kde-base/kdebase/kdebase-3.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0-r1.ebuild,v 1.10 2006/01/11 19:58:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.5.0-r1.ebuild,v 1.11 2006/01/11 20:26:52 flameeyes Exp $
inherit kde-dist eutils flag-o-matic
@@ -88,6 +88,11 @@ src_unpack() {
# Add --without-xscreenserver option to disable libXSS support
epatch "${FILESDIR}/kdesktop-3.5.0-xscreensaver.patch"
+ # Extra fix for composite support in kicker this time, different from the
+ # patch with the same name in kicker as it has to interact with the above
+ # kwin patch.
+ epatch "${FILESDIR}/kicker-3.5.0-composite.patch"
+
# For the noimake patch.
make -f admin/Makefile.common || die
}