summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-10 11:05:43 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-10 11:05:43 +0000
commit889a138bc71b5fe2a62f957676f68b1126844c73 (patch)
tree13ad4cb62772c45711cccdf100b47dd8f4b93db5 /kde-base
parentDrop USE='flint remote', bug #433611 (diff)
downloadgentoo-2-889a138bc71b5fe2a62f957676f68b1126844c73.tar.gz
gentoo-2-889a138bc71b5fe2a62f957676f68b1126844c73.tar.bz2
gentoo-2-889a138bc71b5fe2a62f957676f68b1126844c73.zip
Revision bump adds upstream patch which fixes a focus issue spotted by Bernd Buschinski <b.buschinski@googlemail.com> wrt bug #434464. Remove old.
(Portage version: 2.2.0_alpha124/cvs/Linux i686)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/konqueror/ChangeLog11
-rw-r--r--kde-base/konqueror/files/konqueror-4.9.1-focus.patch43
-rw-r--r--kde-base/konqueror/konqueror-4.9.1-r1.ebuild (renamed from kde-base/konqueror/konqueror-4.9.1.ebuild)4
3 files changed, 55 insertions, 3 deletions
diff --git a/kde-base/konqueror/ChangeLog b/kde-base/konqueror/ChangeLog
index 16e331b8e6b9..7c14ebdb63d2 100644
--- a/kde-base/konqueror/ChangeLog
+++ b/kde-base/konqueror/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/konqueror
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/konqueror/ChangeLog,v 1.253 2012/09/04 18:45:02 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konqueror/ChangeLog,v 1.254 2012/09/10 11:05:43 johu Exp $
+
+*konqueror-4.9.1-r1 (10 Sep 2012)
+
+ 10 Sep 2012; Johannes Huber <johu@gentoo.org>
+ +files/konqueror-4.9.1-focus.patch, +konqueror-4.9.1-r1.ebuild,
+ -konqueror-4.9.1.ebuild:
+ Revision bump adds upstream patch which fixes a focus issue spotted by Bernd
+ Buschinski <b.buschinski@googlemail.com> wrt bug #434464. Remove old.
*konqueror-4.9.1 (04 Sep 2012)
@@ -1049,4 +1057,3 @@
+konqueror-3.4.0_beta1.ebuild:
Adding the split ebuilds to portage. For KDE 3.4, we've created separate
ebuilds for all the KDE apps.
-
diff --git a/kde-base/konqueror/files/konqueror-4.9.1-focus.patch b/kde-base/konqueror/files/konqueror-4.9.1-focus.patch
new file mode 100644
index 000000000000..4fdbdb0679cf
--- /dev/null
+++ b/kde-base/konqueror/files/konqueror-4.9.1-focus.patch
@@ -0,0 +1,43 @@
+commit 5fa3dbc49f8cac8253e198298948832ca7d38674
+Author: Dawit Alemayehu <adawit@kde.org>
+Date: Wed Sep 5 03:14:52 2012 -0400
+
+ Fix commit a2ae8003352442efdb5731b3fd3de3107b0c1e99. :(
+
+ Do not attempt to change focus when the active view is not the current one.
+ Fixes location bar address being changed when opening URLs in a background tab.
+
+diff --git a/konqueror/src/konqview.cpp b/konqueror/src/konqview.cpp
+index 0130292..2ee9896 100644
+--- a/konqueror/src/konqview.cpp
++++ b/konqueror/src/konqview.cpp
+@@ -518,19 +518,20 @@ void KonqView::slotRequestFocus( KParts::ReadOnlyPart * )
+ void KonqView::setLoading( bool loading, bool hasPending /*= false*/)
+ {
+ //kDebug() << "loading=" << loading << "hasPending=" << hasPending;
+- if (loading) {
++ m_bLoading = loading;
++ m_bPendingRedirection = hasPending;
++ if ( m_pMainWindow->currentView() == this ) {
++ m_pMainWindow->updateToolBarActions( hasPending );
+ // Make sure the focus is restored on the part's widget and not the combo
+ // box if it starts loading a request. See #304933.
+- QWidget* partWidget = (m_pPart ? m_pPart->widget() : 0);
+- if (partWidget && !partWidget->hasFocus()) {
+- //kDebug() << "SET FOCUS on the widget";
+- partWidget->setFocus();
++ if (loading) {
++ QWidget* partWidget = (m_pPart ? m_pPart->widget() : 0);
++ if (partWidget && !partWidget->hasFocus()) {
++ //kDebug() << "SET FOCUS on the widget";
++ partWidget->setFocus();
++ }
+ }
+ }
+- m_bLoading = loading;
+- m_bPendingRedirection = hasPending;
+- if ( m_pMainWindow->currentView() == this )
+- m_pMainWindow->updateToolBarActions( hasPending );
+
+ m_pMainWindow->viewManager()->setLoading( this, loading || hasPending );
+ }
diff --git a/kde-base/konqueror/konqueror-4.9.1.ebuild b/kde-base/konqueror/konqueror-4.9.1-r1.ebuild
index 5950018dca7b..2c97d121784b 100644
--- a/kde-base/konqueror/konqueror-4.9.1.ebuild
+++ b/kde-base/konqueror/konqueror-4.9.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/konqueror/konqueror-4.9.1.ebuild,v 1.1 2012/09/04 18:45:02 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konqueror/konqueror-4.9.1-r1.ebuild,v 1.1 2012/09/10 11:05:43 johu Exp $
EAPI=4
@@ -29,6 +29,8 @@ KMEXTRACTONLY="
lib/konq/
"
+PATCHES=( "${FILESDIR}/${P}-focus.patch" )
+
src_prepare() {
[[ ${CHOST} == *-solaris* ]] && append-ldflags -lmalloc