summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-07-25 18:20:37 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-07-25 18:20:37 +0000
commit83dced1b2264fb0c02f58a1258a09d120f274e07 (patch)
tree4a3af1d25ac8bfc23a19f9527bc453516193b537 /kde-base
parentStable on hppa. (diff)
downloadgentoo-2-83dced1b2264fb0c02f58a1258a09d120f274e07.tar.gz
gentoo-2-83dced1b2264fb0c02f58a1258a09d120f274e07.tar.bz2
gentoo-2-83dced1b2264fb0c02f58a1258a09d120f274e07.zip
Fix forwarding using templates, a crash fix, other issues. KDE bugs 125920, 146534, 140549.
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmail/ChangeLog8
-rw-r--r--kde-base/kmail/files/digest-kmail-3.5.7-r26
-rw-r--r--kde-base/kmail/kmail-3.5.7-r2.ebuild68
3 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 04a19b630d03..ed9c75d79e24 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.112 2007/07/10 05:45:11 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.113 2007/07/25 18:20:37 carlo Exp $
+
+*kmail-3.5.7-r2 (25 Jul 2007)
+
+ 25 Jul 2007; Carsten Lohrke <carlo@gentoo.org> +kmail-3.5.7-r2.ebuild:
+ Fix forwarding using templates, a crash fix, other issues. KDE bugs 125920,
+ 146534, 140549.
*kmail-3.5.7-r1 (10 Jul 2007)
diff --git a/kde-base/kmail/files/digest-kmail-3.5.7-r2 b/kde-base/kmail/files/digest-kmail-3.5.7-r2
new file mode 100644
index 000000000000..c779ca922394
--- /dev/null
+++ b/kde-base/kmail/files/digest-kmail-3.5.7-r2
@@ -0,0 +1,6 @@
+MD5 bf6b46337388fa6a93c9084d3d2c4509 kdepim-3.5-patchset-04.tar.bz2 133990
+RMD160 9d9fd1e7b04512f1f28bba78d5eeadfc3e3280ba kdepim-3.5-patchset-04.tar.bz2 133990
+SHA256 8b1968a7bef8ab2efdb2d87e96943ce636775b76365bc1bc99e1e377f9abfc61 kdepim-3.5-patchset-04.tar.bz2 133990
+MD5 8571db6dcf4168614c96bb72c493f931 kdepim-3.5.7.tar.bz2 14166061
+RMD160 14c05d4620abf1eb5421ad434dc63f037069e930 kdepim-3.5.7.tar.bz2 14166061
+SHA256 9d981d372f1822662e102b6f84f046e4df771641fc4d041aae81b8fafd47b32e kdepim-3.5.7.tar.bz2 14166061
diff --git a/kde-base/kmail/kmail-3.5.7-r2.ebuild b/kde-base/kmail/kmail-3.5.7-r2.ebuild
new file mode 100644
index 000000000000..5b7e5e3dc6cd
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.7-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.7-r2.ebuild,v 1.1 2007/07/25 18:20:37 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
+
+RESTRICT="test"
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+ $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+ $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+ $(deprange $PV $MAXKDEVER kde-base/mimelib)
+ $(deprange $PV $MAXKDEVER kde-base/libksieve)
+ $(deprange $PV $MAXKDEVER kde-base/certmanager)
+ $(deprange $PV $MAXKDEVER kde-base/libkcal)
+ $(deprange $PV $MAXKDEVER kde-base/kontact)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/libkpgp)
+ $(deprange $PV $MAXKDEVER kde-base/libkmime)"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+ $(deprange 3.5.5 $MAXKDEVER kde-base/kmailcvt)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_install() {
+ kde-meta_src_install
+ # Install KMail icons with libkdepim to work around bug #136810.
+ #find ${D}/${KDEDIR}/share/icons/hicolor/ -name "kmail\.png" -exec rm '{}' \;
+ rm ${D}/${KDEDIR}/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128}/apps/kmail.png || die "bääh"
+}