summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-01-20 10:57:31 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-01-20 10:57:31 +0000
commit7cbc5d128c6ce0d20d1790b7f413ab5ae5eb609c (patch)
treec5fe8407eabf6ea948b0cee22764bcef42d2c429 /kde-base
parentAdd back -O0 optimization since this may fix crashes with the C-based lexers. (diff)
downloadgentoo-2-7cbc5d128c6ce0d20d1790b7f413ab5ae5eb609c.tar.gz
gentoo-2-7cbc5d128c6ce0d20d1790b7f413ab5ae5eb609c.tar.bz2
gentoo-2-7cbc5d128c6ce0d20d1790b7f413ab5ae5eb609c.zip
Remove unused patch.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/dolphin/ChangeLog6
-rw-r--r--kde-base/dolphin/files/dolphin-4.11.3-regression.patch61
2 files changed, 5 insertions, 62 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 8abeaf203f8d..646566e4f004 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.222 2014/01/20 08:00:13 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.223 2014/01/20 10:57:31 kensington Exp $
+
+ 20 Jan 2014; Michael Palimaka <kensington@gentoo.org>
+ -files/dolphin-4.11.3-regression.patch:
+ Remove unused patch.
20 Jan 2014; Michael Palimaka <kensington@gentoo.org> dolphin-4.11.5.ebuild:
Restore keywords that were accidentally omitted.
diff --git a/kde-base/dolphin/files/dolphin-4.11.3-regression.patch b/kde-base/dolphin/files/dolphin-4.11.3-regression.patch
deleted file mode 100644
index d27c176faa27..000000000000
--- a/kde-base/dolphin/files/dolphin-4.11.3-regression.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-commit 1c856e44774a7ce8eb6dce6828ef689647f83ca4
-Author: Wolfgang Bauer <wbauer@tmo.at>
-Date: Wed Nov 6 16:46:09 2013 +0100
-
- Revert "Files passed as arguments: Ignore unsupported files"
-
- This reverts commit cd9e50ae4f3ded5a78d0cfb09a67684a9c15d726.
-
- See bug#327224 for details.
-
-diff --git a/dolphin/src/dolphinmainwindow.cpp b/dolphin/src/dolphinmainwindow.cpp
-index 9da73f9..b477600 100644
---- a/dolphin/src/dolphinmainwindow.cpp
-+++ b/dolphin/src/dolphinmainwindow.cpp
-@@ -31,7 +31,6 @@
- #include "panels/information/informationpanel.h"
- #include "settings/dolphinsettingsdialog.h"
- #include "statusbar/dolphinstatusbar.h"
--#include "views/dolphinview.h"
- #include "views/dolphinviewactionhandler.h"
- #include "views/dolphinremoteencoding.h"
- #include "views/draganddrophelper.h"
-@@ -244,20 +243,8 @@ void DolphinMainWindow::openDirectories(const QList<KUrl>& dirs)
- return;
- }
-
-- // dirs could contain URLs that actually point to archives or other files.
-- // Replace them by URLs we can open where possible and filter the rest out.
-- QList<KUrl> urlsToOpen;
-- foreach (const KUrl& rawUrl, dirs) {
-- const KFileItem& item = KFileItem(KFileItem::Unknown, KFileItem::Unknown, rawUrl);
-- item.determineMimeType();
-- const KUrl& url = DolphinView::openItemAsFolderUrl(item);
-- if (!url.isEmpty()) {
-- urlsToOpen.append(url);
-- }
-- }
--
-- if (urlsToOpen.count() == 1) {
-- m_activeViewContainer->setUrl(urlsToOpen.first());
-+ if (dirs.count() == 1) {
-+ m_activeViewContainer->setUrl(dirs.first());
- return;
- }
-
-@@ -267,12 +254,12 @@ void DolphinMainWindow::openDirectories(const QList<KUrl>& dirs)
-
- // Open each directory inside a new tab. If the "split view" option has been enabled,
- // always show two directories within one tab.
-- QList<KUrl>::const_iterator it = urlsToOpen.begin();
-- while (it != urlsToOpen.end()) {
-+ QList<KUrl>::const_iterator it = dirs.begin();
-+ while (it != dirs.end()) {
- openNewTab(*it);
- ++it;
-
-- if (hasSplitView && (it != urlsToOpen.end())) {
-+ if (hasSplitView && (it != dirs.end())) {
- const int tabIndex = m_viewTab.count() - 1;
- m_viewTab[tabIndex].secondaryView->setUrl(*it);
- ++it;