summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-27 19:33:43 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-27 19:33:43 +0000
commit7300873e43fa655b17f08dce5b4e6021efd119be (patch)
tree4cd25edbff0f904326e2a638087115d4e4de872a /kde-base
parentmasking kde 3.0.2 (diff)
downloadgentoo-2-7300873e43fa655b17f08dce5b4e6021efd119be.tar.gz
gentoo-2-7300873e43fa655b17f08dce5b4e6021efd119be.tar.bz2
gentoo-2-7300873e43fa655b17f08dce5b4e6021efd119be.zip
kde 3.0.2. not officially released yet. in testing by me and verwilst as usual.
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/arts-1.0.2.ebuild37
-rw-r--r--kde-base/kde/kde-3.0.2.ebuild10
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.0.2.ebuild33
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.0.2.ebuild16
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.0.2.ebuild28
-rw-r--r--kde-base/kdebase/kdebase-3.0.2.ebuild87
-rw-r--r--kde-base/kdebindings/kdebindings-3.0.2.ebuild39
-rw-r--r--kde-base/kdeedu/kdeedu-3.0.2.ebuild37
-rw-r--r--kde-base/kdegames/kdegames-3.0.2.ebuild8
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.0.2.ebuild24
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.2.ebuild100
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.0.2.ebuild68
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.0.2.ebuild38
-rw-r--r--kde-base/kdepim/kdepim-3.0.2.ebuild20
-rw-r--r--kde-base/kdesdk/kdesdk-3.0.2.ebuild9
-rw-r--r--kde-base/kdetoys/kdetoys-3.0.2.ebuild11
-rw-r--r--kde-base/kdeutils/kdeutils-3.0.2.ebuild9
17 files changed, 574 insertions, 0 deletions
diff --git a/kde-base/arts/arts-1.0.2.ebuild b/kde-base/arts/arts-1.0.2.ebuild
new file mode 100644
index 000000000000..e320fc6b9a14
--- /dev/null
+++ b/kde-base/arts/arts-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-patch kde-base kde.org flag-o-matic
+
+SRC_URI="$SRC_URI ftp://ftp.kde.org/pub/kde/stable/3.0.1/src/${P}.tar.bz2"
+DESCRIPTION="KDE 3.x Sound Server"
+set-kdedir 3
+need-qt 3.0.3
+
+if [ "${COMPILER}" == "gcc3" ]; then
+# GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+# these.. Even starting a compile shuts down the arts server
+filter-flags "-fomit-frame-pointer -fstrength-reduce"
+
+fi
+
+SLOT="1"
+
+use alsa && myconf="$myconf --enable-alsa" || myconf="$myconf --disable-alsa"
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/soundserver
+
+}
+
+src_install() {
+
+ kde_src_install
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+}
diff --git a/kde-base/kde/kde-3.0.2.ebuild b/kde-base/kde/kde-3.0.2.ebuild
new file mode 100644
index 000000000000..5de48291ec65
--- /dev/null
+++ b/kde-base/kde/kde-3.0.2.ebuild
@@ -0,0 +1,10 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+DESCRIPTION="KDE 3.0 - merge this to pull in all non-developer kde-base/* packages"
+HOMEPAGE="http://www.kde.org/"
+# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
+RDEPEND=`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`
+
diff --git a/kde-base/kdeaddons/kdeaddons-3.0.2.ebuild b/kde-base/kdeaddons/kdeaddons-3.0.2.ebuild
new file mode 100644
index 000000000000..1adafe8103d8
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Addons"
+
+newdepend ">=kde-base/kdebase-${PV}
+ >=kde-base/kdenetwork-${PV}
+ >=kde-base/kdemultimedia-${PV}
+ sdl? ( >=media-libs/libsdl-1.2 )
+ svga? ( media-libs/svgalib )"
+
+use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+# This is a fix used for a makefile/linking problem when destdir=!kdelibsdir. I haven't tested it
+# with 3.0.1, don't know if it's still necessary.
+#src_unpack() {
+#
+# base_src_unpack
+#
+# cd ${S}/noatun-plugins
+# for x in `find -iname Makefile.am` `find -iname Makefile.in`; do
+# echo "(Maybe) patching ${x}..."
+# cp ${x} ${x}2
+# sed -e "s:\$(kde_libraries)/libnoatun.so:${KDEDIR}/lib/libnoatun.so:" ${x}2 > ${x}
+# rm ${x}2
+# done
+#
+#}
+
diff --git a/kde-base/kdeadmin/kdeadmin-3.0.2.ebuild b/kde-base/kdeadmin/kdeadmin-3.0.2.ebuild
new file mode 100644
index 000000000000..22ae78353058
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.0.2.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Administration"
+
+newdepend ">=app-arch/rpm-4.0.4-r1
+ dev-libs/popt
+ pam? ( >=sys-libs/pam-0.72 )"
+
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --without-pam --with-shadow"
+myconf="$myconf --with-rpm"
+
diff --git a/kde-base/kdeartwork/kdeartwork-3.0.2.ebuild b/kde-base/kdeartwork/kdeartwork-3.0.2.ebuild
new file mode 100644
index 000000000000..9595d1636837
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+newdepend "opengl? ( virtual/opengl ) >=kde-base/kdebase-${PV}"
+
+DESCRIPTION="${DESCRIPTION}Artwork"
+
+myconf="$myconf --with-dpms"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+
+src_unpack() {
+
+ base_src_unpack
+
+ cd ${S}
+ # added to fix GL problems within xscreensavers
+ patch -p1 < ${FILESDIR}/kdeartwork-screensaver.patch
+
+}
+
+src_install() {
+ dodir ${KDEDIR}/share/apps/kthememgr/Themes
+ kde_src_install all
+}
diff --git a/kde-base/kdebase/kdebase-3.0.2.ebuild b/kde-base/kdebase/kdebase-3.0.2.ebuild
new file mode 100644
index 000000000000..ba468074ba15
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.0.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ media-sound/cdparanoia
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-3.0,kde-2.2.2,:' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}
diff --git a/kde-base/kdebindings/kdebindings-3.0.2.ebuild b/kde-base/kdebindings/kdebindings-3.0.2.ebuild
new file mode 100644
index 000000000000..1295a0c4bfe3
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+# TODO: add gnustep bindings
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Bindings"
+
+newdepend ">=kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ >=kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+src_unpack()
+{
+ base_src_unpack
+
+ if [ -z "`use mozilla`" ]; then
+ # disable mozilla bindings/xpart
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+ chmod +x configure
+ fi
+} \ No newline at end of file
diff --git a/kde-base/kdeedu/kdeedu-3.0.2.ebuild b/kde-base/kdeedu/kdeedu-3.0.2.ebuild
new file mode 100644
index 000000000000..5abdc7b3d9c3
--- /dev/null
+++ b/kde-base/kdeedu/kdeedu-3.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/kdeedu-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Educational"
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/klettres/klettres
+
+}
+
+src_compile() {
+
+ # build fails with -fomit-frame-pointer optimization in kgeo
+
+ CFLAGS2="$CFLAGS"
+ CXXFLAGS2="$CXXFLAGS"
+ CFLAGS=${CFLAGS/-fomit-frame-pointer}
+ CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+
+ kde_src_compile myconf configure
+
+ cd ${S}/kgeo
+ emake || die
+
+ CFLAGS="$CFLAGS2"
+ CXXFLAGS="$CXXFLAGS2"
+
+ kde_src_compile all
+
+}
diff --git a/kde-base/kdegames/kdegames-3.0.2.ebuild b/kde-base/kdegames/kdegames-3.0.2.ebuild
new file mode 100644
index 000000000000..9cc7a107f204
--- /dev/null
+++ b/kde-base/kdegames/kdegames-3.0.2.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegames/kdegames-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Games"
diff --git a/kde-base/kdegraphics/kdegraphics-3.0.2.ebuild b/kde-base/kdegraphics/kdegraphics-3.0.2.ebuild
new file mode 100644
index 000000000000..e7fc89cdc58a
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Graphics"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ media-gfx/sane-backends
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib"
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin "
+
diff --git a/kde-base/kdelibs/kdelibs-3.0.2.ebuild b/kde-base/kdelibs/kdelibs-3.0.2.ebuild
new file mode 100644
index 000000000000..1c4de0986c37
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.0.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE ${PV} - Libraries"
+HOMEPAGE="http//www.kde.org/"
+
+SLOT="3"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ >=kde-base/arts-1.0.1
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+myconf="$myconf --enable-final --with-distribution=Gentoo"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+ if [ "$KDE3DIR" != "$KDE3LIBSDIR" ]; then
+echo "PATH=${KDE3LIBSDIR}/bin:${KDE3DIR}/bin
+ROOTPATH=${KDE3LIBSDIR}/bin:${KDE3DIR}/bin
+LDPATH=${KDE3LIBSDIR}/lib:${KDE3DIR}/lib" > ${D}/etc/env.d/65kdelibs-${PV}
+ else
+echo "PATH=${KDE3LIBSDIR}/bin
+ROOTPATH=${KDE3LIBSDIR}/bin
+LDPATH=${KDE3LIBSDIR}/lib" > ${D}/etc/env.d/65kdelibs-${PV}
+ fi
+
+ echo "KDEDIR=${KDE3DIR}" > ${D}/etc/env.d/50kdedir-${PV}
+
+ dodir /usr/qt/3
+ cd ${D}
+ mv ./${KDEDIR}/lib/kde3/plugins ./usr/qt/3
+ dosym /usr/qt/3/plugins /${KDEDIR}/lib/kde3/plugins
+
+}
+
+
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.0.2.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.0.2.ebuild
new file mode 100644
index 000000000000..af5aa2c63afc
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.0.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="${DESCRIPTION}Multimedia"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ app-cdr/cdrtools
+ >=app-cdr/cdrdao-1.1.5
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )"
+# alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses"
+
+#use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" ||
+myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+
+myconf="$myconf $myaudio $myinterface"
+
+src_unpack() {
+
+ base_src_unpack
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo-timidity.diff || die
+# use alsa && patch -p0 < ${FILESDIR}/${P}-gentoo-alsa.diff
+
+ kde_sandbox_patch ${S}/kmidi/config
+
+ cd ${S}/kmidi/config
+ for x in Makefile.am Makefile.in; do
+ mv $x $x.orig
+ sed -e 's:TIMID_DIR = $(DESTDIR)/$(kde_datadir):TIMID_DIR = $(kde_datadir):g' $x.orig > $x
+ done
+
+}
+
+pkg_postinst() {
+
+ if [ -n "`use alsa`" ]; then
+ einfo "WARNING: alsa support has been removed becuase of a bug in kdemm sources.
+For further information see bug #2324 on bugs.gentoo.org and bug #39574 on bugs.kde.org.
+Meanwhile, you can use the alsa oss emulation."
+ fi
+ return 0
+
+}
diff --git a/kde-base/kdenetwork/kdenetwork-3.0.2.ebuild b/kde-base/kdenetwork/kdenetwork-3.0.2.ebuild
new file mode 100644
index 000000000000..f7c9ede591cb
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Network"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.bz2
+
+ kde_sandbox_patch ${S}/kppp
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ chmod +s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settinsg
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+}
+
diff --git a/kde-base/kdepim/kdepim-3.0.2.ebuild b/kde-base/kdepim/kdepim-3.0.2.ebuild
new file mode 100644
index 000000000000..07342e611d75
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}PIM"
+
+DEPEND="$DEPEND sys-devel/perl"
+
+newdepend "pda? ( >=dev-libs/pilot-link-0.9.0 )"
+
+use pda && myconf="$myconf --with-extra-includes=/usr/include/libpisock"
+
+src_install() {
+ kde_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/kde-base/kdesdk/kdesdk-3.0.2.ebuild b/kde-base/kdesdk/kdesdk-3.0.2.ebuild
new file mode 100644
index 000000000000..42fa85d33610
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-3.0.2.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}SDK"
+
diff --git a/kde-base/kdetoys/kdetoys-3.0.2.ebuild b/kde-base/kdetoys/kdetoys-3.0.2.ebuild
new file mode 100644
index 000000000000..62dd6ff5dbc7
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-3.0.2.ebuild
@@ -0,0 +1,11 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Toys"
+
+
diff --git a/kde-base/kdeutils/kdeutils-3.0.2.ebuild b/kde-base/kdeutils/kdeutils-3.0.2.ebuild
new file mode 100644
index 000000000000..c3d2adf89dee
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.0.2.ebuild
@@ -0,0 +1,9 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Utilities"
+