summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 08:33:43 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 08:33:43 +0000
commit617f6770073e99494d68a2ed34d2aeddd1fc5837 (patch)
treee49be3f8bac77e50761b15f7d84da9f8267644e9 /kde-base
parentRemove old versions (diff)
downloadgentoo-2-617f6770073e99494d68a2ed34d2aeddd1fc5837.tar.gz
gentoo-2-617f6770073e99494d68a2ed34d2aeddd1fc5837.tar.bz2
gentoo-2-617f6770073e99494d68a2ed34d2aeddd1fc5837.zip
Add KDE 4.2.2
(Portage version: 2.2_rc29/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.2.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 16dde5792fa6..260e84f36fca 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.117 2009/04/11 20:25:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.118 2009/04/12 08:33:43 alexxy Exp $
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> kalzium-4.2.1.ebuild:
Add ~alpha/~ia64
+*kalzium-4.2.2 (11 Apr 2009)
+
+ 11 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.2.2.ebuild:
+ Add KDE 4.2.2
+
15 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org> kalzium-4.2.1.ebuild:
Merge missed ebuild from kde-testing.
diff --git a/kde-base/kalzium/kalzium-4.2.2.ebuild b/kde-base/kalzium/kalzium-4.2.2.ebuild
new file mode 100644
index 000000000000..430def552bf2
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.2.2.ebuild,v 1.1 2009/04/12 08:33:43 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug doc +plasma solver"
+
+COMMON_DEPEND="
+ >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-1.0.5 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+PATCHES=( "${FILESDIR}/${P}-include-order.patch" )
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}