summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-04-09 13:58:19 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-04-09 13:58:19 +0000
commit5433b5d7013f4d40eb3070564ed8443a5e159ee3 (patch)
treee56629022da6de75b3bbd405677fb3202d56f91f /kde-base
parentStable for HPPA (bug #459722). (diff)
downloadgentoo-2-5433b5d7013f4d40eb3070564ed8443a5e159ee3.tar.gz
gentoo-2-5433b5d7013f4d40eb3070564ed8443a5e159ee3.tar.bz2
gentoo-2-5433b5d7013f4d40eb3070564ed8443a5e159ee3.zip
Backport patch from upstream to fix build with speech-dispatcher-0.8, wrt bug #463620.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/jovie/ChangeLog7
-rw-r--r--kde-base/jovie/files/jovie-4.10.1-speechd-0.8.patch40
-rw-r--r--kde-base/jovie/jovie-4.10.2.ebuild4
3 files changed, 49 insertions, 2 deletions
diff --git a/kde-base/jovie/ChangeLog b/kde-base/jovie/ChangeLog
index 36c3712b2510..c5c9175bbb30 100644
--- a/kde-base/jovie/ChangeLog
+++ b/kde-base/jovie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/jovie
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/jovie/ChangeLog,v 1.87 2013/04/06 00:04:25 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/jovie/ChangeLog,v 1.88 2013/04/09 13:58:19 kensington Exp $
+
+ 09 Apr 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/jovie-4.10.1-speechd-0.8.patch, jovie-4.10.2.ebuild:
+ Backport patch from upstream to fix build with speech-dispatcher-0.8, wrt bug
+ #463620.
*jovie-4.10.2 (05 Apr 2013)
diff --git a/kde-base/jovie/files/jovie-4.10.1-speechd-0.8.patch b/kde-base/jovie/files/jovie-4.10.1-speechd-0.8.patch
new file mode 100644
index 000000000000..743b4e2acc75
--- /dev/null
+++ b/kde-base/jovie/files/jovie-4.10.1-speechd-0.8.patch
@@ -0,0 +1,40 @@
+From e31b78b183c7c8a74f5bae8974e00daad5f581a3 Mon Sep 17 00:00:00 2001
+From: Sven-Hendrik Haase <sh@lutzhaase.com>
+Date: Thu, 4 Apr 2013 06:27:43 +0159
+Subject: [PATCH] Support for Speechd 0.8 in CMake
+
+Reviewed-by: Jeremy Whiting
+BUG: 317758
+FIXED-IN: 4.10.3
+---
+ cmake/FindSpeechd.cmake | 2 +-
+ jovie/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/FindSpeechd.cmake b/cmake/FindSpeechd.cmake
+index cf78d32..0902cdd 100644
+--- a/cmake/FindSpeechd.cmake
++++ b/cmake/FindSpeechd.cmake
+@@ -9,7 +9,7 @@
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+-find_path(SPEECHD_INCLUDE_DIR libspeechd.h)
++find_path(SPEECHD_INCLUDE_DIR libspeechd.h PATH_SUFFIXES speech-dispatcher)
+
+ find_library(SPEECHD_LIBRARIES NAMES speechd)
+
+diff --git a/jovie/CMakeLists.txt b/jovie/CMakeLists.txt
+index bd9dcfc..f3191d4 100644
+--- a/jovie/CMakeLists.txt
++++ b/jovie/CMakeLists.txt
+@@ -1,5 +1,5 @@
+
+-include_directories( /usr/local/include ${CMAKE_SOURCE_DIR}/jovie/libkttsd )
++include_directories( /usr/local/include ${CMAKE_SOURCE_DIR}/jovie/libkttsd ${SPEECHD_INCLUDE_DIR} )
+
+ add_definitions(-DKDE_DEFAULT_DEBUG_AREA=2400)
+
+--
+1.8.1.5
+
diff --git a/kde-base/jovie/jovie-4.10.2.ebuild b/kde-base/jovie/jovie-4.10.2.ebuild
index a2d4c4ab80c9..e5ebd501dae5 100644
--- a/kde-base/jovie/jovie-4.10.2.ebuild
+++ b/kde-base/jovie/jovie-4.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/jovie/jovie-4.10.2.ebuild,v 1.1 2013/04/06 00:04:25 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/jovie/jovie-4.10.2.ebuild,v 1.2 2013/04/09 13:58:19 kensington Exp $
EAPI=5
@@ -15,3 +15,5 @@ DEPEND="
app-accessibility/speech-dispatcher
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.10.1-speechd-0.8.patch" )