summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:11 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:11 +0000
commit5380343c450e03a1a43434763b7aa1619976abf5 (patch)
treef2340899f5495b0d03d545b027cf4b30395f09cf /kde-base
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-5380343c450e03a1a43434763b7aa1619976abf5.tar.gz
gentoo-2-5380343c450e03a1a43434763b7aa1619976abf5.tar.bz2
gentoo-2-5380343c450e03a1a43434763b7aa1619976abf5.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-3.5.9.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index feff4d8c4632..f824b3fafa64 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.56 2008/02/20 18:51:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.57 2008/02/20 23:36:11 philantrop Exp $
+
+*smoke-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +smoke-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
20 Feb 2008; Raúl Porcel <armin76@gentoo.org> smoke-3.5.8.ebuild:
sparc stable wrt #210666
diff --git a/kde-base/smoke/smoke-3.5.9.ebuild b/kde-base/smoke/smoke-3.5.9.ebuild
new file mode 100644
index 000000000000..8a04718ed21f
--- /dev/null
+++ b/kde-base/smoke/smoke-3.5.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-3.5.9.ebuild,v 1.1 2008/02/20 23:36:11 philantrop Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="kalyptus/"
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine: a language-agnostic bindings generator for qt and kde"
+HOMEPAGE="http://developer.kde.org/language-bindings/smoke/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ x11-libs/qscintilla" # QScintilla is an optional dep, there's a configure
+ # flag for it, but I don't want to introduce a local
+ # noqscintilla use flag as it's a light dep.
+ # Of course it'd be nice if someone told me what the difference
+ # is between a smoke compiled with and without qscintilla
+ # support. --danarmak
+
+PATCHES="${FILESDIR}/no-gtk-glib-check.diff"
+
+# enable-final works, but requires at least 1.5GB of RAM to complete without swapping,
+# so it's best to turn it off here. (I don't have that much RAM, so can't estimate
+# how much would be enough, but it's at least that much... --danarmak)
+src_compile() {
+ # Remove this to avoid strange errors
+ rm -f "${S}/kalyptus/configure.in"
+
+ kde-meta_src_compile myconf
+ # override myconf's setting of enable-final
+ myconf="$myconf --disable-final"
+
+ # Needs patch to fix paralell building again
+ MAKEOPTS="$MAKEOPTS -j1"
+
+ kde-meta_src_compile configure make
+}