summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-06 07:40:14 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-06 07:40:14 +0000
commit492bbf23b579d94add4b1021dbd20983d23b0744 (patch)
tree4394e5ce5a5ac7ccecd7482f60e430ff4188f82e /kde-base
parentStart akonadi asynchronously on kde-4.6, bug 362199 (diff)
downloadgentoo-2-492bbf23b579d94add4b1021dbd20983d23b0744.tar.gz
gentoo-2-492bbf23b579d94add4b1021dbd20983d23b0744.tar.bz2
gentoo-2-492bbf23b579d94add4b1021dbd20983d23b0744.zip
Start akonadi asynchronously on kde-4.6, bug 362199
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmail/ChangeLog8
-rw-r--r--kde-base/kmail/files/kmail-4.4.10-asyncako.patch53
-rw-r--r--kde-base/kmail/kmail-4.4.10-r1.ebuild84
3 files changed, 144 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 6d79db60e9f8..f71274c1e6ba 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.242 2011/03/24 23:59:13 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.243 2011/04/06 07:40:14 dilfridge Exp $
+
+*kmail-4.4.10-r1 (06 Apr 2011)
+
+ 06 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmail-4.4.10-r1.ebuild, +files/kmail-4.4.10-asyncako.patch:
+ Start akonadi asynchronously on kde-4.6, bug 362199
24 Mar 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-kmail-4.4.5.ebuild:
diff --git a/kde-base/kmail/files/kmail-4.4.10-asyncako.patch b/kde-base/kmail/files/kmail-4.4.10-asyncako.patch
new file mode 100644
index 000000000000..b8c07165de72
--- /dev/null
+++ b/kde-base/kmail/files/kmail-4.4.10-asyncako.patch
@@ -0,0 +1,53 @@
+commit cfa404b7188e4c26bddbc9579728f6d25f8cd214
+Author: Stephen Kelly <steveire@gmail.com>
+Date: Tue Apr 5 11:09:43 2011 +0200
+
+ Start kdepim 4.4 asynchronously if built against 4.6.
+
+ The synchronous mechanism doesn't have enough time to start
+ before it reports failure.
+
+diff --git a/kmail/kmmainwidget.cpp b/kmail/kmmainwidget.cpp
+index a31973a..10b14e4 100644
+--- a/kmail/kmmainwidget.cpp
++++ b/kmail/kmmainwidget.cpp
+@@ -165,6 +165,9 @@ using KMail::TemplateParser;
+
+ #include <errno.h> // ugh
+
++#include <akonadi/control.h>
++#include <akonadi/servermanager.h>
++
+ #include "kmmainwidget.moc"
+
+ K_GLOBAL_STATIC( KMMainWidget::PtrList, theMainWidgetList )
+@@ -186,6 +189,10 @@ KMMainWidget::KMMainWidget( QWidget *parent, KXMLGUIClient *aGUIClient,
+ mVacationIndicatorActive( false ),
+ mGoToFirstUnreadMessageInSelectedFolder( false )
+ {
++#if KDE_IS_VERSION(4,6,0)
++ Akonadi::Control::widgetNeedsAkonadi(this);
++ Akonadi::ServerManager::start();
++#endif
+ // must be the first line of the constructor:
+ mStartupDone = false;
+ mWasEverShown = false;
+diff --git a/kmail/main.cpp b/kmail/main.cpp
+index f39ca5f..c2dd1c3 100644
+--- a/kmail/main.cpp
++++ b/kmail/main.cpp
+@@ -145,12 +145,14 @@ int main(int argc, char *argv[])
+ app.setEventLoopReached();
+ app.delayedInstanceCreation();
+
++#if !KDE_IS_VERSION(4,6,0)
+ // Start Akonadi
+ if ( !Akonadi::Control::start( kmkernel->getKMMainWidget() ) ) {
+ //TODO: add message box after string freeze
+ kWarning() << "Unable to start Akonadi server, exit application";
+ return 1;
+ }
++#endif
+
+ // Go!
+ int ret = qApp->exec();
diff --git a/kde-base/kmail/kmail-4.4.10-r1.ebuild b/kde-base/kmail/kmail-4.4.10-r1.ebuild
new file mode 100644
index 000000000000..8d5c3bfff122
--- /dev/null
+++ b/kde-base/kmail/kmail-4.4.10-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.4.10-r1.ebuild,v 1.1 2011/04/06 07:40:14 dilfridge Exp $
+
+EAPI="3"
+
+KMNAME="kdepim"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+ $(add_kdebase_dep libkpgp)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker messagecore
+add_blocker messagelist
+add_blocker messageviewer
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo/
+ libkpgp/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ messagecore/
+ messagelist/
+ messageviewer/
+ mimelib/
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.4.9-nodbus.patch"
+ "${FILESDIR}/${PN}-4.4.10-asyncako.patch"
+)
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ -DWITH_IndicateQt=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}