summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-16 12:13:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-16 12:13:42 +0000
commit3fc59f7605d612d527690bf976d779894e80854e (patch)
treedb0f0a06bb3ccbddca0dafbf199b423e044192d3 /kde-base
parentVersion Bump (diff)
downloadgentoo-2-3fc59f7605d612d527690bf976d779894e80854e.tar.gz
gentoo-2-3fc59f7605d612d527690bf976d779894e80854e.tar.bz2
gentoo-2-3fc59f7605d612d527690bf976d779894e80854e.zip
Fix building with libpng14 wrt #319901 by Howard B. Golden.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/ksplash/ChangeLog6
-rw-r--r--kde-base/ksplash/files/ksplash-4.3.5-libpng14.patch28
-rw-r--r--kde-base/ksplash/ksplash-4.3.5.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 68b8d579c561..67d0d52180b3 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.63 2010/05/03 22:01:47 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.64 2010/05/16 12:13:42 ssuominen Exp $
+
+ 16 May 2010; Samuli Suominen <ssuominen@gentoo.org> ksplash-4.3.5.ebuild,
+ +files/ksplash-4.3.5-libpng14.patch:
+ Fix building with libpng14 wrt #319901 by Howard B. Golden.
03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> -ksplash-4.4.1.ebuild:
Drop KDE SC 4.4.1
diff --git a/kde-base/ksplash/files/ksplash-4.3.5-libpng14.patch b/kde-base/ksplash/files/ksplash-4.3.5-libpng14.patch
new file mode 100644
index 000000000000..1077fdcc8f2b
--- /dev/null
+++ b/kde-base/ksplash/files/ksplash-4.3.5-libpng14.patch
@@ -0,0 +1,28 @@
+http://bugs.gentoo.org/319901
+
+--- ksplash/ksplashx/qpngio.cpp
++++ ksplash/ksplashx/qpngio.cpp
+@@ -151,7 +151,11 @@
+ image.setColor( i, qRgba(c,c,c,0xff) );
+ }
+ if ( png_get_valid(png_ptr, info_ptr, PNG_INFO_tRNS) ) {
++ #if PNG_LIBPNG_VER < 10400
+ const int g = info_ptr->trans_values.gray;
++ #else
++ const int g = info_ptr->trans_color.gray;
++ #endif
+ if (g < ncols) {
+ image.setAlphaBuffer(true);
+ image.setColor(g, image.color(g) & RGB_MASK);
+@@ -179,7 +183,11 @@
+ info_ptr->palette[i].red,
+ info_ptr->palette[i].green,
+ info_ptr->palette[i].blue,
++ #if PNG_LIBPNG_VER < 10400
+ info_ptr->trans[i]
++ #else
++ info_ptr->trans_alpha[i]
++ #endif
+ )
+ );
+ i++;
diff --git a/kde-base/ksplash/ksplash-4.3.5.ebuild b/kde-base/ksplash/ksplash-4.3.5.ebuild
index 74e633497b29..0130c2bd0962 100644
--- a/kde-base/ksplash/ksplash-4.3.5.ebuild
+++ b/kde-base/ksplash/ksplash-4.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.3.5.ebuild,v 1.3 2010/03/11 18:36:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.3.5.ebuild,v 1.4 2010/05/16 12:13:42 ssuominen Exp $
EAPI="2"
@@ -20,6 +20,8 @@ DEPEND="${COMMONDEPEND}
"
RDEPEND="${COMMONDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-libpng14.patch" )
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_has 3dnow X86_3DNOW)